diff options
author | Gianfranco Costamagna <gianfranco.costamagna@abinsula.com> | 2017-10-03 09:18:08 +0200 |
---|---|---|
committer | Otavio Salvador <otavio@ossystems.com.br> | 2017-10-03 18:56:41 -0300 |
commit | 16e54fde6943bb81e2c6aaf7f757570b04216fc8 (patch) | |
tree | 4474f07e473f07882dd36f8223fe1279864ae6aa /recipes-bsp/imx-uuc | |
parent | dc7e6d3923801d9ce16ca1f26fe1a2e651b53922 (diff) | |
download | meta-freescale-16e54fde6943bb81e2c6aaf7f757570b04216fc8.tar.gz |
imx-uuc: Fix missing build ldflags leading to QA issues
Signed-off-by: Gianfranco Costamagna <gianfranco.costamagna@abinsula.com>
Signed-off-by: Otavio Salvador <otavio@ossystems.com.br>
Diffstat (limited to 'recipes-bsp/imx-uuc')
-rw-r--r-- | recipes-bsp/imx-uuc/imx-uuc/0001-Fix-missing-build-flags-leading-to-yocto-QA-issues.patch | 44 | ||||
-rw-r--r-- | recipes-bsp/imx-uuc/imx-uuc_git.bb | 3 |
2 files changed, 46 insertions, 1 deletions
diff --git a/recipes-bsp/imx-uuc/imx-uuc/0001-Fix-missing-build-flags-leading-to-yocto-QA-issues.patch b/recipes-bsp/imx-uuc/imx-uuc/0001-Fix-missing-build-flags-leading-to-yocto-QA-issues.patch new file mode 100644 index 00000000..36ce2f06 --- /dev/null +++ b/recipes-bsp/imx-uuc/imx-uuc/0001-Fix-missing-build-flags-leading-to-yocto-QA-issues.patch | |||
@@ -0,0 +1,44 @@ | |||
1 | From bfdf01bfb462b21cf0a8f3e35d160b8ee4cea4ab Mon Sep 17 00:00:00 2001 | ||
2 | From: Gianfranco Costamagna <gianfranco.costamagna@abinsula.com> | ||
3 | Date: Tue, 3 Oct 2017 08:58:08 +0200 | ||
4 | Subject: [PATCH] Fix missing build flags, leading to yocto QA issues | ||
5 | |||
6 | ERROR: imx-uuc-0.5.1+gitAUTOINC+1de598e7b3-r0 do_package_qa: QA Issue: No GNU_HASH in the elf binary: 'imx-uuc/0.5.1+gitAUTOINC+1de598e7b3-r0/packages-split/imx-uuc/usr/bin/uuc' | ||
7 | No GNU_HASH in the elf binary: 'imx-uuc/0.5.1+gitAUTOINC+1de598e7b3-r0/packages-split/imx-uuc/usr/bin/sdimage' [ldflags] | ||
8 | |||
9 | similar issues have been reported on meta-freescale mail list too and then I'm attaching the Found-by/Signed-off-by flags correspondingly: | ||
10 | (the patches were against meta-freescale, I'm upstreaming them with some little changes) | ||
11 | https://lists.yoctoproject.org/pipermail/meta-freescale/2017-April/020355.html | ||
12 | |||
13 | Found-by: Gianfranco Costamagna <gianfranco.costamagna@abinsula.com> | ||
14 | Found-by: Joel Esponde <Joel.Esponde@Honeywell.com> | ||
15 | Signed-off-by: Bas Mevissen <bas.mevissen@emcodev.nl> | ||
16 | --- | ||
17 | Makefile | 5 +++-- | ||
18 | 1 file changed, 3 insertions(+), 2 deletions(-) | ||
19 | |||
20 | diff --git a/Makefile b/Makefile | ||
21 | index 5e2816c..1a8f51f 100644 | ||
22 | --- a/Makefile | ||
23 | +++ b/Makefile | ||
24 | @@ -1,14 +1,15 @@ | ||
25 | CC ?= $(CROSS_COMPILE)gcc | ||
26 | BINDIR ?= /usr/bin | ||
27 | PROGRAMS = uuc sdimage | ||
28 | +LIBS ?= -lpthread | ||
29 | |||
30 | all: $(PROGRAMS) | ||
31 | |||
32 | uuc: uu.c | ||
33 | - $(CC) $(CFLAGS) uu.c -o uuc -lpthread | ||
34 | + $(CC) $(CFLAGS) $(CPPFLAGS) uu.c -o uuc $(LDFLAGS) $(LIBS) | ||
35 | |||
36 | sdimage: sdimage.c | ||
37 | - $(CC) $(CFLAGS) sdimage.c -o sdimage | ||
38 | + $(CC) $(CFLAGS) $(CPPFLAGS) sdimage.c -o sdimage $(LDFLAGS) | ||
39 | |||
40 | install: | ||
41 | install -d $(DESTDIR)$(BINDIR) | ||
42 | -- | ||
43 | 2.11.0 | ||
44 | |||
diff --git a/recipes-bsp/imx-uuc/imx-uuc_git.bb b/recipes-bsp/imx-uuc/imx-uuc_git.bb index 8c1a81d7..a019fa17 100644 --- a/recipes-bsp/imx-uuc/imx-uuc_git.bb +++ b/recipes-bsp/imx-uuc/imx-uuc_git.bb | |||
@@ -10,7 +10,8 @@ inherit autotools-brokensep | |||
10 | 10 | ||
11 | PV = "0.5.1+git${SRCPV}" | 11 | PV = "0.5.1+git${SRCPV}" |
12 | 12 | ||
13 | SRC_URI = "git://github.com/NXPmicro/imx-uuc.git;protocol=https" | 13 | SRC_URI = "git://github.com/NXPmicro/imx-uuc.git;protocol=https \ |
14 | file://0001-Fix-missing-build-flags-leading-to-yocto-QA-issues.patch " | ||
14 | SRCREV = "1de598e7b36d95596435902106c9a746697b9afc" | 15 | SRCREV = "1de598e7b36d95596435902106c9a746697b9afc" |
15 | 16 | ||
16 | S = "${WORKDIR}/git" | 17 | S = "${WORKDIR}/git" |