diff options
author | Tom Hochstein <tom.hochstein@nxp.com> | 2018-07-27 11:52:56 -0500 |
---|---|---|
committer | Otavio Salvador <otavio@ossystems.com.br> | 2018-08-30 21:57:09 -0300 |
commit | d760297b9e8edafa7396edcfa9a014ec0101ceb7 (patch) | |
tree | fcdbe1263e5538a63e17d8c50a251d396e91ac68 /recipes-bsp/imx-test | |
parent | 851234ee9fd50e0fbe0f6815badfb4db199c092b (diff) | |
download | meta-freescale-d760297b9e8edafa7396edcfa9a014ec0101ceb7.tar.gz |
imx-test: Add i.MX 8 support
Signed-off-by: Tom Hochstein <tom.hochstein@nxp.com>
Signed-off-by: Otavio Salvador <otavio@ossystems.com.br>
Diffstat (limited to 'recipes-bsp/imx-test')
-rw-r--r-- | recipes-bsp/imx-test/imx-test/memtool_profile | 1 | ||||
-rw-r--r-- | recipes-bsp/imx-test/imx-test_git.bb | 33 |
2 files changed, 20 insertions, 14 deletions
diff --git a/recipes-bsp/imx-test/imx-test/memtool_profile b/recipes-bsp/imx-test/imx-test/memtool_profile new file mode 100644 index 00000000..97d6f614 --- /dev/null +++ b/recipes-bsp/imx-test/imx-test/memtool_profile | |||
@@ -0,0 +1 @@ | |||
complete -o nospace -C /unit_tests/memtool memtool | |||
diff --git a/recipes-bsp/imx-test/imx-test_git.bb b/recipes-bsp/imx-test/imx-test_git.bb index 0932d410..b0567dc1 100644 --- a/recipes-bsp/imx-test/imx-test_git.bb +++ b/recipes-bsp/imx-test/imx-test_git.bb | |||
@@ -8,34 +8,36 @@ SECTION = "base" | |||
8 | LICENSE = "GPLv2" | 8 | LICENSE = "GPLv2" |
9 | LIC_FILES_CHKSUM = "file://${COREBASE}/meta/files/common-licenses/GPL-2.0;md5=801f80980d171dd6425610833a22dbe6" | 9 | LIC_FILES_CHKSUM = "file://${COREBASE}/meta/files/common-licenses/GPL-2.0;md5=801f80980d171dd6425610833a22dbe6" |
10 | 10 | ||
11 | DEPENDS = "virtual/kernel imx-lib alsa-lib" | 11 | DEPENDS = "virtual/kernel alsa-lib libdrm" |
12 | DEPENDS_append_mx6 = " imx-lib" | ||
13 | DEPENDS_append_mx7 = " imx-lib" | ||
12 | 14 | ||
13 | PE = "1" | 15 | PE = "1" |
14 | PV = "7.0+${SRCPV}" | 16 | PV = "7.0+${SRCPV}" |
15 | 17 | ||
16 | SRCBRANCH = "imx_4.9.88_2.0.0_ga" | 18 | SRCBRANCH = "imx_4.9.88_imx8qxp_beta2" |
17 | SRCREV = "1f7da41b3a8d5dff8329d7b01b10d4d71144b43e" | ||
18 | SRC_URI = " \ | 19 | SRC_URI = " \ |
19 | git://source.codeaurora.org/external/imx/imx-test.git;protocol=https;branch=${SRCBRANCH} \ | 20 | git://source.codeaurora.org/external/imx/imx-test.git;protocol=https;branch=${SRCBRANCH} \ |
20 | file://0001-test-Makefile-Add-include-path-to-CC-command.patch \ | 21 | file://0001-test-Makefile-Add-include-path-to-CC-command.patch \ |
22 | file://memtool_profile \ | ||
21 | " | 23 | " |
22 | 24 | SRCREV = "3a87347ae408ef0234314a279ee74d9b015f06be" | |
23 | S = "${WORKDIR}/git" | 25 | S = "${WORKDIR}/git" |
24 | 26 | ||
25 | |||
26 | inherit module-base | 27 | inherit module-base |
27 | 28 | ||
28 | INHIBIT_PACKAGE_STRIP = "1" | 29 | INHIBIT_PACKAGE_STRIP = "1" |
29 | INHIBIT_PACKAGE_DEBUG_SPLIT = "1" | 30 | INHIBIT_PACKAGE_DEBUG_SPLIT = "1" |
30 | 31 | ||
31 | PLATFORM_mx6q = "IMX6Q" | 32 | PLATFORM_mx6q = "IMX6Q" |
32 | PLATFORM_mx6dl = "IMX6Q" | 33 | PLATFORM_mx6dl = "IMX6Q" |
33 | PLATFORM_mx6sl = "IMX6SL" | 34 | PLATFORM_mx6sl = "IMX6SL" |
34 | PLATFORM_mx6sll = "IMX6SL" | 35 | PLATFORM_mx6sll = "IMX6SL" |
35 | PLATFORM_mx6sx = "IMX6SX" | 36 | PLATFORM_mx6sx = "IMX6SX" |
36 | PLATFORM_mx6ul = "IMX6UL" | 37 | PLATFORM_mx6ul = "IMX6UL" |
37 | PLATFORM_mx7d = "IMX7D" | 38 | PLATFORM_mx7d = "IMX7D" |
38 | PLATFORM_mx7ulp = "IMX7D" | 39 | PLATFORM_mx7ulp = "IMX7D" |
40 | PLATFORM_mx8 = "IMX8" | ||
39 | 41 | ||
40 | PARALLEL_MAKE = "-j 1" | 42 | PARALLEL_MAKE = "-j 1" |
41 | EXTRA_OEMAKE += "${PACKAGECONFIG_CONFARGS}" | 43 | EXTRA_OEMAKE += "${PACKAGECONFIG_CONFARGS}" |
@@ -60,6 +62,7 @@ do_compile() { | |||
60 | -I${STAGING_KERNEL_DIR}/drivers/mxc/security/rng/include \ | 62 | -I${STAGING_KERNEL_DIR}/drivers/mxc/security/rng/include \ |
61 | -I${STAGING_KERNEL_DIR}/drivers/mxc/security/sahara2/include" \ | 63 | -I${STAGING_KERNEL_DIR}/drivers/mxc/security/sahara2/include" \ |
62 | CC="${CC} -L${STAGING_LIBDIR} ${LDFLAGS}" \ | 64 | CC="${CC} -L${STAGING_LIBDIR} ${LDFLAGS}" \ |
65 | SDKTARGETSYSROOT=${STAGING_DIR_HOST} \ | ||
63 | LINUXPATH=${STAGING_KERNEL_DIR} \ | 66 | LINUXPATH=${STAGING_KERNEL_DIR} \ |
64 | KBUILD_OUTPUT=${STAGING_KERNEL_BUILDDIR} \ | 67 | KBUILD_OUTPUT=${STAGING_KERNEL_BUILDDIR} \ |
65 | PLATFORM=${PLATFORM} | 68 | PLATFORM=${PLATFORM} |
@@ -73,10 +76,12 @@ do_install() { | |||
73 | if [ -e ${WORKDIR}/clocks.sh ]; then | 76 | if [ -e ${WORKDIR}/clocks.sh ]; then |
74 | install -m 755 ${WORKDIR}/clocks.sh ${D}/unit_tests/clocks.sh | 77 | install -m 755 ${WORKDIR}/clocks.sh ${D}/unit_tests/clocks.sh |
75 | fi | 78 | fi |
79 | install -d -m 0755 ${D}/home/root/ | ||
80 | install -m 0644 ${WORKDIR}/memtool_profile ${D}/home/root/.profile | ||
76 | } | 81 | } |
77 | 82 | ||
78 | FILES_${PN} += "/unit_tests" | 83 | FILES_${PN} += "/unit_tests /home/root/.profile" |
79 | RDEPENDS_${PN} = "bash" | 84 | RDEPENDS_${PN} = "bash" |
80 | 85 | ||
81 | FILES_${PN}-dbg += "/unit_tests/.debug" | 86 | FILES_${PN}-dbg += "/unit_tests/.debug" |
82 | COMPATIBLE_MACHINE = "(mx6|mx7)" | 87 | COMPATIBLE_MACHINE = "(mx6|mx7|mx8)" |