diff options
author | Otavio Salvador <otavio@ossystems.com.br> | 2015-08-05 08:50:26 -0300 |
---|---|---|
committer | Otavio Salvador <otavio@ossystems.com.br> | 2016-04-19 15:03:14 -0300 |
commit | d5e730317a4d1aa94bdfbf25654847fe788d70df (patch) | |
tree | 36c4c98296a7c073fa66a9bf938343ba63a9cf91 /recipes-bsp/imx-test | |
parent | b33e2a1f77655f625f3a4477a345991310af615b (diff) | |
download | meta-freescale-d5e730317a4d1aa94bdfbf25654847fe788d70df.tar.gz |
Drop Freescale official Linux kernel for i.MX23, i.MX28 and i.MX5 SoC families
The Linux kernel provided by Freescale for i.MX28 and i.MX5 is too old
(2.6.35.3) and there are no plans to upgrade it, as the OE-Core is
going to use GCC 5.2 as default compiler soon and it is not possible
to compile this kernel with the new toolchain, thus the removal.
The metadata related to the i.MX23, i.MX28 and i.MX5 SoC family, which
is dependant of this Linux kernel support, has been removed in this
commit so if someone ever wants to bring it back it is easy to find
out all the necessary changes. The recipes affected are:
- alsa-state
- amd-gpu-x11-bin
- gtk+3
- imx-lib
- imx-test
- imx-vpu
- libfslcodec
- linux-imx
- mesa
- qt4-embedded-free
- qt4-x11-free
- qtbase
- xf86-video-imxfb
Signed-off-by: Otavio Salvador <otavio@ossystems.com.br>
Acked-by: Daiane Angolini <daiane.angolini@freescale.com>
Diffstat (limited to 'recipes-bsp/imx-test')
-rw-r--r-- | recipes-bsp/imx-test/imx-test.inc | 4 | ||||
-rw-r--r-- | recipes-bsp/imx-test/imx-test/Fix-build-in-OpenEmbedded-Core-environment.patch | 30 | ||||
-rwxr-xr-x | recipes-bsp/imx-test/imx-test/clocks.sh | 29 | ||||
-rw-r--r-- | recipes-bsp/imx-test/imx-test/revert_epdc_hdr_change.patch | 30 | ||||
-rw-r--r-- | recipes-bsp/imx-test/imx-test_5.1.bb | 5 |
5 files changed, 1 insertions, 97 deletions
diff --git a/recipes-bsp/imx-test/imx-test.inc b/recipes-bsp/imx-test/imx-test.inc index a459ea91..7174b052 100644 --- a/recipes-bsp/imx-test/imx-test.inc +++ b/recipes-bsp/imx-test/imx-test.inc | |||
@@ -3,12 +3,10 @@ | |||
3 | SUMMARY = "Test programs for IMX BSP" | 3 | SUMMARY = "Test programs for IMX BSP" |
4 | DESCRIPTION = "Unit tests for the IMX BSP" | 4 | DESCRIPTION = "Unit tests for the IMX BSP" |
5 | SECTION = "base" | 5 | SECTION = "base" |
6 | DEPENDS_mx5 = "virtual/kernel imx-lib imx-vpu" | ||
7 | DEPENDS_mx6q = "virtual/kernel imx-lib imx-vpu" | 6 | DEPENDS_mx6q = "virtual/kernel imx-lib imx-vpu" |
8 | DEPENDS_mx6dl = "virtual/kernel imx-lib imx-vpu" | 7 | DEPENDS_mx6dl = "virtual/kernel imx-lib imx-vpu" |
9 | DEPENDS_mx6sl = "virtual/kernel imx-lib" | 8 | DEPENDS_mx6sl = "virtual/kernel imx-lib" |
10 | DEPENDS_mx6sx = "virtual/kernel imx-lib" | 9 | DEPENDS_mx6sx = "virtual/kernel imx-lib" |
11 | DEPENDS_mxs = "virtual/kernel" | ||
12 | DEPENDS_mx6ul = "virtual/kernel imx-lib" | 10 | DEPENDS_mx6ul = "virtual/kernel imx-lib" |
13 | DEPENDS_mx7 = "virtual/kernel imx-lib" | 11 | DEPENDS_mx7 = "virtual/kernel imx-lib" |
14 | 12 | ||
@@ -28,8 +26,6 @@ INHIBIT_PACKAGE_DEBUG_SPLIT = "1" | |||
28 | PLATFORM_mx6 = "IMX6Q" | 26 | PLATFORM_mx6 = "IMX6Q" |
29 | PLATFORM_mx6sl = "IMX6SL" | 27 | PLATFORM_mx6sl = "IMX6SL" |
30 | PLATFORM_mx6sx = "IMX6SX" | 28 | PLATFORM_mx6sx = "IMX6SX" |
31 | PLATFORM_mx53 = "IMX53" | ||
32 | PLATFORM_mx51 = "IMX51" | ||
33 | PLATFORM_mx7 = "IMX7D" | 29 | PLATFORM_mx7 = "IMX7D" |
34 | PLATFORM_mx6ul = "IMX6UL" | 30 | PLATFORM_mx6ul = "IMX6UL" |
35 | 31 | ||
diff --git a/recipes-bsp/imx-test/imx-test/Fix-build-in-OpenEmbedded-Core-environment.patch b/recipes-bsp/imx-test/imx-test/Fix-build-in-OpenEmbedded-Core-environment.patch deleted file mode 100644 index 7497e91d..00000000 --- a/recipes-bsp/imx-test/imx-test/Fix-build-in-OpenEmbedded-Core-environment.patch +++ /dev/null | |||
@@ -1,30 +0,0 @@ | |||
1 | From fd826140db0f2a867ef588cccf2e5322cc77126a Mon Sep 17 00:00:00 2001 | ||
2 | From: Otavio Salvador <otavio@ossystems.com.br> | ||
3 | Date: Mon, 19 Jan 2015 16:56:29 -0200 | ||
4 | Subject: [PATCH] Fix build in OpenEmbedded-Core environment | ||
5 | Organization: O.S. Systems Software LTDA. | ||
6 | |||
7 | Some of the unit-tests were not being built due to differences on how | ||
8 | the build system behaves when running inside of the OE-Core. This | ||
9 | fixes those minor issues and increases the number of tests available. | ||
10 | |||
11 | Upstream-Status: Pending | ||
12 | |||
13 | Signed-off-by: Otavio Salvador <otavio@ossystems.com.br> | ||
14 | |||
15 | diff --git a/test/ar3k_bt/Makefile b/test/ar3k_bt/Makefile | ||
16 | index 92e2901..75d3e78 100755 | ||
17 | --- a/test/ar3k_bt/Makefile | ||
18 | +++ b/test/ar3k_bt/Makefile | ||
19 | @@ -21,7 +21,7 @@ all: $(OBJS) | ||
20 | CFLAGS += -lbluetooth | ||
21 | |||
22 | $(OBJDIR)/hciattach-ar3k.bin : | ||
23 | - $(CC) ${INC} -Wall -lbluetooth -g hciattach_ath3k.c hciattach.c hciattach_qualcomm.c hciattach_st.c hciattach_tialt.c hciattach_ti.c -o hciattach-ar3k.bin | ||
24 | + $(CC) ${INC} -Wall -lbluetooth -g hciattach_ath3k.c hciattach.c hciattach_qualcomm.c hciattach_st.c hciattach_tialt.c hciattach_ti.c -o $(OBJDIR)/hciattach-ar3k.bin | ||
25 | |||
26 | clean: | ||
27 | rm -f *.o hciattach-ar3k.bin | ||
28 | -- | ||
29 | 2.1.4 | ||
30 | |||
diff --git a/recipes-bsp/imx-test/imx-test/clocks.sh b/recipes-bsp/imx-test/imx-test/clocks.sh deleted file mode 100755 index 2121bef6..00000000 --- a/recipes-bsp/imx-test/imx-test/clocks.sh +++ /dev/null | |||
@@ -1,29 +0,0 @@ | |||
1 | #!/bin/bash | ||
2 | |||
3 | # This script is taken directly from the section 5.10 of the Freescale Application Note | ||
4 | # AN4509 and it simple prints the CPU clocks in a nice format | ||
5 | |||
6 | saved_path=$PWD | ||
7 | if ! mount|grep -sq '/sys/kernel/debug'; then | ||
8 | mount -t debugfs none /sys/kernel/debug | ||
9 | fi | ||
10 | |||
11 | printf "%-24s %-20s %3s %9s\n" "clock" "parent" "use" "flags" "rate" | ||
12 | |||
13 | for foo in $(find /sys/kernel/debug/clock -type d); do | ||
14 | if [ "$foo" = '/sys/kernel/debug/clock' ]; then | ||
15 | continue | ||
16 | fi | ||
17 | cd $foo | ||
18 | ec="$(cat usecount)" | ||
19 | rate="$(cat rate)" | ||
20 | flag="$(cat flags)" | ||
21 | clk="$(basename $foo)" | ||
22 | cd .. | ||
23 | parent="$(basename $PWD)" | ||
24 | if [ "$parent" = 'clock' ]; then | ||
25 | parent=" ---" | ||
26 | fi | ||
27 | printf "%-24s %-24s %2d %2d %10d\n" "$clk" "$parent" "$ec" "$flag" "$rate" | ||
28 | cd $saved_path | ||
29 | done | ||
diff --git a/recipes-bsp/imx-test/imx-test/revert_epdc_hdr_change.patch b/recipes-bsp/imx-test/imx-test/revert_epdc_hdr_change.patch deleted file mode 100644 index 4fb0564a..00000000 --- a/recipes-bsp/imx-test/imx-test/revert_epdc_hdr_change.patch +++ /dev/null | |||
@@ -1,30 +0,0 @@ | |||
1 | From e559eb0a9573b9011c03efaf42364dce67af893a Mon Sep 17 00:00:00 2001 | ||
2 | From: Lauren Post <lauren.post@freescale.com> | ||
3 | Date: Tue, 10 Sep 2013 10:58:28 -0500 | ||
4 | Subject: [PATCH] ENGR00279068-2 epdc_test_driver: Update header name change | ||
5 | of mxc_epdc.h | ||
6 | |||
7 | Upstream-Status: Pending | ||
8 | |||
9 | Signed-off-by: Lauren Post <lauren.post@freescale.com> | ||
10 | Signed-off-by: Frank Li <Frank.li@freescale.com> | ||
11 | --- | ||
12 | module_test/epdc_test_driver.c | 4 ++-- | ||
13 | 1 file changed, 1 insertions(+), 1 deletions(-) | ||
14 | |||
15 | diff --git a/module_test/epdc_test_driver.c b/module_test/epdc_test_driver.c | ||
16 | index fb15aec..447246f 100644 | ||
17 | --- a/module_test/epdc_test_driver.c | ||
18 | +++ b/module_test/epdc_test_driver.c | ||
19 | @@ -36,7 +36,7 @@ | ||
20 | |||
21 | #include <linux/device.h> | ||
22 | #include <linux/mxcfb.h> | ||
23 | -#include <linux/mxcfb_epdc.h> | ||
24 | +#include <linux/mxcfb_epdc_kernel.h> | ||
25 | |||
26 | /* major number of device */ | ||
27 | static int gMajor; | ||
28 | -- | ||
29 | 1.7.9.5 | ||
30 | |||
diff --git a/recipes-bsp/imx-test/imx-test_5.1.bb b/recipes-bsp/imx-test/imx-test_5.1.bb index ff42c7fe..82df7652 100644 --- a/recipes-bsp/imx-test/imx-test_5.1.bb +++ b/recipes-bsp/imx-test/imx-test_5.1.bb | |||
@@ -2,10 +2,7 @@ | |||
2 | 2 | ||
3 | include imx-test.inc | 3 | include imx-test.inc |
4 | 4 | ||
5 | SRC_URI_append_mx5 = " file://clocks.sh" | ||
6 | SRC_URI_append_mxs = " file://clocks.sh" | ||
7 | |||
8 | SRC_URI[md5sum] = "5991439d4b20abac1095688164d26f40" | 5 | SRC_URI[md5sum] = "5991439d4b20abac1095688164d26f40" |
9 | SRC_URI[sha256sum] = "042d0b03d7838395a6b35d0ca7159f1f4b6cf3055dcc4a12a1b66488fca987b1" | 6 | SRC_URI[sha256sum] = "042d0b03d7838395a6b35d0ca7159f1f4b6cf3055dcc4a12a1b66488fca987b1" |
10 | 7 | ||
11 | COMPATIBLE_MACHINE = "(mxs|mx5|mx6|mx7)" | 8 | COMPATIBLE_MACHINE = "(mx6|mx7)" |