summaryrefslogtreecommitdiffstats
path: root/recipes-bsp/imx-test
diff options
context:
space:
mode:
authorCristinel Panfir <cristinel.panfir@nxp.com>2020-10-20 14:20:24 +0300
committerOtavio Salvador <otavio@ossystems.com.br>2020-10-20 10:23:07 -0300
commit346197c11b74b17974d8b260ac83f1d7d170e79b (patch)
treed1041710d84cf626c5ba5e226ad32b43c34fd6c7 /recipes-bsp/imx-test
parent350017397b22930c854a8024a0d7b825f000de26 (diff)
downloadmeta-freescale-346197c11b74b17974d8b260ac83f1d7d170e79b.tar.gz
imx-test: Upgrade recipe to imx_5.4.47_2.2.0 branch
- Drop the mxc_v4l2_test patch - the compilation error fix is included in the source code - Add pxp_test patch to fix format-security error Signed-off-by: Cristinel Panfir <cristinel.panfir@nxp.com>
Diffstat (limited to 'recipes-bsp/imx-test')
-rw-r--r--recipes-bsp/imx-test/imx-test/0001-mxc_v4l2_test-fix-compilation-error-produced-by-gcc9.patch39
-rw-r--r--recipes-bsp/imx-test/imx-test/0001-pxp-test-Fix-format-security-error.patch32
-rw-r--r--recipes-bsp/imx-test/imx-test_git.bb9
3 files changed, 35 insertions, 45 deletions
diff --git a/recipes-bsp/imx-test/imx-test/0001-mxc_v4l2_test-fix-compilation-error-produced-by-gcc9.patch b/recipes-bsp/imx-test/imx-test/0001-mxc_v4l2_test-fix-compilation-error-produced-by-gcc9.patch
deleted file mode 100644
index 3fb9d4ef..00000000
--- a/recipes-bsp/imx-test/imx-test/0001-mxc_v4l2_test-fix-compilation-error-produced-by-gcc9.patch
+++ /dev/null
@@ -1,39 +0,0 @@
1From d2e35983281a811b38e540ab82e7643322e84aab Mon Sep 17 00:00:00 2001
2From: Andrey Zhizhikin <andrey.zhizhikin@leica-geosystems.com>
3Date: Wed, 4 Dec 2019 14:17:50 +0000
4Subject: [PATCH] mxc_v4l2_test: fix compilation error produced by gcc9
5
6Fix trivial compilation error when GCC9 is used:
7
8error: call to '__open_missing_mode' declared with attribute error: open
9with O_CREAT or O_TMPFILE in second argument needs 3 arguments
10
11This is now caused by not explicitly supplying the mode when O_CREAT is
12used as disposition.
13
14Upstream-Status: Pending
15
16Signed-off-by: Andrey Zhizhikin <andrey.zhizhikin@leica-geosystems.com>
17---
18 test/mxc_v4l2_test/mx8_v4l2_cap_drm.c | 4 ----
19 1 file changed, 4 deletions(-)
20
21diff --git a/test/mxc_v4l2_test/mx8_v4l2_cap_drm.c b/test/mxc_v4l2_test/mx8_v4l2_cap_drm.c
22index 6e10744..d63b2db 100644
23--- a/test/mxc_v4l2_test/mx8_v4l2_cap_drm.c
24+++ b/test/mxc_v4l2_test/mx8_v4l2_cap_drm.c
25@@ -561,11 +561,7 @@ static int open_save_file(struct video_channel *video_ch)
26
27 for (i = 0; i < NUM_SENSORS; i++) {
28 if ((g_cam >> i) & 0x01) {
29-#ifdef BUILD_FOR_ANDROID
30 fd = open(video_ch[i].save_file_name, O_RDWR | O_CREAT, 0660);
31-#else
32- fd = open(video_ch[i].save_file_name, O_RDWR | O_CREAT);
33-#endif
34 if (fd < 0) {
35 v4l2_err("Channel[%d] unable to create recording file\n", i);
36 while (i)
37--
382.17.1
39
diff --git a/recipes-bsp/imx-test/imx-test/0001-pxp-test-Fix-format-security-error.patch b/recipes-bsp/imx-test/imx-test/0001-pxp-test-Fix-format-security-error.patch
new file mode 100644
index 00000000..1fe997d7
--- /dev/null
+++ b/recipes-bsp/imx-test/imx-test/0001-pxp-test-Fix-format-security-error.patch
@@ -0,0 +1,32 @@
1From 97a55fe4b1e02b9a4992517234a8b24f8f9f0009 Mon Sep 17 00:00:00 2001
2From: "i.MX Yocto Project Build" <imx.build@nxp.com>
3Date: Mon, 27 Jan 2020 13:43:47 -0600
4Subject: [PATCH] pxp test: Fix format-security error
5
6| pxp_lib_test/pxp_test.c: In function 'main':
7| pxp_lib_test/pxp_test.c:541:2: error: format not a string literal and no format arguments [-Werror=format-security]
8| 541 | printf(usage);
9| | ^~~~~~
10
11Upstream-Status: Pending
12
13Signed-off-by: Tom Hochstein <tom.hochstein@nxp.com>
14---
15 test/pxp_lib_test/pxp_test.c | 2 +-
16 1 file changed, 1 insertion(+), 1 deletion(-)
17
18diff --git a/test/pxp_lib_test/pxp_test.c b/test/pxp_lib_test/pxp_test.c
19index 107198f..72c984d 100644
20--- a/test/pxp_lib_test/pxp_test.c
21+++ b/test/pxp_lib_test/pxp_test.c
22@@ -538,6 +538,6 @@ int main(int argc, char *argv[])
23
24 return 0;
25 usage:
26- printf(usage);
27+ printf("%s", usage);
28 return -1;
29 }
30--
312.17.1
32
diff --git a/recipes-bsp/imx-test/imx-test_git.bb b/recipes-bsp/imx-test/imx-test_git.bb
index 61f5e9d4..b9c12e18 100644
--- a/recipes-bsp/imx-test/imx-test_git.bb
+++ b/recipes-bsp/imx-test/imx-test_git.bb
@@ -16,13 +16,13 @@ DEPENDS_append_imxvpu = " virtual/imxvpu"
16PE = "1" 16PE = "1"
17PV = "7.0+${SRCPV}" 17PV = "7.0+${SRCPV}"
18 18
19SRCBRANCH = "lf-5.4.y" 19SRCBRANCH = "imx_5.4.47_2.2.0"
20SRC_URI = " \ 20SRC_URI = " \
21 git://source.codeaurora.org/external/imx/imx-test.git;protocol=https;branch=${SRCBRANCH} \ 21 git://source.codeaurora.org/external/imx/imx-test.git;protocol=https;branch=${SRCBRANCH} \
22 file://0001-mxc_v4l2_test-fix-compilation-error-produced-by-gcc9.patch \ 22 file://0001-pxp-test-Fix-format-security-error.patch \
23 file://memtool_profile \ 23 file://memtool_profile \
24" 24"
25SRCREV = "6d20e84f2dbe5940fe6d629c2839e1390994ee1f" 25SRCREV = "31623a4972bf6f2f4239b4667aeb33baba07a3c8"
26S = "${WORKDIR}/git" 26S = "${WORKDIR}/git"
27 27
28inherit module-base use-imx-headers 28inherit module-base use-imx-headers
@@ -49,9 +49,6 @@ PACKAGECONFIG_append_imxvpu = " vpu"
49PACKAGECONFIG[x11] = ",,libx11 libxdamage libxrender libxrandr" 49PACKAGECONFIG[x11] = ",,libx11 libxdamage libxrender libxrandr"
50PACKAGECONFIG[vpu] = "HAS_VPU=true,HAS_VPU=false,virtual/imxvpu" 50PACKAGECONFIG[vpu] = "HAS_VPU=true,HAS_VPU=false,virtual/imxvpu"
51 51
52# FIXME: Fail to build due to misuse of printf
53SECURITY_STRINGFORMAT = ""
54
55do_compile() { 52do_compile() {
56 CFLAGS="${TOOLCHAIN_OPTIONS}" 53 CFLAGS="${TOOLCHAIN_OPTIONS}"
57 oe_runmake V=1 VERBOSE='' \ 54 oe_runmake V=1 VERBOSE='' \