summaryrefslogtreecommitdiffstats
path: root/recipes-bsp/imx-test
diff options
context:
space:
mode:
authorOtavio Salvador <otavio@ossystems.com.br>2015-07-15 17:14:27 -0300
committerOtavio Salvador <otavio@ossystems.com.br>2015-07-16 15:01:29 -0300
commitf8517afc7a5ada4538b3b7d397fa32586d57ffe5 (patch)
tree79349f091306d1760fd4687e62336ffa8fb8c721 /recipes-bsp/imx-test
parentc92b415d653afc55f33b6b93fb9248193bfd4fa0 (diff)
downloadmeta-freescale-f8517afc7a5ada4538b3b7d397fa32586d57ffe5.tar.gz
Move meta-fsl-arm content to layer root
The meta-fsl-arm is going to be used as the base for this layer. It contains a clean history and allowing a more granullar set of changes. This commit is just a rename of all contents of meta-fsl-arm subdirectory to this layer's root, subsequent changes are based on top of that. Signed-off-by: Otavio Salvador <otavio@ossystems.com.br>
Diffstat (limited to 'recipes-bsp/imx-test')
-rw-r--r--recipes-bsp/imx-test/imx-test.inc69
-rw-r--r--recipes-bsp/imx-test/imx-test/Fix-build-in-OpenEmbedded-Core-environment.patch30
-rwxr-xr-xrecipes-bsp/imx-test/imx-test/clocks.sh29
-rw-r--r--recipes-bsp/imx-test/imx-test/revert_epdc_hdr_change.patch30
-rw-r--r--recipes-bsp/imx-test/imx-test_00.00.00.bb10
-rw-r--r--recipes-bsp/imx-test/imx-test_3.14.28-1.0.0.bb13
6 files changed, 181 insertions, 0 deletions
diff --git a/recipes-bsp/imx-test/imx-test.inc b/recipes-bsp/imx-test/imx-test.inc
new file mode 100644
index 00000000..cba72f58
--- /dev/null
+++ b/recipes-bsp/imx-test/imx-test.inc
@@ -0,0 +1,69 @@
1# Copyright (C) 2012-2015 O.S. Systems Software LTDA.
2
3SUMMARY = "Test programs for IMX BSP"
4DESCRIPTION = "Unit tests for the IMX BSP"
5SECTION = "base"
6DEPENDS_mx5 = "virtual/kernel imx-lib imx-vpu"
7DEPENDS_mx6q = "virtual/kernel imx-lib imx-vpu"
8DEPENDS_mx6dl = "virtual/kernel imx-lib imx-vpu"
9DEPENDS_mx6sl = "virtual/kernel imx-lib"
10DEPENDS_mx6sx = "virtual/kernel imx-lib"
11DEPENDS_mxs = "virtual/kernel"
12
13LICENSE = "GPLv2"
14LIC_FILES_CHKSUM = "file://${COREBASE}/meta/files/common-licenses/GPL-2.0;md5=801f80980d171dd6425610833a22dbe6"
15
16PE = "1"
17
18SRC_URI = "${FSL_MIRROR}/imx-test-${PV}.tar.gz"
19
20inherit module-base
21
22INHIBIT_PACKAGE_STRIP = "1"
23INHIBIT_PACKAGE_DEBUG_SPLIT = "1"
24
25PLATFORM_mx6 = "IMX6Q"
26PLATFORM_mx6sl = "IMX6SL"
27PLATFORM_mx6sx = "IMX6SX"
28PLATFORM_mx53 = "IMX53"
29PLATFORM_mx51 = "IMX51"
30
31# Required so the fixdep binary is generated
32addtask make_scripts after do_patch before do_compile
33do_make_scripts[lockfiles] = "${TMPDIR}/kernel-scripts.lock"
34do_make_scripts[deptask] = "do_populate_sysroot"
35do_make_scripts[depends] += "virtual/kernel:do_install"
36
37do_compile() {
38 CFLAGS="${TOOLCHAIN_OPTIONS}"
39 LDFLAGS="${TOOLCHAIN_OPTIONS} -L${STAGING_LIBDIR}"
40 oe_runmake V=1 VERBOSE='' \
41 CROSS_COMPILE=${TARGET_PREFIX} \
42 INC="-I${STAGING_INCDIR} \
43 -I${S}/include \
44 -I${STAGING_KERNEL_BUILDDIR}/include/uapi \
45 -I${STAGING_KERNEL_BUILDDIR}/include \
46 -I${STAGING_KERNEL_DIR}/include/uapi \
47 -I${STAGING_KERNEL_DIR}/include \
48 -I${STAGING_KERNEL_DIR}/arch/arm/include \
49 -I${STAGING_KERNEL_DIR}/drivers/mxc/security/rng/include \
50 -I${STAGING_KERNEL_DIR}/drivers/mxc/security/sahara2/include" \
51 LINUXPATH=${STAGING_KERNEL_DIR} \
52 KBUILD_OUTPUT=${STAGING_KERNEL_BUILDDIR} \
53 PLATFORM=${PLATFORM}
54}
55
56do_install() {
57 oe_runmake DESTDIR=${D}/unit_tests \
58 PLATFORM=${PLATFORM} \
59 install
60
61 if [ -e ${WORKDIR}/clocks.sh ]; then
62 install -m 755 ${WORKDIR}/clocks.sh ${D}/unit_tests/clocks.sh
63 fi
64}
65
66FILES_${PN} += "/unit_tests"
67RDEPENDS_${PN} = "bash"
68
69FILES_${PN}-dbg += "/unit_tests/.debug"
diff --git a/recipes-bsp/imx-test/imx-test/Fix-build-in-OpenEmbedded-Core-environment.patch b/recipes-bsp/imx-test/imx-test/Fix-build-in-OpenEmbedded-Core-environment.patch
new file mode 100644
index 00000000..7497e91d
--- /dev/null
+++ b/recipes-bsp/imx-test/imx-test/Fix-build-in-OpenEmbedded-Core-environment.patch
@@ -0,0 +1,30 @@
1From fd826140db0f2a867ef588cccf2e5322cc77126a Mon Sep 17 00:00:00 2001
2From: Otavio Salvador <otavio@ossystems.com.br>
3Date: Mon, 19 Jan 2015 16:56:29 -0200
4Subject: [PATCH] Fix build in OpenEmbedded-Core environment
5Organization: O.S. Systems Software LTDA.
6
7Some of the unit-tests were not being built due to differences on how
8the build system behaves when running inside of the OE-Core. This
9fixes those minor issues and increases the number of tests available.
10
11Upstream-Status: Pending
12
13Signed-off-by: Otavio Salvador <otavio@ossystems.com.br>
14
15diff --git a/test/ar3k_bt/Makefile b/test/ar3k_bt/Makefile
16index 92e2901..75d3e78 100755
17--- a/test/ar3k_bt/Makefile
18+++ b/test/ar3k_bt/Makefile
19@@ -21,7 +21,7 @@ all: $(OBJS)
20 CFLAGS += -lbluetooth
21
22 $(OBJDIR)/hciattach-ar3k.bin :
23- $(CC) ${INC} -Wall -lbluetooth -g hciattach_ath3k.c hciattach.c hciattach_qualcomm.c hciattach_st.c hciattach_tialt.c hciattach_ti.c -o hciattach-ar3k.bin
24+ $(CC) ${INC} -Wall -lbluetooth -g hciattach_ath3k.c hciattach.c hciattach_qualcomm.c hciattach_st.c hciattach_tialt.c hciattach_ti.c -o $(OBJDIR)/hciattach-ar3k.bin
25
26 clean:
27 rm -f *.o hciattach-ar3k.bin
28--
292.1.4
30
diff --git a/recipes-bsp/imx-test/imx-test/clocks.sh b/recipes-bsp/imx-test/imx-test/clocks.sh
new file mode 100755
index 00000000..2121bef6
--- /dev/null
+++ b/recipes-bsp/imx-test/imx-test/clocks.sh
@@ -0,0 +1,29 @@
1#!/bin/bash
2
3# This script is taken directly from the section 5.10 of the Freescale Application Note
4# AN4509 and it simple prints the CPU clocks in a nice format
5
6saved_path=$PWD
7if ! mount|grep -sq '/sys/kernel/debug'; then
8 mount -t debugfs none /sys/kernel/debug
9fi
10
11printf "%-24s %-20s %3s %9s\n" "clock" "parent" "use" "flags" "rate"
12
13for foo in $(find /sys/kernel/debug/clock -type d); do
14 if [ "$foo" = '/sys/kernel/debug/clock' ]; then
15 continue
16 fi
17 cd $foo
18 ec="$(cat usecount)"
19 rate="$(cat rate)"
20 flag="$(cat flags)"
21 clk="$(basename $foo)"
22 cd ..
23 parent="$(basename $PWD)"
24 if [ "$parent" = 'clock' ]; then
25 parent=" ---"
26 fi
27 printf "%-24s %-24s %2d %2d %10d\n" "$clk" "$parent" "$ec" "$flag" "$rate"
28 cd $saved_path
29done
diff --git a/recipes-bsp/imx-test/imx-test/revert_epdc_hdr_change.patch b/recipes-bsp/imx-test/imx-test/revert_epdc_hdr_change.patch
new file mode 100644
index 00000000..4fb0564a
--- /dev/null
+++ b/recipes-bsp/imx-test/imx-test/revert_epdc_hdr_change.patch
@@ -0,0 +1,30 @@
1From e559eb0a9573b9011c03efaf42364dce67af893a Mon Sep 17 00:00:00 2001
2From: Lauren Post <lauren.post@freescale.com>
3Date: Tue, 10 Sep 2013 10:58:28 -0500
4Subject: [PATCH] ENGR00279068-2 epdc_test_driver: Update header name change
5 of mxc_epdc.h
6
7Upstream-Status: Pending
8
9Signed-off-by: Lauren Post <lauren.post@freescale.com>
10Signed-off-by: Frank Li <Frank.li@freescale.com>
11---
12 module_test/epdc_test_driver.c | 4 ++--
13 1 file changed, 1 insertions(+), 1 deletions(-)
14
15diff --git a/module_test/epdc_test_driver.c b/module_test/epdc_test_driver.c
16index fb15aec..447246f 100644
17--- a/module_test/epdc_test_driver.c
18+++ b/module_test/epdc_test_driver.c
19@@ -36,7 +36,7 @@
20
21 #include <linux/device.h>
22 #include <linux/mxcfb.h>
23-#include <linux/mxcfb_epdc.h>
24+#include <linux/mxcfb_epdc_kernel.h>
25
26 /* major number of device */
27 static int gMajor;
28--
291.7.9.5
30
diff --git a/recipes-bsp/imx-test/imx-test_00.00.00.bb b/recipes-bsp/imx-test/imx-test_00.00.00.bb
new file mode 100644
index 00000000..f38dc67f
--- /dev/null
+++ b/recipes-bsp/imx-test/imx-test_00.00.00.bb
@@ -0,0 +1,10 @@
1SUMMARY = "Dummy package for SoCs lacking imx-test package"
2DESCRIPTION = "Dummy package for SoCs lacking imx-test package"
3SECTION = "base"
4LICENSE = "MIT"
5LIC_FILES_CHKSUM = "file://${COREBASE}/meta/files/common-licenses/MIT;md5=0835ade698e0bcf8506ecda2f7b4f302"
6
7ALLOW_EMPTY_${PN} = "1"
8
9PACKAGE_ARCH = "${MACHINE_ARCH}"
10COMPATIBLE_MACHINE = "(mxs|mx3|mx5|mx6|vf50|vf60)"
diff --git a/recipes-bsp/imx-test/imx-test_3.14.28-1.0.0.bb b/recipes-bsp/imx-test/imx-test_3.14.28-1.0.0.bb
new file mode 100644
index 00000000..fc2ad1d5
--- /dev/null
+++ b/recipes-bsp/imx-test/imx-test_3.14.28-1.0.0.bb
@@ -0,0 +1,13 @@
1# Copyright (C) 2013-2015 Freescale Semiconductor
2
3include imx-test.inc
4
5SRC_URI_append_mx5 = " file://revert_epdc_hdr_change.patch \
6 file://clocks.sh"
7SRC_URI_append_mxs = " file://revert_epdc_hdr_change.patch \
8 file://clocks.sh"
9
10SRC_URI[md5sum] = "f349aed49830a21cc75d305b06979205"
11SRC_URI[sha256sum] = "ea3d572e82a374bcfc9acc654b66262cd97a246ffec9fb9fc458b19a02512723"
12
13COMPATIBLE_MACHINE = "(mxs|mx5|mx6)"