diff options
author | Otavio Salvador <otavio@ossystems.com.br> | 2018-10-25 22:44:12 -0300 |
---|---|---|
committer | Otavio Salvador <otavio@ossystems.com.br> | 2018-10-26 14:23:37 -0300 |
commit | bc937ade566528cc097c9321694c0f5f5ef8cbf6 (patch) | |
tree | ce4a1a56a5082f9c5f6d849963f5bbef4f993733 /recipes-bsp/imx-test | |
parent | 700abd5d1b9ce55de5c62a8d0a82c08aa6cd6897 (diff) | |
download | meta-freescale-bc937ade566528cc097c9321694c0f5f5ef8cbf6.tar.gz |
classes/use-imx-headers: Easy linux-imx-headers use
This allow to easy reuse of binary packages among similar SoCs. The
usual use for this is to share SoC specific packages among different
boards independently of the kernel version it is using, as far it is
ABI compatible with the official version it will just work.
Following recipes has been reworked to make use of the class:
- imx-lib
- imx-test
- imx-vpu-hantro
- imx-vpu
- imx-alsa-plugins
- gstreamer1.0-plugins-base
- gstreamer1.0-plugins-imx
- imx-gst1.0-plugin
Signed-off-by: Otavio Salvador <otavio@ossystems.com.br>
Signed-off-by: Tom Hochstein <tom.hochstein@nxp.com>
Diffstat (limited to 'recipes-bsp/imx-test')
-rw-r--r-- | recipes-bsp/imx-test/imx-test_git.bb | 11 |
1 files changed, 5 insertions, 6 deletions
diff --git a/recipes-bsp/imx-test/imx-test_git.bb b/recipes-bsp/imx-test/imx-test_git.bb index 729e2670..fae459ca 100644 --- a/recipes-bsp/imx-test/imx-test_git.bb +++ b/recipes-bsp/imx-test/imx-test_git.bb | |||
@@ -8,7 +8,7 @@ SECTION = "base" | |||
8 | LICENSE = "GPLv2" | 8 | LICENSE = "GPLv2" |
9 | LIC_FILES_CHKSUM = "file://${COREBASE}/meta/files/common-licenses/GPL-2.0;md5=801f80980d171dd6425610833a22dbe6" | 9 | LIC_FILES_CHKSUM = "file://${COREBASE}/meta/files/common-licenses/GPL-2.0;md5=801f80980d171dd6425610833a22dbe6" |
10 | 10 | ||
11 | DEPENDS = "linux-imx-headers alsa-lib libdrm" | 11 | DEPENDS = "alsa-lib libdrm" |
12 | DEPENDS_append_mx6 = " imx-lib" | 12 | DEPENDS_append_mx6 = " imx-lib" |
13 | DEPENDS_append_mx7 = " imx-lib" | 13 | DEPENDS_append_mx7 = " imx-lib" |
14 | 14 | ||
@@ -24,7 +24,7 @@ SRC_URI = " \ | |||
24 | SRCREV = "3a87347ae408ef0234314a279ee74d9b015f06be" | 24 | SRCREV = "3a87347ae408ef0234314a279ee74d9b015f06be" |
25 | S = "${WORKDIR}/git" | 25 | S = "${WORKDIR}/git" |
26 | 26 | ||
27 | inherit module-base | 27 | inherit module-base use-imx-headers |
28 | 28 | ||
29 | INHIBIT_PACKAGE_STRIP = "1" | 29 | INHIBIT_PACKAGE_STRIP = "1" |
30 | INHIBIT_PACKAGE_DEBUG_SPLIT = "1" | 30 | INHIBIT_PACKAGE_DEBUG_SPLIT = "1" |
@@ -55,9 +55,9 @@ do_compile() { | |||
55 | CFLAGS="${TOOLCHAIN_OPTIONS}" | 55 | CFLAGS="${TOOLCHAIN_OPTIONS}" |
56 | oe_runmake V=1 VERBOSE='' \ | 56 | oe_runmake V=1 VERBOSE='' \ |
57 | CROSS_COMPILE=${TARGET_PREFIX} \ | 57 | CROSS_COMPILE=${TARGET_PREFIX} \ |
58 | INC="-I${STAGING_INCDIR} \ | 58 | INC="-I${S}/include \ |
59 | -I${S}/include \ | 59 | -I${STAGING_INCDIR} \ |
60 | -I${STAGING_INCDIR}/imx" \ | 60 | -I${STAGING_INCDIR_IMX}" \ |
61 | CC="${CC} -L${STAGING_LIBDIR} ${LDFLAGS}" \ | 61 | CC="${CC} -L${STAGING_LIBDIR} ${LDFLAGS}" \ |
62 | SDKTARGETSYSROOT=${STAGING_DIR_HOST} \ | 62 | SDKTARGETSYSROOT=${STAGING_DIR_HOST} \ |
63 | LINUXPATH=${STAGING_KERNEL_DIR} \ | 63 | LINUXPATH=${STAGING_KERNEL_DIR} \ |
@@ -82,5 +82,4 @@ RDEPENDS_${PN} = "bash" | |||
82 | 82 | ||
83 | FILES_${PN}-dbg += "/unit_tests/.debug" | 83 | FILES_${PN}-dbg += "/unit_tests/.debug" |
84 | 84 | ||
85 | PACKAGE_ARCH = "${MACHINE_SOCARCH}" | ||
86 | COMPATIBLE_MACHINE = "(mx6|mx7|mx8)" | 85 | COMPATIBLE_MACHINE = "(mx6|mx7|mx8)" |