diff options
author | Otavio Salvador <otavio@ossystems.com.br> | 2020-10-02 10:15:10 -0300 |
---|---|---|
committer | Otavio Salvador <otavio@ossystems.com.br> | 2020-10-02 10:18:30 -0300 |
commit | 8a6193807d07edc30fd06e19f475dc7a7c1689b2 (patch) | |
tree | 75e671920f36301b672fdc5475b316f0026fd089 /recipes-bsp/imx-test | |
parent | f607eb8734af83a3667bb4581c1b93307e06d337 (diff) | |
download | meta-freescale-8a6193807d07edc30fd06e19f475dc7a7c1689b2.tar.gz |
imx-test: Disable stringformat security flags
This fixes following build error:
,----
| pxp_lib_test/pxp_test.c: In function 'main':
| pxp_lib_test/pxp_test.c:541:2: error: format not a string literal and no format arguments [-Werror=format-security]
| 541 | printf(usage);
| | ^~~~~~
`----
Fixes: #506.
Signed-off-by: Otavio Salvador <otavio@ossystems.com.br>
Change-Id: Ie6df1a64ba7126967861cb8fc889d4ca6f22b67a
Diffstat (limited to 'recipes-bsp/imx-test')
-rw-r--r-- | recipes-bsp/imx-test/imx-test_git.bb | 3 |
1 files changed, 3 insertions, 0 deletions
diff --git a/recipes-bsp/imx-test/imx-test_git.bb b/recipes-bsp/imx-test/imx-test_git.bb index 81bbd3a3..61f5e9d4 100644 --- a/recipes-bsp/imx-test/imx-test_git.bb +++ b/recipes-bsp/imx-test/imx-test_git.bb | |||
@@ -49,6 +49,9 @@ PACKAGECONFIG_append_imxvpu = " vpu" | |||
49 | PACKAGECONFIG[x11] = ",,libx11 libxdamage libxrender libxrandr" | 49 | PACKAGECONFIG[x11] = ",,libx11 libxdamage libxrender libxrandr" |
50 | PACKAGECONFIG[vpu] = "HAS_VPU=true,HAS_VPU=false,virtual/imxvpu" | 50 | PACKAGECONFIG[vpu] = "HAS_VPU=true,HAS_VPU=false,virtual/imxvpu" |
51 | 51 | ||
52 | # FIXME: Fail to build due to misuse of printf | ||
53 | SECURITY_STRINGFORMAT = "" | ||
54 | |||
52 | do_compile() { | 55 | do_compile() { |
53 | CFLAGS="${TOOLCHAIN_OPTIONS}" | 56 | CFLAGS="${TOOLCHAIN_OPTIONS}" |
54 | oe_runmake V=1 VERBOSE='' \ | 57 | oe_runmake V=1 VERBOSE='' \ |