diff options
author | Fabio Berton <fabio.berton@ossystems.com.br> | 2018-06-11 15:54:36 -0300 |
---|---|---|
committer | Otavio Salvador <otavio@ossystems.com.br> | 2018-06-26 14:16:13 -0300 |
commit | 8b0357fdb0f26bad796ab2560cdea57c3201b445 (patch) | |
tree | 5db24ac93bf5c9929c95edbe75c082ff96fa9263 /recipes-bsp/imx-test/imx-test_git.bb | |
parent | f62e49dd7966e5d4ea2a9fde536c6150797d0772 (diff) | |
download | meta-freescale-8b0357fdb0f26bad796ab2560cdea57c3201b445.tar.gz |
imx-test: Update to version 7.0
- Remove .inc file to use only one .bb file
- Add alsa-lib to DEPENDS
- Add patch to use include path when compile sources from test directory
- Drop unused patch
- Update O.S. Systems Software Copyright
Signed-off-by: Fabio Berton <fabio.berton@ossystems.com.br>
Diffstat (limited to 'recipes-bsp/imx-test/imx-test_git.bb')
-rw-r--r-- | recipes-bsp/imx-test/imx-test_git.bb | 84 |
1 files changed, 77 insertions, 7 deletions
diff --git a/recipes-bsp/imx-test/imx-test_git.bb b/recipes-bsp/imx-test/imx-test_git.bb index ddc87a97..94765df4 100644 --- a/recipes-bsp/imx-test/imx-test_git.bb +++ b/recipes-bsp/imx-test/imx-test_git.bb | |||
@@ -1,16 +1,86 @@ | |||
1 | # Copyright (C) 2013-2016 Freescale Semiconductor | 1 | # Copyright (C) 2012-2018 O.S. Systems Software LTDA. |
2 | # Copyright (C) 2015 Freescale Semiconductor | ||
2 | # Copyright 2017 NXP | 3 | # Copyright 2017 NXP |
3 | 4 | ||
4 | include imx-test.inc | 5 | SUMMARY = "Test programs for IMX BSP" |
6 | DESCRIPTION = "Unit tests for the IMX BSP" | ||
7 | SECTION = "base" | ||
8 | LICENSE = "GPLv2" | ||
9 | LIC_FILES_CHKSUM = "file://${COREBASE}/meta/files/common-licenses/GPL-2.0;md5=801f80980d171dd6425610833a22dbe6" | ||
5 | 10 | ||
6 | PV = "6.0+${SRCPV}" | 11 | DEPENDS_mx6q = "virtual/kernel imx-lib virtual/imxvpu" |
12 | DEPENDS_mx6dl = "virtual/kernel imx-lib virtual/imxvpu" | ||
13 | DEPENDS_mx6sl = "virtual/kernel imx-lib" | ||
14 | DEPENDS_mx6sll = "virtual/kernel imx-lib" | ||
15 | DEPENDS_mx6sx = "virtual/kernel imx-lib" | ||
16 | DEPENDS_mx6ul = "virtual/kernel imx-lib" | ||
17 | DEPENDS_mx7d = "virtual/kernel imx-lib" | ||
18 | DEPENDS_mx7ulp = "virtual/kernel imx-lib" | ||
19 | DEPENDS_append = " alsa-lib" | ||
7 | 20 | ||
8 | PARALLEL_MAKE="-j 1" | 21 | PE = "1" |
22 | PV = "7.0+${SRCPV}" | ||
9 | 23 | ||
10 | SRCBRANCH = "nxp/imx_4.9.11_1.0.0_ga" | 24 | SRCBRANCH = "imx_4.9.88_2.0.0_ga" |
11 | SRC_URI = "git://source.codeaurora.org/external/imx/imx-test.git;protocol=https;branch=${SRCBRANCH}" | 25 | SRCREV = "1f7da41b3a8d5dff8329d7b01b10d4d71144b43e" |
12 | SRCREV = "fb250a795ce0d25c19610e9e19e1cd815fc64cb9" | 26 | SRC_URI = " \ |
27 | git://source.codeaurora.org/external/imx/imx-test.git;protocol=https;branch=${SRCBRANCH} \ | ||
28 | file://0001-test-Makefile-Add-include-path-to-CC-command.patch \ | ||
29 | " | ||
13 | 30 | ||
14 | S = "${WORKDIR}/git" | 31 | S = "${WORKDIR}/git" |
15 | 32 | ||
33 | |||
34 | inherit module-base | ||
35 | |||
36 | INHIBIT_PACKAGE_STRIP = "1" | ||
37 | INHIBIT_PACKAGE_DEBUG_SPLIT = "1" | ||
38 | |||
39 | PLATFORM_mx6q = "IMX6Q" | ||
40 | PLATFORM_mx6dl = "IMX6Q" | ||
41 | PLATFORM_mx6sl = "IMX6SL" | ||
42 | PLATFORM_mx6sll = "IMX6SL" | ||
43 | PLATFORM_mx6sx = "IMX6SX" | ||
44 | PLATFORM_mx6ul = "IMX6UL" | ||
45 | PLATFORM_mx7d = "IMX7D" | ||
46 | PLATFORM_mx7ulp = "IMX7D" | ||
47 | |||
48 | PARALLEL_MAKE="-j 1" | ||
49 | |||
50 | PACKAGECONFIG ?= "${@bb.utils.contains('DISTRO_FEATURES', 'x11', 'x11', '', d)}" | ||
51 | PACKAGECONFIG[x11] = ",,libx11 libxdamage libxrender libxrandr" | ||
52 | |||
53 | do_compile() { | ||
54 | CFLAGS="${TOOLCHAIN_OPTIONS}" | ||
55 | oe_runmake V=1 VERBOSE='' \ | ||
56 | CROSS_COMPILE=${TARGET_PREFIX} \ | ||
57 | INC="-I${STAGING_INCDIR} \ | ||
58 | -I${S}/include \ | ||
59 | -I${STAGING_KERNEL_BUILDDIR}/include/uapi \ | ||
60 | -I${STAGING_KERNEL_BUILDDIR}/include \ | ||
61 | -I${STAGING_KERNEL_DIR}/include/uapi \ | ||
62 | -I${STAGING_KERNEL_DIR}/include \ | ||
63 | -I${STAGING_KERNEL_DIR}/arch/arm/include \ | ||
64 | -I${STAGING_KERNEL_DIR}/drivers/mxc/security/rng/include \ | ||
65 | -I${STAGING_KERNEL_DIR}/drivers/mxc/security/sahara2/include" \ | ||
66 | CC="${CC} -L${STAGING_LIBDIR} ${LDFLAGS}" \ | ||
67 | LINUXPATH=${STAGING_KERNEL_DIR} \ | ||
68 | KBUILD_OUTPUT=${STAGING_KERNEL_BUILDDIR} \ | ||
69 | PLATFORM=${PLATFORM} | ||
70 | } | ||
71 | |||
72 | do_install() { | ||
73 | oe_runmake DESTDIR=${D}/unit_tests \ | ||
74 | PLATFORM=${PLATFORM} \ | ||
75 | install | ||
76 | |||
77 | if [ -e ${WORKDIR}/clocks.sh ]; then | ||
78 | install -m 755 ${WORKDIR}/clocks.sh ${D}/unit_tests/clocks.sh | ||
79 | fi | ||
80 | } | ||
81 | |||
82 | FILES_${PN} += "/unit_tests" | ||
83 | RDEPENDS_${PN} = "bash" | ||
84 | |||
85 | FILES_${PN}-dbg += "/unit_tests/.debug" | ||
16 | COMPATIBLE_MACHINE = "(mx6|mx7)" | 86 | COMPATIBLE_MACHINE = "(mx6|mx7)" |