diff options
author | Khem Raj <raj.khem@gmail.com> | 2023-01-07 22:01:06 -0800 |
---|---|---|
committer | Khem Raj <raj.khem@gmail.com> | 2023-01-07 22:01:06 -0800 |
commit | 9d0f293b68e5d7bbfa925ecace5068e41855a4ac (patch) | |
tree | 02c79f4cd635187086f75a10fa27c4bcd3b33e7c /recipes-bsp/imx-seco | |
parent | 3099ed6a03a2f9a8295638c74e2c54b3c68c461d (diff) | |
download | meta-freescale-9d0f293b68e5d7bbfa925ecace5068e41855a4ac.tar.gz |
imx-seco-libs: Fix build with clang
Signed-off-by: Khem Raj <raj.khem@gmail.com>
Diffstat (limited to 'recipes-bsp/imx-seco')
-rw-r--r-- | recipes-bsp/imx-seco/imx-seco-libs/0001-Fix-return-value-of-void-functions.patch | 57 | ||||
-rw-r--r-- | recipes-bsp/imx-seco/imx-seco-libs_git.bb | 3 |
2 files changed, 59 insertions, 1 deletions
diff --git a/recipes-bsp/imx-seco/imx-seco-libs/0001-Fix-return-value-of-void-functions.patch b/recipes-bsp/imx-seco/imx-seco-libs/0001-Fix-return-value-of-void-functions.patch new file mode 100644 index 00000000..656469c2 --- /dev/null +++ b/recipes-bsp/imx-seco/imx-seco-libs/0001-Fix-return-value-of-void-functions.patch | |||
@@ -0,0 +1,57 @@ | |||
1 | From 2eff97fe2345d8255869224404322d23193f1115 Mon Sep 17 00:00:00 2001 | ||
2 | From: Khem Raj <raj.khem@gmail.com> | ||
3 | Date: Sat, 7 Jan 2023 21:59:15 -0800 | ||
4 | Subject: [PATCH] Fix return value of void* functions | ||
5 | |||
6 | This is found with clang | ||
7 | |||
8 | Fixes | ||
9 | error: non-void function does not return a value [-Werror,-Wreturn-type] | ||
10 | |||
11 | Upstream-Status: Pending | ||
12 | Signed-off-by: Khem Raj <raj.khem@gmail.com> | ||
13 | --- | ||
14 | test/hsm/hsm_test.c | 1 + | ||
15 | test/she/src/she_test_storage_manager.c | 1 + | ||
16 | test/v2x/v2x_test.c | 1 + | ||
17 | 3 files changed, 3 insertions(+) | ||
18 | |||
19 | diff --git a/test/hsm/hsm_test.c b/test/hsm/hsm_test.c | ||
20 | index 9f29ca9..01820b8 100644 | ||
21 | --- a/test/hsm/hsm_test.c | ||
22 | +++ b/test/hsm/hsm_test.c | ||
23 | @@ -391,6 +391,7 @@ static uint32_t nvm_status; | ||
24 | static void *hsm_storage_thread(void *arg) | ||
25 | { | ||
26 | seco_nvm_manager(NVM_FLAGS_HSM, &nvm_status); | ||
27 | + return 0; | ||
28 | } | ||
29 | |||
30 | |||
31 | diff --git a/test/she/src/she_test_storage_manager.c b/test/she/src/she_test_storage_manager.c | ||
32 | index 32a4cb9..68cdba7 100644 | ||
33 | --- a/test/she/src/she_test_storage_manager.c | ||
34 | +++ b/test/she/src/she_test_storage_manager.c | ||
35 | @@ -28,6 +28,7 @@ static uint32_t nvm_status; | ||
36 | static void *she_storage_thread(void *arg) | ||
37 | { | ||
38 | seco_nvm_manager(NVM_FLAGS_SHE, &nvm_status); | ||
39 | + return 0; | ||
40 | } | ||
41 | |||
42 | |||
43 | diff --git a/test/v2x/v2x_test.c b/test/v2x/v2x_test.c | ||
44 | index aeb3d2a..5f02354 100644 | ||
45 | --- a/test/v2x/v2x_test.c | ||
46 | +++ b/test/v2x/v2x_test.c | ||
47 | @@ -181,6 +181,7 @@ static uint32_t nvm_status; | ||
48 | static void *v2x_hsm_storage_thread(void *arg) | ||
49 | { | ||
50 | seco_nvm_manager(NVM_FLAGS_V2X | NVM_FLAGS_HSM, &nvm_status); | ||
51 | + return 0; | ||
52 | } | ||
53 | |||
54 | |||
55 | -- | ||
56 | 2.39.0 | ||
57 | |||
diff --git a/recipes-bsp/imx-seco/imx-seco-libs_git.bb b/recipes-bsp/imx-seco/imx-seco-libs_git.bb index 625834b7..9b250975 100644 --- a/recipes-bsp/imx-seco/imx-seco-libs_git.bb +++ b/recipes-bsp/imx-seco/imx-seco-libs_git.bb | |||
@@ -12,7 +12,8 @@ SRCBRANCH = "imx_5.4.70_2.3.9" | |||
12 | SRC_URI = "git://github.com/NXP/imx-seco-libs.git;protocol=https;branch=${SRCBRANCH} \ | 12 | SRC_URI = "git://github.com/NXP/imx-seco-libs.git;protocol=https;branch=${SRCBRANCH} \ |
13 | file://0001-Makefile-Fix-LIBDIR-for-multilib.patch \ | 13 | file://0001-Makefile-Fix-LIBDIR-for-multilib.patch \ |
14 | file://0002-Makefile-Fix-install-to-clear-host-user-contaminated.patch \ | 14 | file://0002-Makefile-Fix-install-to-clear-host-user-contaminated.patch \ |
15 | file://0001-add-v2x_test-to-the-installed-binaries.patch" | 15 | file://0001-add-v2x_test-to-the-installed-binaries.patch \ |
16 | file://0001-Fix-return-value-of-void-functions.patch" | ||
16 | SRCREV = "b2550476388e1d1453bddbf356844301467c7bfa" | 17 | SRCREV = "b2550476388e1d1453bddbf356844301467c7bfa" |
17 | 18 | ||
18 | S = "${WORKDIR}/git" | 19 | S = "${WORKDIR}/git" |