diff options
author | Tom Hochstein <tom.hochstein@nxp.com> | 2022-05-09 13:48:48 -0500 |
---|---|---|
committer | github-actions[bot] <github-actions[bot]@users.noreply.github.com> | 2022-05-10 16:47:51 +0000 |
commit | 1ca79c1acd4b185cdf5f52e4e18d6ad3d91684af (patch) | |
tree | e204bfbd788bc7018f281b0109eafd4e996dc04f /recipes-bsp/imx-seco | |
parent | 15c484d12610f037729377014bdd753a24776093 (diff) | |
download | meta-freescale-1ca79c1acd4b185cdf5f52e4e18d6ad3d91684af.tar.gz |
imx-seco-libs: Update for NXP release 5.15.5-1.0.0
Fixes:
06a9062 V2XA-767: add a delay for v2x signed msg
f0d294b HSM-630: update doc
e98a558 HSM-630: Update project name doxyfile
c22f003 HSM-630: update version and hsm api doc
e0886ae HSM-630: add fast mac flag to use cau for cmac
Includes patches:
- Fix for multilib
- Add v2x_test
Signed-off-by: Tom Hochstein <tom.hochstein@nxp.com>
(cherry picked from commit 9d815c53eba15bf036cac35f5b2be6613bc53cea)
Diffstat (limited to 'recipes-bsp/imx-seco')
3 files changed, 66 insertions, 3 deletions
diff --git a/recipes-bsp/imx-seco/imx-seco-libs/0001-Makefile-Fix-LIBDIR-for-multilib.patch b/recipes-bsp/imx-seco/imx-seco-libs/0001-Makefile-Fix-LIBDIR-for-multilib.patch new file mode 100644 index 00000000..27107a6a --- /dev/null +++ b/recipes-bsp/imx-seco/imx-seco-libs/0001-Makefile-Fix-LIBDIR-for-multilib.patch | |||
@@ -0,0 +1,28 @@ | |||
1 | From 9e89d173a7fab97c913960344ae01dfa409b6258 Mon Sep 17 00:00:00 2001 | ||
2 | From: Cristinel Panfir <cristinel.panfir@nxp.com> | ||
3 | Date: Mon, 27 Jul 2020 18:55:30 +0000 | ||
4 | Subject: [PATCH] Makefile: Fix LIBDIR for multilib | ||
5 | |||
6 | Upstream-Status: Pending | ||
7 | Signed-off-by: Cristinel Panfir <cristinel.panfir@nxp.com> | ||
8 | --- | ||
9 | Makefile | 3 ++- | ||
10 | 1 file changed, 2 insertions(+), 1 deletion(-) | ||
11 | |||
12 | diff --git a/Makefile b/Makefile | ||
13 | index b16cebf..492d700 100644 | ||
14 | --- a/Makefile | ||
15 | +++ b/Makefile | ||
16 | @@ -4,7 +4,8 @@ all: she_test hsm_test v2x_test she_lib.a seco_nvm_manager.a hsm_lib.a | ||
17 | CFLAGS = -O1 -Werror -fPIC | ||
18 | DESTDIR ?= export | ||
19 | BINDIR ?= /usr/bin | ||
20 | -LIBDIR ?= /usr/lib | ||
21 | +base_libdir ?= /lib | ||
22 | +LIBDIR ?= /usr/$(base_libdir) | ||
23 | INCLUDEDIR ?= /usr/include | ||
24 | |||
25 | ifdef COVERAGE | ||
26 | -- | ||
27 | 2.7.4 | ||
28 | |||
diff --git a/recipes-bsp/imx-seco/imx-seco-libs/0001-add-v2x_test-to-the-installed-binaries.patch b/recipes-bsp/imx-seco/imx-seco-libs/0001-add-v2x_test-to-the-installed-binaries.patch new file mode 100644 index 00000000..81a4c17e --- /dev/null +++ b/recipes-bsp/imx-seco/imx-seco-libs/0001-add-v2x_test-to-the-installed-binaries.patch | |||
@@ -0,0 +1,33 @@ | |||
1 | From b62f020ea723dc33f28e5e865d0ddd13219971c9 Mon Sep 17 00:00:00 2001 | ||
2 | From: Cristinel Panfir <cristinel.panfir@nxp.com> | ||
3 | Date: Mon, 29 Mar 2021 15:24:42 +0300 | ||
4 | Subject: [PATCH] Makefile: Add v2x test to the installed-binaries | ||
5 | |||
6 | Upstream-Status: Pending | ||
7 | Signed-off-by: Cristinel Panfir <cristinel.panfir@nxp.com> | ||
8 | [regenerate the patch to be applied after meta-imx patches] | ||
9 | Signed-off-by: Fausto Chiatante <fausto.chiatante@nxp.com> | ||
10 | |||
11 | --- | ||
12 | Makefile | 4 ++-- | ||
13 | 1 file changed, 2 insertions(+), 2 deletions(-) | ||
14 | |||
15 | diff --git a/Makefile b/Makefile | ||
16 | index 25ad333..a397814 100644 | ||
17 | --- a/Makefile | ||
18 | +++ b/Makefile | ||
19 | @@ -61,9 +61,9 @@ hsm_doc: include/hsm/hsm_api.h | ||
20 | cp doc/latex/refman.pdf doc/hsm_api_document.pdf | ||
21 | rm -rf doc/latex/ | ||
22 | |||
23 | -install: hsm_test she_test she_lib.a seco_nvm_manager.a hsm_lib.a | ||
24 | +install: hsm_test she_test v2x_test she_lib.a seco_nvm_manager.a hsm_lib.a | ||
25 | mkdir -p $(DESTDIR)$(BINDIR) $(DESTDIR)$(LIBDIR) $(DESTDIR)$(INCLUDEDIR) | ||
26 | cp seco_nvm_manager.a hsm_lib.a she_lib.a $(DESTDIR)$(LIBDIR) | ||
27 | - cp hsm_test she_test $(DESTDIR)$(BINDIR) | ||
28 | + cp hsm_test she_test v2x_test $(DESTDIR)$(BINDIR) | ||
29 | cp -a include/* $(DESTDIR)$(INCLUDEDIR) | ||
30 | |||
31 | -- | ||
32 | 2.25.1 | ||
33 | |||
diff --git a/recipes-bsp/imx-seco/imx-seco-libs_git.bb b/recipes-bsp/imx-seco/imx-seco-libs_git.bb index 38349f4b..2f59f214 100644 --- a/recipes-bsp/imx-seco/imx-seco-libs_git.bb +++ b/recipes-bsp/imx-seco/imx-seco-libs_git.bb | |||
@@ -8,10 +8,12 @@ LIC_FILES_CHKSUM = "file://EULA.txt;md5=76871788f27c28af824e2ec1ca187832" | |||
8 | 8 | ||
9 | DEPENDS = "zlib" | 9 | DEPENDS = "zlib" |
10 | 10 | ||
11 | SRCBRANCH = "lf-5.10.72_2.2.0" | 11 | SRCBRANCH = "lf-5.15.5_1.0.0" |
12 | SRC_URI = "git://github.com/NXP/imx-seco-libs.git;protocol=https;branch=${SRCBRANCH} \ | 12 | SRC_URI = "git://github.com/NXP/imx-seco-libs.git;protocol=https;branch=${SRCBRANCH} \ |
13 | file://0002-Makefile-Fix-install-to-clear-host-user-contaminated.patch" | 13 | file://0001-Makefile-Fix-LIBDIR-for-multilib.patch \ |
14 | SRCREV = "3e8ad6b168f23a8c6ecd75edabc18d2673403e24" | 14 | file://0002-Makefile-Fix-install-to-clear-host-user-contaminated.patch \ |
15 | file://0001-add-v2x_test-to-the-installed-binaries.patch" | ||
16 | SRCREV = "06a9062cdf51aa29a1c872709e21f927ca00d0b6" | ||
15 | 17 | ||
16 | S = "${WORKDIR}/git" | 18 | S = "${WORKDIR}/git" |
17 | 19 | ||