summaryrefslogtreecommitdiffstats
path: root/recipes-bsp/imx-seco/imx-seco_5.9.0.bb
diff options
context:
space:
mode:
authorOtavio Salvador <otavio@ossystems.com.br>2023-01-10 08:33:58 -0300
committerGitHub <noreply@github.com>2023-01-10 08:33:58 -0300
commitbfc79d62e3048173f893b63f2a7b0484f3e670fb (patch)
treea8273ed5a9b9dc8c70245645e3b0447fe9c7a954 /recipes-bsp/imx-seco/imx-seco_5.9.0.bb
parent8ef79121cc16a5ee3616d115abd809ac615dc187 (diff)
parent7ef6cf54bea75aa456b808226466797613443513 (diff)
downloadmeta-freescale-bfc79d62e3048173f893b63f2a7b0484f3e670fb.tar.gz
Merge pull request #1370 from Freescale/backport-1363-to-kirkstone
[Backport kirkstone] imx-seco Update from lf-5.15.52-2.1.0 to lf-5.15.71-2.2.0
Diffstat (limited to 'recipes-bsp/imx-seco/imx-seco_5.9.0.bb')
-rw-r--r--recipes-bsp/imx-seco/imx-seco_5.9.0.bb27
1 files changed, 27 insertions, 0 deletions
diff --git a/recipes-bsp/imx-seco/imx-seco_5.9.0.bb b/recipes-bsp/imx-seco/imx-seco_5.9.0.bb
new file mode 100644
index 00000000..712be23a
--- /dev/null
+++ b/recipes-bsp/imx-seco/imx-seco_5.9.0.bb
@@ -0,0 +1,27 @@
1# Copyright 2019-2022 NXP
2
3SUMMARY = "NXP i.MX SECO firmware"
4DESCRIPTION = "Firmware for i.MX Security Controller Subsystem"
5SECTION = "base"
6LICENSE = "Proprietary"
7LIC_FILES_CHKSUM = "file://COPYING;md5=5a0bf11f745e68024f37b4724a5364fe"
8
9inherit fsl-eula-unpack use-imx-security-controller-firmware deploy
10
11SRC_URI = "${FSL_MIRROR}/${BP}.bin;fsl-eula=true"
12
13SRC_URI[md5sum] = "b722a534c4d3cc90270e05eaa812514d"
14SRC_URI[sha256sum] = "c3bd761f457e939035b01a0ab36e79064a2a1bc6c3cdb3cd847f7f38df0964df"
15
16
17do_compile[noexec] = "1"
18
19do_install[noexec] = "1"
20
21addtask deploy after do_install
22do_deploy () {
23 # Deploy i.MX8 SECO firmware files
24 install -m 0644 ${S}/firmware/seco/${SECO_FIRMWARE_NAME} ${DEPLOYDIR}
25}
26
27COMPATIBLE_MACHINE = "(mx8qm-nxp-bsp|mx8qxp-nxp-bsp|mx8dxl-nxp-bsp|mx8dx-nxp-bsp)"