summaryrefslogtreecommitdiffstats
path: root/recipes-bsp/imx-seco/imx-seco-libs_git.bb
diff options
context:
space:
mode:
authorAndrey Zhizhikin <andrey.zhizhikin@leica-geosystems.com>2020-08-18 20:21:24 +0000
committerOtavio Salvador <otavio@ossystems.com.br>2020-09-23 23:40:51 -0300
commitda4b4663ac9a6cb6c592ce96d5011345013fd839 (patch)
tree46c2cb6a7cb04464d1ea0d97860fd536c973b3d4 /recipes-bsp/imx-seco/imx-seco-libs_git.bb
parentc0a1a03151b8097e7e9904db3871dc7134074cc5 (diff)
downloadmeta-freescale-da4b4663ac9a6cb6c592ce96d5011345013fd839.tar.gz
imx-seco: upgrade to version 3.6.3
Upstream version has been bumped up, update the recipe to match it. SECO FW name is picked up from the machine definition, as it is now defined in a separate bbclass which allows FW names to be set based on machine's SoC. Signed-off-by: Andrey Zhizhikin <andrey.zhizhikin@leica-geosystems.com>
Diffstat (limited to 'recipes-bsp/imx-seco/imx-seco-libs_git.bb')
-rw-r--r--recipes-bsp/imx-seco/imx-seco-libs_git.bb24
1 files changed, 24 insertions, 0 deletions
diff --git a/recipes-bsp/imx-seco/imx-seco-libs_git.bb b/recipes-bsp/imx-seco/imx-seco-libs_git.bb
new file mode 100644
index 00000000..f292dedd
--- /dev/null
+++ b/recipes-bsp/imx-seco/imx-seco-libs_git.bb
@@ -0,0 +1,24 @@
1# Copyright (C) 2019-2020 NXP
2
3SUMMARY = "NXP i.MX SECO library"
4DESCRIPTION = "NXP IMX SECO library"
5SECTION = "base"
6LICENSE = "Proprietary"
7LIC_FILES_CHKSUM = "file://EULA.txt;md5=228c72f2a91452b8a03c4cab30f30ef9"
8
9DEPENDS = "zlib"
10
11SRCBRANCH = "imx_5.4.24_2.1.0"
12SRC_URI = "git://github.com/NXP/imx-seco-libs.git;protocol=https;branch=${SRCBRANCH}"
13SRCREV = "a4faaa474e49fa0d3668db466739834fe45a6767"
14
15S = "${WORKDIR}/git"
16
17TARGET_CC_ARCH += "${LDFLAGS}"
18
19do_install () {
20 oe_runmake DESTDIR=${D} install
21}
22
23COMPATIBLE_MACHINE = "(mx8)"
24COMPATIBLE_MACHINE_mx8m = "(^$)"