diff options
author | Max Krummenacher <max.krummenacher@toradex.com> | 2020-08-31 16:28:57 +0200 |
---|---|---|
committer | Otavio Salvador <otavio@ossystems.com.br> | 2020-10-02 09:22:30 -0300 |
commit | f607eb8734af83a3667bb4581c1b93307e06d337 (patch) | |
tree | 67a0ca368df49856fd3b26f857777a65d787fc27 /recipes-bsp/imx-mkimage | |
parent | d49ab0d5bbd01d8cca8103668da72962124e14d3 (diff) | |
download | meta-freescale-f607eb8734af83a3667bb4581c1b93307e06d337.tar.gz |
imx-boot: allow for additional/different u-boot device-tree
With the current call to imx-mkimage and SOC_TARGET = "iMX8M" the u-boot
device tree file name is set to $(PLAT)-evk.dtb in iMX8M/soc.mak which
happens to match ${UBOOT_DTB_NAME} if building for an NXP machine.
Setting the dtbs environment variable to ${UBOOT_DTB_NAME} makes the build
succeed also for other machines.
In the hardcoded version $(dtbs) is an intermediate file and gets delete
as the last step of make. Thus for several make targets we have to redo
the copy step before each make invocation or the second one will fail as
the device tree file is then missing.
Signed-off-by: Max Krummenacher <max.krummenacher@toradex.com>
Diffstat (limited to 'recipes-bsp/imx-mkimage')
-rw-r--r-- | recipes-bsp/imx-mkimage/imx-boot_1.0.bb | 6 |
1 files changed, 3 insertions, 3 deletions
diff --git a/recipes-bsp/imx-mkimage/imx-boot_1.0.bb b/recipes-bsp/imx-mkimage/imx-boot_1.0.bb index 4b6ef699..a54b439d 100644 --- a/recipes-bsp/imx-mkimage/imx-boot_1.0.bb +++ b/recipes-bsp/imx-mkimage/imx-boot_1.0.bb | |||
@@ -126,20 +126,20 @@ compile_mx8x() { | |||
126 | fi | 126 | fi |
127 | } | 127 | } |
128 | do_compile() { | 128 | do_compile() { |
129 | compile_${SOC_FAMILY} | ||
130 | # mkimage for i.MX8 | 129 | # mkimage for i.MX8 |
131 | # Copy TEE binary to SoC target folder to mkimage | 130 | # Copy TEE binary to SoC target folder to mkimage |
132 | if ${DEPLOY_OPTEE}; then | 131 | if ${DEPLOY_OPTEE}; then |
133 | cp ${DEPLOY_DIR_IMAGE}/tee.bin ${BOOT_STAGING} | 132 | cp ${DEPLOY_DIR_IMAGE}/tee.bin ${BOOT_STAGING} |
134 | fi | 133 | fi |
135 | for target in ${IMXBOOT_TARGETS}; do | 134 | for target in ${IMXBOOT_TARGETS}; do |
135 | compile_${SOC_FAMILY} | ||
136 | if [ "$target" = "flash_linux_m4_no_v2x" ]; then | 136 | if [ "$target" = "flash_linux_m4_no_v2x" ]; then |
137 | # Special target build for i.MX 8DXL with V2X off | 137 | # Special target build for i.MX 8DXL with V2X off |
138 | bbnote "building ${SOC_TARGET} - ${REV_OPTION} V2X=NO ${target}" | 138 | bbnote "building ${SOC_TARGET} - ${REV_OPTION} V2X=NO ${target}" |
139 | make SOC=${SOC_TARGET} ${REV_OPTION} V2X=NO flash_linux_m4 | 139 | make SOC=${SOC_TARGET} ${REV_OPTION} V2X=NO dtbs=${UBOOT_DTB_NAME} flash_linux_m4 |
140 | else | 140 | else |
141 | bbnote "building ${SOC_TARGET} - ${REV_OPTION} ${target}" | 141 | bbnote "building ${SOC_TARGET} - ${REV_OPTION} ${target}" |
142 | make SOC=${SOC_TARGET} ${REV_OPTION} ${target} | 142 | make SOC=${SOC_TARGET} ${REV_OPTION} dtbs=${UBOOT_DTB_NAME} ${target} |
143 | fi | 143 | fi |
144 | if [ -e "${BOOT_STAGING}/flash.bin" ]; then | 144 | if [ -e "${BOOT_STAGING}/flash.bin" ]; then |
145 | cp ${BOOT_STAGING}/flash.bin ${S}/${BOOT_CONFIG_MACHINE}-${target} | 145 | cp ${BOOT_STAGING}/flash.bin ${S}/${BOOT_CONFIG_MACHINE}-${target} |