diff options
author | Tom Hochstein <tom.hochstein@nxp.com> | 2018-11-29 12:18:56 -0600 |
---|---|---|
committer | Otavio Salvador <otavio@ossystems.com.br> | 2018-12-13 07:26:04 -0200 |
commit | cdda3a3b46e3522ca93af69c6272ab31074b5be9 (patch) | |
tree | 078447b2907a312e475f2ab07e84085efd3976e7 /recipes-bsp/imx-mkimage | |
parent | d9597d0ce603ee99434abd7da0786b7d1cb553e5 (diff) | |
download | meta-freescale-cdda3a3b46e3522ca93af69c6272ab31074b5be9.tar.gz |
imx-mkimage: Add recipe for i.MX 8 boot partition packages
Signed-off-by: Tom Hochstein <tom.hochstein@nxp.com>
Diffstat (limited to 'recipes-bsp/imx-mkimage')
-rw-r--r-- | recipes-bsp/imx-mkimage/imx-mkimage_git.bb | 35 | ||||
-rw-r--r-- | recipes-bsp/imx-mkimage/imx-mkimage_git.inc | 11 |
2 files changed, 46 insertions, 0 deletions
diff --git a/recipes-bsp/imx-mkimage/imx-mkimage_git.bb b/recipes-bsp/imx-mkimage/imx-mkimage_git.bb new file mode 100644 index 00000000..b0a2719f --- /dev/null +++ b/recipes-bsp/imx-mkimage/imx-mkimage_git.bb | |||
@@ -0,0 +1,35 @@ | |||
1 | # Copyright (C) 2016 Freescale Semiconductor | ||
2 | # Copyright 2017-2018 NXP | ||
3 | |||
4 | require imx-mkimage_git.inc | ||
5 | |||
6 | DESCRIPTION = "i.MX make image" | ||
7 | LICENSE = "GPLv2" | ||
8 | LIC_FILES_CHKSUM = "file://${COREBASE}/meta/files/common-licenses/GPL-2.0;md5=801f80980d171dd6425610833a22dbe6" | ||
9 | SECTION = "BSP" | ||
10 | |||
11 | inherit native deploy | ||
12 | |||
13 | CFLAGS = "-O2 -Wall -std=c99 -static -I ${STAGING_INCDIR} -L ${STAGING_LIBDIR}" | ||
14 | |||
15 | do_compile () { | ||
16 | cd ${S} | ||
17 | oe_runmake clean | ||
18 | oe_runmake bin | ||
19 | oe_runmake -C iMX8M -f soc.mak mkimage_imx8 | ||
20 | oe_runmake -C iMX8QM -f soc.mak imx8qm_dcd.cfg.tmp | ||
21 | oe_runmake -C iMX8QX -f soc.mak imx8qx_dcd.cfg.tmp | ||
22 | } | ||
23 | |||
24 | do_install () { | ||
25 | cd ${S} | ||
26 | install -d ${D}${bindir} | ||
27 | install -m 0755 iMX8M/mkimage_imx8 ${D}${bindir}/mkimage_imx8m | ||
28 | install -m 0755 mkimage_imx8 ${D}${bindir}/mkimage_imx8 | ||
29 | } | ||
30 | |||
31 | do_deploy () { | ||
32 | install -m 0644 ${S}/iMX8QM/imx8qm_dcd.cfg.tmp ${DEPLOYDIR} | ||
33 | install -m 0644 ${S}/iMX8QX/imx8qx_dcd.cfg.tmp ${DEPLOYDIR} | ||
34 | } | ||
35 | addtask deploy before do_build after do_install | ||
diff --git a/recipes-bsp/imx-mkimage/imx-mkimage_git.inc b/recipes-bsp/imx-mkimage/imx-mkimage_git.inc new file mode 100644 index 00000000..a8cd930b --- /dev/null +++ b/recipes-bsp/imx-mkimage/imx-mkimage_git.inc | |||
@@ -0,0 +1,11 @@ | |||
1 | # Copyright 2017-2018 NXP | ||
2 | |||
3 | DEPENDS = "zlib-native openssl-native" | ||
4 | |||
5 | SRCBRANCH = "imx_4.9.123_imx8mm_ga" | ||
6 | SRC_URI = "git://source.codeaurora.org/external/imx/imx-mkimage.git;protocol=https;branch=${SRCBRANCH}" | ||
7 | SRCREV = "9e289f314eddb9d38cab73780b936acb30bb88b4" | ||
8 | S = "${WORKDIR}/git" | ||
9 | |||
10 | BOOT_TOOLS = "imx-boot-tools" | ||
11 | SYSROOT_DIRS += "/boot" | ||