diff options
author | Tom Hochstein <tom.hochstein@nxp.com> | 2019-05-22 11:14:18 -0500 |
---|---|---|
committer | Otavio Salvador <otavio@ossystems.com.br> | 2019-06-13 13:27:33 -0300 |
commit | 55785f8d99fd9003fbe6126b7c321887c77aad62 (patch) | |
tree | cd4f0fdba9434673114753d93c7e3a902aa0cb7d /recipes-bsp/imx-mkimage | |
parent | 8c9b42b58e27ab33032ad3e9d1e080aca37bb092 (diff) | |
download | meta-freescale-55785f8d99fd9003fbe6126b7c321887c77aad62.tar.gz |
imx-boot: Upgrade to L4.14.98-2.0.0_ga
- Rename atf binary
- Update intermediate name for u-boot nodtb binary
- Improve whitespace for file copies
Signed-off-by: Tom Hochstein <tom.hochstein@nxp.com>
Diffstat (limited to 'recipes-bsp/imx-mkimage')
-rw-r--r-- | recipes-bsp/imx-mkimage/imx-boot_0.2.bb | 15 |
1 files changed, 9 insertions, 6 deletions
diff --git a/recipes-bsp/imx-mkimage/imx-boot_0.2.bb b/recipes-bsp/imx-mkimage/imx-boot_0.2.bb index 03e99491..296eb437 100644 --- a/recipes-bsp/imx-mkimage/imx-boot_0.2.bb +++ b/recipes-bsp/imx-mkimage/imx-boot_0.2.bb | |||
@@ -36,7 +36,7 @@ SC_FIRMWARE_NAME ?= "scfw_tcm.bin" | |||
36 | 36 | ||
37 | ATF_MACHINE_NAME ?= "bl31-imx8qm.bin" | 37 | ATF_MACHINE_NAME ?= "bl31-imx8qm.bin" |
38 | ATF_MACHINE_NAME_mx8qm = "bl31-imx8qm.bin" | 38 | ATF_MACHINE_NAME_mx8qm = "bl31-imx8qm.bin" |
39 | ATF_MACHINE_NAME_mx8qxp = "bl31-imx8qxp.bin" | 39 | ATF_MACHINE_NAME_mx8qxp = "bl31-imx8qx.bin" |
40 | ATF_MACHINE_NAME_mx8mq = "bl31-imx8mq.bin" | 40 | ATF_MACHINE_NAME_mx8mq = "bl31-imx8mq.bin" |
41 | ATF_MACHINE_NAME_mx8mm = "bl31-imx8mm.bin" | 41 | ATF_MACHINE_NAME_mx8mm = "bl31-imx8mm.bin" |
42 | ATF_MACHINE_NAME_append = "${@bb.utils.contains('COMBINED_FEATURES', 'optee', '-optee', '', d)}" | 42 | ATF_MACHINE_NAME_append = "${@bb.utils.contains('COMBINED_FEATURES', 'optee', '-optee', '', d)}" |
@@ -84,9 +84,11 @@ compile_mx8m() { | |||
84 | cp ${DEPLOY_DIR_IMAGE}/${ddr_firmware} ${BOOT_STAGING} | 84 | cp ${DEPLOY_DIR_IMAGE}/${ddr_firmware} ${BOOT_STAGING} |
85 | done | 85 | done |
86 | cp ${DEPLOY_DIR_IMAGE}/signed_*_imx8m.bin ${BOOT_STAGING} | 86 | cp ${DEPLOY_DIR_IMAGE}/signed_*_imx8m.bin ${BOOT_STAGING} |
87 | cp ${DEPLOY_DIR_IMAGE}/u-boot-spl.bin-${MACHINE}-${UBOOT_CONFIG} ${BOOT_STAGING}/u-boot-spl.bin | 87 | cp ${DEPLOY_DIR_IMAGE}/u-boot-spl.bin-${MACHINE}-${UBOOT_CONFIG} \ |
88 | ${BOOT_STAGING}/u-boot-spl.bin | ||
88 | cp ${DEPLOY_DIR_IMAGE}/${BOOT_TOOLS}/${UBOOT_DTB_NAME} ${BOOT_STAGING} | 89 | cp ${DEPLOY_DIR_IMAGE}/${BOOT_TOOLS}/${UBOOT_DTB_NAME} ${BOOT_STAGING} |
89 | cp ${DEPLOY_DIR_IMAGE}/${BOOT_TOOLS}/u-boot-nodtb.bin ${BOOT_STAGING} | 90 | cp ${DEPLOY_DIR_IMAGE}/${BOOT_TOOLS}/u-boot-nodtb.bin-${MACHINE}-${UBOOT_CONFIG} \ |
91 | ${BOOT_STAGING}/u-boot-nodtb.bin | ||
90 | cp ${DEPLOY_DIR_IMAGE}/${BOOT_TOOLS}/mkimage_uboot ${BOOT_STAGING} | 92 | cp ${DEPLOY_DIR_IMAGE}/${BOOT_TOOLS}/mkimage_uboot ${BOOT_STAGING} |
91 | cp ${DEPLOY_DIR_IMAGE}/${BOOT_TOOLS}/${ATF_MACHINE_NAME} ${BOOT_STAGING}/bl31.bin | 93 | cp ${DEPLOY_DIR_IMAGE}/${BOOT_TOOLS}/${ATF_MACHINE_NAME} ${BOOT_STAGING}/bl31.bin |
92 | cp ${DEPLOY_DIR_IMAGE}/${UBOOT_NAME} ${BOOT_STAGING}/u-boot.bin | 94 | cp ${DEPLOY_DIR_IMAGE}/${UBOOT_NAME} ${BOOT_STAGING}/u-boot.bin |
@@ -126,7 +128,8 @@ do_install () { | |||
126 | 128 | ||
127 | deploy_mx8m() { | 129 | deploy_mx8m() { |
128 | install -d ${DEPLOYDIR}/${BOOT_TOOLS} | 130 | install -d ${DEPLOYDIR}/${BOOT_TOOLS} |
129 | install -m 0644 ${DEPLOY_DIR_IMAGE}/u-boot-spl.bin-${MACHINE}-${UBOOT_CONFIG} ${DEPLOYDIR}/${BOOT_TOOLS} | 131 | install -m 0644 ${DEPLOY_DIR_IMAGE}/u-boot-spl.bin-${MACHINE}-${UBOOT_CONFIG} \ |
132 | ${DEPLOYDIR}/${BOOT_TOOLS} | ||
130 | for ddr_firmware in ${DDR_FIRMWARE_NAME}; do | 133 | for ddr_firmware in ${DDR_FIRMWARE_NAME}; do |
131 | install -m 0644 ${DEPLOY_DIR_IMAGE}/${ddr_firmware} ${DEPLOYDIR}/${BOOT_TOOLS} | 134 | install -m 0644 ${DEPLOY_DIR_IMAGE}/${ddr_firmware} ${DEPLOYDIR}/${BOOT_TOOLS} |
132 | done | 135 | done |
@@ -151,9 +154,9 @@ deploy_mx8x() { | |||
151 | do_deploy() { | 154 | do_deploy() { |
152 | deploy_${SOC_FAMILY} | 155 | deploy_${SOC_FAMILY} |
153 | # copy the tool mkimage to deploy path and sc fw, dcd and uboot | 156 | # copy the tool mkimage to deploy path and sc fw, dcd and uboot |
154 | install -m 0644 ${DEPLOY_DIR_IMAGE}/${UBOOT_NAME} ${DEPLOYDIR}/${BOOT_TOOLS} | 157 | install -m 0644 ${DEPLOY_DIR_IMAGE}/${UBOOT_NAME} ${DEPLOYDIR}/${BOOT_TOOLS} |
155 | # copy makefile (soc.mak) for reference | 158 | # copy makefile (soc.mak) for reference |
156 | install -m 0644 ${BOOT_STAGING}/soc.mak ${DEPLOYDIR}/${BOOT_TOOLS} | 159 | install -m 0644 ${BOOT_STAGING}/soc.mak ${DEPLOYDIR}/${BOOT_TOOLS} |
157 | # copy the generated boot image to deploy path | 160 | # copy the generated boot image to deploy path |
158 | for target in ${IMXBOOT_TARGETS}; do | 161 | for target in ${IMXBOOT_TARGETS}; do |
159 | # Use first "target" as IMAGE_IMXBOOT_TARGET | 162 | # Use first "target" as IMAGE_IMXBOOT_TARGET |