diff options
author | Tom Hochstein <tom.hochstein@nxp.com> | 2022-01-13 17:56:08 -0600 |
---|---|---|
committer | Tom Hochstein <tom.hochstein@nxp.com> | 2022-01-19 15:50:12 -0600 |
commit | 92acf99a6124df0d2e10bf10f296962ab9383ba1 (patch) | |
tree | dc2e1db48c353f686c25aaa7197b713ae6448c04 /recipes-bsp/imx-mkimage | |
parent | 1f270dc776dc70856d645da5cdf1096edf2f369e (diff) | |
download | meta-freescale-92acf99a6124df0d2e10bf10f296962ab9383ba1.tar.gz |
imx-boot,u-boot-imx: Add bootloader image size to SD card image
Append a tag to the bootloader image used in the SD card image. The tag
contains the size of the bootloader image so UUU can easily find the end of
the bootloader in the SD card image.
Signed-off-by: Tom Hochstein <tom.hochstein@nxp.com>
Diffstat (limited to 'recipes-bsp/imx-mkimage')
-rw-r--r-- | recipes-bsp/imx-mkimage/imx-boot_1.0.bb | 10 |
1 files changed, 6 insertions, 4 deletions
diff --git a/recipes-bsp/imx-mkimage/imx-boot_1.0.bb b/recipes-bsp/imx-mkimage/imx-boot_1.0.bb index f8ebb730..b332e079 100644 --- a/recipes-bsp/imx-mkimage/imx-boot_1.0.bb +++ b/recipes-bsp/imx-mkimage/imx-boot_1.0.bb | |||
@@ -24,7 +24,10 @@ DEPENDS:append:mx8m = " u-boot-mkimage-native dtc-native" | |||
24 | BOOT_NAME = "imx-boot" | 24 | BOOT_NAME = "imx-boot" |
25 | PROVIDES = "${BOOT_NAME}" | 25 | PROVIDES = "${BOOT_NAME}" |
26 | 26 | ||
27 | inherit deploy | 27 | inherit deploy uuu_bootloader_tag |
28 | |||
29 | UUU_BOOTLOADER = "${BOOT_NAME}" | ||
30 | UUU_BOOTLOADER_TAGGED = "${BOOT_NAME}-tagged" | ||
28 | 31 | ||
29 | # Add CFLAGS with native INCDIR & LIBDIR for imx-mkimage build | 32 | # Add CFLAGS with native INCDIR & LIBDIR for imx-mkimage build |
30 | CFLAGS = "-O2 -Wall -std=c99 -I ${STAGING_INCDIR_NATIVE} -L ${STAGING_LIBDIR_NATIVE}" | 33 | CFLAGS = "-O2 -Wall -std=c99 -I ${STAGING_INCDIR_NATIVE} -L ${STAGING_LIBDIR_NATIVE}" |
@@ -190,9 +193,8 @@ do_deploy() { | |||
190 | fi | 193 | fi |
191 | install -m 0644 ${S}/${BOOT_CONFIG_MACHINE}-${target} ${DEPLOYDIR} | 194 | install -m 0644 ${S}/${BOOT_CONFIG_MACHINE}-${target} ${DEPLOYDIR} |
192 | done | 195 | done |
193 | cd ${DEPLOYDIR} | 196 | |
194 | ln -sf ${BOOT_CONFIG_MACHINE}-${IMAGE_IMXBOOT_TARGET} ${BOOT_NAME} | 197 | ln -sf ${BOOT_CONFIG_MACHINE}-${IMAGE_IMXBOOT_TARGET} ${DEPLOYDIR}/${BOOT_NAME} |
195 | cd - | ||
196 | } | 198 | } |
197 | addtask deploy before do_build after do_compile | 199 | addtask deploy before do_build after do_compile |
198 | 200 | ||