diff options
author | Tom Hochstein <tom.hochstein@nxp.com> | 2022-08-16 13:12:24 -0500 |
---|---|---|
committer | github-actions[bot] <github-actions[bot]@users.noreply.github.com> | 2022-08-18 11:22:14 +0000 |
commit | 6134e06afe69013176bc29d585d16ee45c8a2b53 (patch) | |
tree | a442c375ad6bb10eda8976d10727de7810241048 /recipes-bsp/imx-mkimage | |
parent | 448a800e7f6e0237d085b9466296dbe145e67925 (diff) | |
download | meta-freescale-6134e06afe69013176bc29d585d16ee45c8a2b53.tar.gz |
imx-mkimage: Update to 5.15.32_2.0.0
Drop patches incorporated in the new version:
- 0001-mkimage_fit_atf-fix-fit-generator-node-naming.patch
- 0001-Add-support-for-overriding-BL32-and-BL33-not-only-BL.patch
- 0001-Add-LDFLAGS-to-link-step.patch
- 0001-Add-support-for-overriding-BL31-BL32-and-BL33.patch
Signed-off-by: Tom Hochstein <tom.hochstein@nxp.com>
(cherry picked from commit ca7d70516fb7855a1e84aebf8b9b1e19ae784385)
Diffstat (limited to 'recipes-bsp/imx-mkimage')
7 files changed, 14 insertions, 233 deletions
diff --git a/recipes-bsp/imx-mkimage/files/0001-Add-LDFLAGS-to-link-step.patch b/recipes-bsp/imx-mkimage/files/0001-Add-LDFLAGS-to-link-step.patch deleted file mode 100644 index f8c68d45..00000000 --- a/recipes-bsp/imx-mkimage/files/0001-Add-LDFLAGS-to-link-step.patch +++ /dev/null | |||
@@ -1,28 +0,0 @@ | |||
1 | From 2a6e2d40a4af78d4a0824e384c3aec55db758fee Mon Sep 17 00:00:00 2001 | ||
2 | From: Erik Larsson <erik.larsson@combitech.se> | ||
3 | Date: Tue, 6 Mar 2018 12:28:39 +0100 | ||
4 | Subject: [PATCH] Add LDFLAGS to link step | ||
5 | |||
6 | Upstream-Status: Pending | ||
7 | |||
8 | Signed-off-by: Erik Larsson <karl.erik.larsson@gmail.com> | ||
9 | --- | ||
10 | iMX8M/soc.mak | 2 +- | ||
11 | 1 file changed, 1 insertion(+), 1 deletion(-) | ||
12 | |||
13 | diff --git a/iMX8M/soc.mak b/iMX8M/soc.mak | ||
14 | index 03b05f7aafeb..4d5df0777704 100644 | ||
15 | --- a/iMX8M/soc.mak | ||
16 | +++ b/iMX8M/soc.mak | ||
17 | @@ -84,7 +84,7 @@ FW_DIR = imx-boot/imx-boot-tools/$(PLAT) | ||
18 | $(MKIMG): mkimage_imx8.c | ||
19 | @echo "PLAT="$(PLAT) "HDMI="$(HDMI) | ||
20 | @echo "Compiling mkimage_imx8" | ||
21 | - $(CC) $(CFLAGS) mkimage_imx8.c -o $(MKIMG) -lz | ||
22 | + $(CC) $(CFLAGS) mkimage_imx8.c -o $(MKIMG) $(BUILD_LDFLAGS) -lz | ||
23 | |||
24 | lpddr4_imem_1d = lpddr4_pmu_train_1d_imem$(LPDDR_FW_VERSION).bin | ||
25 | lpddr4_dmem_1d = lpddr4_pmu_train_1d_dmem$(LPDDR_FW_VERSION).bin | ||
26 | -- | ||
27 | 2.35.1 | ||
28 | |||
diff --git a/recipes-bsp/imx-mkimage/files/0001-Add-support-for-overriding-BL31-BL32-and-BL33.patch b/recipes-bsp/imx-mkimage/files/0001-Add-support-for-overriding-BL31-BL32-and-BL33.patch deleted file mode 100644 index 4e0d954a..00000000 --- a/recipes-bsp/imx-mkimage/files/0001-Add-support-for-overriding-BL31-BL32-and-BL33.patch +++ /dev/null | |||
@@ -1,62 +0,0 @@ | |||
1 | From 8fc8fc3dfce7533b9c965185277d34e27055cc8f Mon Sep 17 00:00:00 2001 | ||
2 | From: Thomas Perrot <thomas.perrot@bootlin.com> | ||
3 | Date: Tue, 26 Apr 2022 15:10:04 +0200 | ||
4 | Subject: [PATCH] Add support for overriding BL31, BL32 and BL33 | ||
5 | |||
6 | Upstream-Status: Pending | ||
7 | |||
8 | Signed-off-by: Thomas Perrot <thomas.perrot@bootlin.com> | ||
9 | --- | ||
10 | iMX8M/print_fit_hab.sh | 14 +++++++++----- | ||
11 | 1 file changed, 9 insertions(+), 5 deletions(-) | ||
12 | |||
13 | diff --git a/iMX8M/print_fit_hab.sh b/iMX8M/print_fit_hab.sh | ||
14 | index b915115d1ecc..dbc28f2d9af5 100755 | ||
15 | --- a/iMX8M/print_fit_hab.sh | ||
16 | +++ b/iMX8M/print_fit_hab.sh | ||
17 | @@ -1,12 +1,16 @@ | ||
18 | #!/bin/bash | ||
19 | |||
20 | -BL32="tee.bin" | ||
21 | - | ||
22 | let fit_off=$1 | ||
23 | |||
24 | # keep backward compatibility | ||
25 | [ -z "$TEE_LOAD_ADDR" ] && TEE_LOAD_ADDR="0xfe000000" | ||
26 | |||
27 | +[ -z "$BL31" ] && BL31="bl31.bin" | ||
28 | + | ||
29 | +[ -z "$BL32" ] && BL32="tee.bin" | ||
30 | + | ||
31 | +[ -z "$BL33" ] && BL33="u-boot-nodtb.bin" | ||
32 | + | ||
33 | if [ -z "$ATF_LOAD_ADDR" ]; then | ||
34 | echo "ERROR: BL31 load address is not set" >&2 | ||
35 | exit 0 | ||
36 | @@ -26,7 +30,7 @@ else | ||
37 | let uboot_sign_off=$((fit_off - 0x8000 - ivt_off + 0x3000)) | ||
38 | fi | ||
39 | |||
40 | -let uboot_size=$(ls -lct u-boot-nodtb.bin | awk '{print $5}') | ||
41 | +let uboot_size=$(ls -lct $BL33 | awk '{print $5}') | ||
42 | let uboot_load_addr=0x40200000 | ||
43 | |||
44 | let last_sign_off=$(((uboot_sign_off + uboot_size + 3) & ~3)) | ||
45 | @@ -64,13 +68,13 @@ done | ||
46 | |||
47 | let atf_sign_off=$((last_sign_off)) | ||
48 | let atf_load_addr=$ATF_LOAD_ADDR | ||
49 | -let atf_size=$(ls -lct bl31.bin | awk '{print $5}') | ||
50 | +let atf_size=$(ls -lct $BL31 | awk '{print $5}') | ||
51 | |||
52 | if [ ! -f $BL32 ]; then | ||
53 | let tee_size=0x0 | ||
54 | let tee_sign_off=$((atf_sign_off + atf_size)) | ||
55 | else | ||
56 | - let tee_size=$(ls -lct tee.bin | awk '{print $5}') | ||
57 | + let tee_size=$(ls -lct $BL32 | awk '{print $5}') | ||
58 | |||
59 | let tee_sign_off=$(((atf_sign_off + atf_size + 3) & ~3)) | ||
60 | let tee_load_addr=$TEE_LOAD_ADDR | ||
61 | -- | ||
62 | 2.35.1 | ||
diff --git a/recipes-bsp/imx-mkimage/files/0001-Add-support-for-overriding-BL32-and-BL33-not-only-BL.patch b/recipes-bsp/imx-mkimage/files/0001-Add-support-for-overriding-BL32-and-BL33-not-only-BL.patch deleted file mode 100644 index 72d83e63..00000000 --- a/recipes-bsp/imx-mkimage/files/0001-Add-support-for-overriding-BL32-and-BL33-not-only-BL.patch +++ /dev/null | |||
@@ -1,71 +0,0 @@ | |||
1 | From ef28030129a04b1d70dbca3f2236fe7b1c67b4ed Mon Sep 17 00:00:00 2001 | ||
2 | From: Erik Larsson <erik.larsson@combitech.se> | ||
3 | Date: Thu, 8 Mar 2018 19:04:37 +0100 | ||
4 | Subject: [PATCH] Add support for overriding BL32 and BL33 not only BL31 | ||
5 | |||
6 | Upstream-Status: Pending | ||
7 | |||
8 | Signed-off-by: Erik Larsson <karl.erik.larsson@gmail.com> | ||
9 | Signed-off-by: Christopher Dahlberg <crille.dahlberg@gmail.com> | ||
10 | Signed-off-by: Marcus Folkesson <marcus.folkesson@gmail.com> | ||
11 | Signed-off-by: Thomas Perrot <thomas.perrot@bootlin.com> | ||
12 | --- | ||
13 | iMX8M/mkimage_fit_atf.sh | 19 ++++++++++--------- | ||
14 | 1 file changed, 10 insertions(+), 9 deletions(-) | ||
15 | |||
16 | diff --git a/iMX8M/mkimage_fit_atf.sh b/iMX8M/mkimage_fit_atf.sh | ||
17 | index 10903ea3bbf5..341a4b3da1ef 100755 | ||
18 | --- a/iMX8M/mkimage_fit_atf.sh | ||
19 | +++ b/iMX8M/mkimage_fit_atf.sh | ||
20 | @@ -6,6 +6,7 @@ | ||
21 | # usage: $0 <dt_name> [<dt_name> [<dt_name] ...] | ||
22 | |||
23 | [ -z "$BL31" ] && BL31="bl31.bin" | ||
24 | + | ||
25 | # keep backward compatibility | ||
26 | [ -z "$TEE_LOAD_ADDR" ] && TEE_LOAD_ADDR="0xfe000000" | ||
27 | |||
28 | @@ -18,23 +19,23 @@ if [ ! -f $BL31 ]; then | ||
29 | echo "ERROR: BL31 file $BL31 NOT found" >&2 | ||
30 | exit 0 | ||
31 | else | ||
32 | - echo "bl31.bin size: " >&2 | ||
33 | - ls -lct bl31.bin | awk '{print $5}' >&2 | ||
34 | + echo "$BL31 size: " >&2 | ||
35 | + ls -lct $BL31 | awk '{print $5}' >&2 | ||
36 | fi | ||
37 | |||
38 | -BL32="tee.bin" | ||
39 | +[ -z "$BL32" ] && BL32="tee.bin" | ||
40 | LOADABLES="\"atf-1\"" | ||
41 | |||
42 | if [ ! -f $BL32 ]; then | ||
43 | BL32=/dev/null | ||
44 | else | ||
45 | - echo "Building with TEE support, make sure your bl31 is compiled with spd. If you do not want tee, please delete tee.bin" >&2 | ||
46 | - echo "tee.bin size: " >&2 | ||
47 | - ls -lct tee.bin | awk '{print $5}' >&2 | ||
48 | + echo "Building with TEE support, make sure $BL31 is compiled with spd. If you do not want tee, please delete $BL32" >&2 | ||
49 | + echo "$BL32 size: " >&2 | ||
50 | + ls -lct $BL32 | awk '{print $5}' >&2 | ||
51 | LOADABLES="$LOADABLES, \"tee-1\"" | ||
52 | fi | ||
53 | |||
54 | -BL33="u-boot-nodtb.bin" | ||
55 | +[ -z "$BL33" ] && BL33="u-boot-nodtb.bin" | ||
56 | DEK_BLOB="dek_blob_fit_dummy.bin" | ||
57 | |||
58 | if [ ! -f $DEK_BLOB ]; then | ||
59 | @@ -49,8 +50,8 @@ if [ ! -f $BL33 ]; then | ||
60 | exit 0 | ||
61 | else | ||
62 | |||
63 | - echo "u-boot-nodtb.bin size: " >&2 | ||
64 | - ls -lct u-boot-nodtb.bin | awk '{print $5}' >&2 | ||
65 | + echo "$BL33 size: " >&2 | ||
66 | + ls -lct $BL33 | awk '{print $5}' >&2 | ||
67 | fi | ||
68 | |||
69 | for dtname in $* | ||
70 | -- | ||
71 | 2.35.1 | ||
diff --git a/recipes-bsp/imx-mkimage/files/0001-iMX8M-soc.mak-use-native-mkimage-from-sysroot.patch b/recipes-bsp/imx-mkimage/files/0001-iMX8M-soc.mak-use-native-mkimage-from-sysroot.patch index a879208c..e82b6bee 100644 --- a/recipes-bsp/imx-mkimage/files/0001-iMX8M-soc.mak-use-native-mkimage-from-sysroot.patch +++ b/recipes-bsp/imx-mkimage/files/0001-iMX8M-soc.mak-use-native-mkimage-from-sysroot.patch | |||
@@ -1,4 +1,4 @@ | |||
1 | From a4af3747abd88247bf4498ec0cf67a4151e64d41 Mon Sep 17 00:00:00 2001 | 1 | From 2734c670dc4062015d05559a94fa988da5d705e6 Mon Sep 17 00:00:00 2001 |
2 | From: Andrey Zhizhikin <andrey.z@gmail.com> | 2 | From: Andrey Zhizhikin <andrey.z@gmail.com> |
3 | Date: Thu, 21 Oct 2021 08:53:38 +0000 | 3 | Date: Thu, 21 Oct 2021 08:53:38 +0000 |
4 | Subject: [PATCH] iMX8M: soc.mak: use native mkimage from sysroot | 4 | Subject: [PATCH] iMX8M: soc.mak: use native mkimage from sysroot |
@@ -21,19 +21,19 @@ Signed-off-by: Andrey Zhizhikin <andrey.z@gmail.com> | |||
21 | 1 file changed, 5 insertions(+), 6 deletions(-) | 21 | 1 file changed, 5 insertions(+), 6 deletions(-) |
22 | 22 | ||
23 | diff --git a/iMX8M/soc.mak b/iMX8M/soc.mak | 23 | diff --git a/iMX8M/soc.mak b/iMX8M/soc.mak |
24 | index 4bfdc37..03b05f7 100644 | 24 | index a98195e..60502d8 100644 |
25 | --- a/iMX8M/soc.mak | 25 | --- a/iMX8M/soc.mak |
26 | +++ b/iMX8M/soc.mak | 26 | +++ b/iMX8M/soc.mak |
27 | @@ -148,7 +148,7 @@ u-boot.itb: $(dtb) | 27 | @@ -149,7 +149,7 @@ u-boot.itb: $(dtb) |
28 | ./$(PAD_IMAGE) bl31.bin | 28 | ./$(PAD_IMAGE) bl31.bin |
29 | ./$(PAD_IMAGE) u-boot-nodtb.bin $(dtb) | 29 | ./$(PAD_IMAGE) u-boot-nodtb.bin $(dtb) |
30 | DEK_BLOB_LOAD_ADDR=$(DEK_BLOB_LOAD_ADDR) TEE_LOAD_ADDR=$(TEE_LOAD_ADDR) ATF_LOAD_ADDR=$(ATF_LOAD_ADDR) ./mkimage_fit_atf.sh $(dtb) > u-boot.its | 30 | BL32=$(TEE) DEK_BLOB_LOAD_ADDR=$(DEK_BLOB_LOAD_ADDR) TEE_LOAD_ADDR=$(TEE_LOAD_ADDR) ATF_LOAD_ADDR=$(ATF_LOAD_ADDR) ./mkimage_fit_atf.sh $(dtb) > u-boot.its |
31 | - ./mkimage_uboot -E -p 0x3000 -f u-boot.its u-boot.itb | 31 | - ./mkimage_uboot -E -p 0x3000 -f u-boot.its u-boot.itb |
32 | + mkimage -E -p 0x3000 -f u-boot.its u-boot.itb | 32 | + mkimage -E -p 0x3000 -f u-boot.its u-boot.itb |
33 | @rm -f u-boot.its $(dtb) | 33 | @rm -f u-boot.its $(dtb) |
34 | 34 | ||
35 | dtb_ddr3l = valddr3l.dtb | 35 | dtb_ddr3l = valddr3l.dtb |
36 | @@ -160,7 +160,7 @@ u-boot-ddr3l.itb: $(dtb_ddr3l) | 36 | @@ -161,7 +161,7 @@ u-boot-ddr3l.itb: $(dtb_ddr3l) |
37 | ./$(PAD_IMAGE) bl31.bin | 37 | ./$(PAD_IMAGE) bl31.bin |
38 | ./$(PAD_IMAGE) u-boot-nodtb.bin $(dtb_ddr3l) | 38 | ./$(PAD_IMAGE) u-boot-nodtb.bin $(dtb_ddr3l) |
39 | DEK_BLOB_LOAD_ADDR=$(DEK_BLOB_LOAD_ADDR) TEE_LOAD_ADDR=$(TEE_LOAD_ADDR) ATF_LOAD_ADDR=$(ATF_LOAD_ADDR) ./mkimage_fit_atf.sh $(dtb_ddr3l) > u-boot-ddr3l.its | 39 | DEK_BLOB_LOAD_ADDR=$(DEK_BLOB_LOAD_ADDR) TEE_LOAD_ADDR=$(TEE_LOAD_ADDR) ATF_LOAD_ADDR=$(ATF_LOAD_ADDR) ./mkimage_fit_atf.sh $(dtb_ddr3l) > u-boot-ddr3l.its |
@@ -42,7 +42,7 @@ index 4bfdc37..03b05f7 100644 | |||
42 | @rm -f u-boot.its $(dtb_ddr3l) | 42 | @rm -f u-boot.its $(dtb_ddr3l) |
43 | 43 | ||
44 | dtb_ddr3l_evk = evkddr3l.dtb | 44 | dtb_ddr3l_evk = evkddr3l.dtb |
45 | @@ -172,7 +172,7 @@ u-boot-ddr3l-evk.itb: $(dtb_ddr3l_evk) | 45 | @@ -173,7 +173,7 @@ u-boot-ddr3l-evk.itb: $(dtb_ddr3l_evk) |
46 | ./$(PAD_IMAGE) bl31.bin | 46 | ./$(PAD_IMAGE) bl31.bin |
47 | ./$(PAD_IMAGE) u-boot-nodtb.bin $(dtb_ddr3l_evk) | 47 | ./$(PAD_IMAGE) u-boot-nodtb.bin $(dtb_ddr3l_evk) |
48 | DEK_BLOB_LOAD_ADDR=$(DEK_BLOB_LOAD_ADDR) TEE_LOAD_ADDR=$(TEE_LOAD_ADDR) ATF_LOAD_ADDR=$(ATF_LOAD_ADDR) ./mkimage_fit_atf.sh $(dtb_ddr3l_evk) > u-boot-ddr3l-evk.its | 48 | DEK_BLOB_LOAD_ADDR=$(DEK_BLOB_LOAD_ADDR) TEE_LOAD_ADDR=$(TEE_LOAD_ADDR) ATF_LOAD_ADDR=$(ATF_LOAD_ADDR) ./mkimage_fit_atf.sh $(dtb_ddr3l_evk) > u-boot-ddr3l-evk.its |
@@ -51,7 +51,7 @@ index 4bfdc37..03b05f7 100644 | |||
51 | @rm -f u-boot.its $(dtb_ddr3l_evk) | 51 | @rm -f u-boot.its $(dtb_ddr3l_evk) |
52 | 52 | ||
53 | dtb_ddr4 = valddr4.dtb | 53 | dtb_ddr4 = valddr4.dtb |
54 | @@ -184,7 +184,7 @@ u-boot-ddr4.itb: $(dtb_ddr4) | 54 | @@ -185,7 +185,7 @@ u-boot-ddr4.itb: $(dtb_ddr4) |
55 | ./$(PAD_IMAGE) bl31.bin | 55 | ./$(PAD_IMAGE) bl31.bin |
56 | ./$(PAD_IMAGE) u-boot-nodtb.bin $(dtb_ddr4) | 56 | ./$(PAD_IMAGE) u-boot-nodtb.bin $(dtb_ddr4) |
57 | DEK_BLOB_LOAD_ADDR=$(DEK_BLOB_LOAD_ADDR) TEE_LOAD_ADDR=$(TEE_LOAD_ADDR) ATF_LOAD_ADDR=$(ATF_LOAD_ADDR) ./mkimage_fit_atf.sh $(dtb_ddr4) > u-boot-ddr4.its | 57 | DEK_BLOB_LOAD_ADDR=$(DEK_BLOB_LOAD_ADDR) TEE_LOAD_ADDR=$(TEE_LOAD_ADDR) ATF_LOAD_ADDR=$(ATF_LOAD_ADDR) ./mkimage_fit_atf.sh $(dtb_ddr4) > u-boot-ddr4.its |
@@ -60,7 +60,7 @@ index 4bfdc37..03b05f7 100644 | |||
60 | @rm -f u-boot.its $(dtb_ddr4) | 60 | @rm -f u-boot.its $(dtb_ddr4) |
61 | 61 | ||
62 | dtb_ddr4_evk = evkddr4.dtb | 62 | dtb_ddr4_evk = evkddr4.dtb |
63 | @@ -196,7 +196,7 @@ u-boot-ddr4-evk.itb: $(dtb_ddr4_evk) | 63 | @@ -197,7 +197,7 @@ u-boot-ddr4-evk.itb: $(dtb_ddr4_evk) |
64 | ./$(PAD_IMAGE) bl31.bin | 64 | ./$(PAD_IMAGE) bl31.bin |
65 | ./$(PAD_IMAGE) u-boot-nodtb.bin $(dtb_ddr4_evk) | 65 | ./$(PAD_IMAGE) u-boot-nodtb.bin $(dtb_ddr4_evk) |
66 | DEK_BLOB_LOAD_ADDR=$(DEK_BLOB_LOAD_ADDR) TEE_LOAD_ADDR=$(TEE_LOAD_ADDR) ATF_LOAD_ADDR=$(ATF_LOAD_ADDR) ./mkimage_fit_atf.sh $(dtb_ddr4_evk) > u-boot-ddr4-evk.its | 66 | DEK_BLOB_LOAD_ADDR=$(DEK_BLOB_LOAD_ADDR) TEE_LOAD_ADDR=$(TEE_LOAD_ADDR) ATF_LOAD_ADDR=$(ATF_LOAD_ADDR) ./mkimage_fit_atf.sh $(dtb_ddr4_evk) > u-boot-ddr4-evk.its |
@@ -69,7 +69,7 @@ index 4bfdc37..03b05f7 100644 | |||
69 | @rm -f u-boot.its $(dtb_ddr4_evk) | 69 | @rm -f u-boot.its $(dtb_ddr4_evk) |
70 | 70 | ||
71 | ifeq ($(HDMI),yes) | 71 | ifeq ($(HDMI),yes) |
72 | @@ -312,7 +312,6 @@ nightly : | 72 | @@ -318,7 +318,6 @@ nightly : |
73 | @$(WGET) -q $(SERVER)/$(DIR)/$(FW_DIR)/fsl-$(PLAT)-evk.dtb -O fsl-$(PLAT)-evk.dtb | 73 | @$(WGET) -q $(SERVER)/$(DIR)/$(FW_DIR)/fsl-$(PLAT)-evk.dtb -O fsl-$(PLAT)-evk.dtb |
74 | @$(WGET) -q $(SERVER)/$(DIR)/$(FW_DIR)/signed_hdmi_imx8m.bin -O signed_hdmi_imx8m.bin | 74 | @$(WGET) -q $(SERVER)/$(DIR)/$(FW_DIR)/signed_hdmi_imx8m.bin -O signed_hdmi_imx8m.bin |
75 | @$(WGET) -q $(SERVER)/$(DIR)/$(FW_DIR)/signed_dp_imx8m.bin -O signed_dp_imx8m.bin | 75 | @$(WGET) -q $(SERVER)/$(DIR)/$(FW_DIR)/signed_dp_imx8m.bin -O signed_dp_imx8m.bin |
diff --git a/recipes-bsp/imx-mkimage/files/0001-mkimage_fit_atf-fix-fit-generator-node-naming.patch b/recipes-bsp/imx-mkimage/files/0001-mkimage_fit_atf-fix-fit-generator-node-naming.patch deleted file mode 100644 index 5a4a895b..00000000 --- a/recipes-bsp/imx-mkimage/files/0001-mkimage_fit_atf-fix-fit-generator-node-naming.patch +++ /dev/null | |||
@@ -1,55 +0,0 @@ | |||
1 | From f281b935985f1b592534ee2837ce0d0b28c7dc43 Mon Sep 17 00:00:00 2001 | ||
2 | From: Andrey Zhizhikin <andrey.z@gmail.com> | ||
3 | Date: Tue, 11 Jan 2022 15:32:05 -0600 | ||
4 | Subject: [PATCH] mkimage_fit_atf: fix fit generator node naming | ||
5 | |||
6 | Extend sections which contains "firmware" in their types with "os" | ||
7 | parameter to conform to the latest FIT specification. | ||
8 | |||
9 | Indicate that load and entry addresses are covered by one 32-bit value | ||
10 | by adding "address-cells" in the root node of the generated ITS. | ||
11 | |||
12 | Upstream-Status: Inappropriate [script is imx-boot specific] | ||
13 | Link: [1] https://github.com/u-boot/u-boot/commit/79af75f7776fc20b0d7eb6afe1e27c00fdb4b9b4 | ||
14 | Signed-off-by: Andrey Zhizhikin <andrey.z@gmail.com> | ||
15 | Cc: Tom Hochstein <tom.hochstein@nxp.com> | ||
16 | --- | ||
17 | iMX8M/mkimage_fit_atf.sh | 4 ++++ | ||
18 | 1 file changed, 4 insertions(+) | ||
19 | |||
20 | diff --git a/iMX8M/mkimage_fit_atf.sh b/iMX8M/mkimage_fit_atf.sh | ||
21 | index 4f2b3f3..10903ea 100755 | ||
22 | --- a/iMX8M/mkimage_fit_atf.sh | ||
23 | +++ b/iMX8M/mkimage_fit_atf.sh | ||
24 | @@ -64,10 +64,12 @@ cat << __HEADER_EOF | ||
25 | |||
26 | / { | ||
27 | description = "Configuration to load ATF before U-Boot"; | ||
28 | + #address-cells = <1>; | ||
29 | |||
30 | images { | ||
31 | uboot-1 { | ||
32 | description = "U-Boot (64-bit)"; | ||
33 | + os = "u-boot"; | ||
34 | data = /incbin/("$BL33"); | ||
35 | type = "standalone"; | ||
36 | arch = "arm64"; | ||
37 | @@ -93,6 +95,7 @@ done | ||
38 | cat << __HEADER_EOF | ||
39 | atf-1 { | ||
40 | description = "ARM Trusted Firmware"; | ||
41 | + os = "arm-trusted-firmware"; | ||
42 | data = /incbin/("$BL31"); | ||
43 | type = "firmware"; | ||
44 | arch = "arm64"; | ||
45 | @@ -106,6 +109,7 @@ if [ -f $BL32 ]; then | ||
46 | cat << __HEADER_EOF | ||
47 | tee-1 { | ||
48 | description = "TEE firmware"; | ||
49 | + os = "op-tee-firmware"; | ||
50 | data = /incbin/("$BL32"); | ||
51 | type = "firmware"; | ||
52 | arch = "arm64"; | ||
53 | -- | ||
54 | 2.17.1 | ||
55 | |||
diff --git a/recipes-bsp/imx-mkimage/imx-mkimage_git.bb b/recipes-bsp/imx-mkimage/imx-mkimage_git.bb index 4906121f..0add1c92 100644 --- a/recipes-bsp/imx-mkimage/imx-mkimage_git.bb +++ b/recipes-bsp/imx-mkimage/imx-mkimage_git.bb | |||
@@ -1,5 +1,5 @@ | |||
1 | # Copyright (C) 2016 Freescale Semiconductor | 1 | # Copyright (C) 2016 Freescale Semiconductor |
2 | # Copyright (C) 2017-2021 NXP | 2 | # Copyright (C) 2017-2022 NXP |
3 | 3 | ||
4 | require imx-mkimage_git.inc | 4 | require imx-mkimage_git.inc |
5 | 5 | ||
diff --git a/recipes-bsp/imx-mkimage/imx-mkimage_git.inc b/recipes-bsp/imx-mkimage/imx-mkimage_git.inc index 165ba64e..6db6a883 100644 --- a/recipes-bsp/imx-mkimage/imx-mkimage_git.inc +++ b/recipes-bsp/imx-mkimage/imx-mkimage_git.inc | |||
@@ -1,16 +1,13 @@ | |||
1 | # Copyright 2017-2021 NXP | 1 | # Copyright 2017-2022 NXP |
2 | 2 | ||
3 | DEPENDS = "zlib-native openssl-native" | 3 | DEPENDS = "zlib-native openssl-native" |
4 | 4 | ||
5 | SRCBRANCH = "lf-5.15.5_1.0.0" | ||
6 | SRC_URI = "git://source.codeaurora.org/external/imx/imx-mkimage.git;protocol=https;branch=${SRCBRANCH} \ | 5 | SRC_URI = "git://source.codeaurora.org/external/imx/imx-mkimage.git;protocol=https;branch=${SRCBRANCH} \ |
7 | file://0001-mkimage_fit_atf-fix-fit-generator-node-naming.patch \ | ||
8 | file://0001-iMX8M-soc.mak-use-native-mkimage-from-sysroot.patch \ | 6 | file://0001-iMX8M-soc.mak-use-native-mkimage-from-sysroot.patch \ |
9 | file://0001-Add-support-for-overriding-BL32-and-BL33-not-only-BL.patch \ | ||
10 | file://0001-Add-LDFLAGS-to-link-step.patch \ | ||
11 | file://0001-Add-support-for-overriding-BL31-BL32-and-BL33.patch \ | ||
12 | " | 7 | " |
13 | SRCREV = "22346a32a88aa752d4bad8f2ed1eb641e18849dc" | 8 | SRCBRANCH = "lf-5.15.32_2.0.0" |
9 | SRCREV = "a8bb8edb45492ac70b33734122a57aa8e38a20bd" | ||
10 | |||
14 | S = "${WORKDIR}/git" | 11 | S = "${WORKDIR}/git" |
15 | 12 | ||
16 | BOOT_TOOLS = "imx-boot-tools" | 13 | BOOT_TOOLS = "imx-boot-tools" |