summaryrefslogtreecommitdiffstats
path: root/recipes-bsp/imx-mkimage/imx-boot_1.0.bb
diff options
context:
space:
mode:
authorOtavio Salvador <otavio@ossystems.com.br>2022-07-26 15:59:38 -0300
committerOtavio Salvador <otavio@ossystems.com.br>2022-07-29 13:23:06 -0300
commit63d73925950aa35ec1378696c0f5dcfd2fef9e83 (patch)
tree78ea8c91fab158055ebc70ee36cb0e8fa66d421f /recipes-bsp/imx-mkimage/imx-boot_1.0.bb
parent0d87d90f79c381dfc1a92548bd19600a23376a98 (diff)
downloadmeta-freescale-63d73925950aa35ec1378696c0f5dcfd2fef9e83.tar.gz
imx-base.inc: consolidate `IMX_EXTRA_FIRMWARE` definition
We should have a single definition for `IMX_EXTRA_FIRMWARE` variable as this is SoC specific and not machine, or recipe, dependent. This removes multiple assignments from: - conf/machine/imx8mq-evk.conf - conf/machine/include/imx8mm-evk.inc - conf/machine/include/imx8mn-evk.inc - conf/machine/include/imx8mp-evk.inc - recipes-bsp/imx-mkimage/imx-boot_1.0.bb Signed-off-by: Otavio Salvador <otavio@ossystems.com.br>
Diffstat (limited to 'recipes-bsp/imx-mkimage/imx-boot_1.0.bb')
-rw-r--r--recipes-bsp/imx-mkimage/imx-boot_1.0.bb3
1 files changed, 0 insertions, 3 deletions
diff --git a/recipes-bsp/imx-mkimage/imx-boot_1.0.bb b/recipes-bsp/imx-mkimage/imx-boot_1.0.bb
index f35561de..ae7e2638 100644
--- a/recipes-bsp/imx-mkimage/imx-boot_1.0.bb
+++ b/recipes-bsp/imx-mkimage/imx-boot_1.0.bb
@@ -9,9 +9,6 @@ SECTION = "BSP"
9 9
10inherit use-imx-security-controller-firmware uboot-sign 10inherit use-imx-security-controller-firmware uboot-sign
11 11
12IMX_EXTRA_FIRMWARE = "firmware-imx-8 imx-sc-firmware imx-seco"
13IMX_EXTRA_FIRMWARE:mx8m-generic-bsp = "firmware-imx-8m"
14IMX_EXTRA_FIRMWARE:mx8x-generic-bsp = "imx-sc-firmware imx-seco"
15DEPENDS += " \ 12DEPENDS += " \
16 u-boot \ 13 u-boot \
17 ${IMX_EXTRA_FIRMWARE} \ 14 ${IMX_EXTRA_FIRMWARE} \