diff options
author | Nathan Rossi <nathan.rossi@digi.com> | 2021-04-20 07:02:51 +0000 |
---|---|---|
committer | Otavio Salvador <otavio@ossystems.com.br> | 2021-04-20 10:26:07 -0300 |
commit | 71a0623ada456790778213a0ea2bb6b1535bd069 (patch) | |
tree | cf0a5dd78ccf54b61f631caea81ed99fe9b04437 /recipes-bsp/imx-mkimage/imx-boot_1.0.bb | |
parent | ce44cd98c4556668f485d5b6d2ff4b52621c7e9c (diff) | |
download | meta-freescale-71a0623ada456790778213a0ea2bb6b1535bd069.tar.gz |
imx-boot: Add dependency on xxd-native
The fspi_packer.sh script uses xxd in order to generate the SPI flash
configuration header. If xxd is missing no error is produced and the
output image does not work. The log however contains the following error
messages (e.g. for iMX8MP flash_evk_flexspi target):
./../scripts/fspi_packer.sh ../scripts/fspi_header
./../scripts/fspi_packer.sh: 5: xxd: not found
dd: failed to open 'qspi-header': No such file or directory
3333+1 records in
3333+1 records out
3413776 bytes (3.4 MB, 3.3 MiB) copied, 0.00566483 s, 603 MB/s
dd: failed to open 'qspi-header.off': No such file or directory
cp: cannot stat 'qspi-header.off': No such file or directory
rm: cannot remove 'qspi-header*': No such file or directory
F(Q)SPI IMAGE PACKED
xxd is not in HOSTTOOLS or HOSTTOOLS_NONFATAL, as such the explicit
DEPENDS is required.
Signed-off-by: Nathan Rossi <nathan.rossi@digi.com>
Diffstat (limited to 'recipes-bsp/imx-mkimage/imx-boot_1.0.bb')
-rw-r--r-- | recipes-bsp/imx-mkimage/imx-boot_1.0.bb | 2 |
1 files changed, 2 insertions, 0 deletions
diff --git a/recipes-bsp/imx-mkimage/imx-boot_1.0.bb b/recipes-bsp/imx-mkimage/imx-boot_1.0.bb index ba1507eb..422670be 100644 --- a/recipes-bsp/imx-mkimage/imx-boot_1.0.bb +++ b/recipes-bsp/imx-mkimage/imx-boot_1.0.bb | |||
@@ -18,6 +18,8 @@ DEPENDS += " \ | |||
18 | imx-atf \ | 18 | imx-atf \ |
19 | ${@bb.utils.contains('MACHINE_FEATURES', 'optee', 'optee-os', '', d)} \ | 19 | ${@bb.utils.contains('MACHINE_FEATURES', 'optee', 'optee-os', '', d)} \ |
20 | " | 20 | " |
21 | # xxd is a dependency of fspi_packer.sh | ||
22 | DEPENDS += "xxd-native" | ||
21 | DEPENDS_append_mx8m = " u-boot-mkimage-native dtc-native" | 23 | DEPENDS_append_mx8m = " u-boot-mkimage-native dtc-native" |
22 | BOOT_NAME = "imx-boot" | 24 | BOOT_NAME = "imx-boot" |
23 | PROVIDES = "${BOOT_NAME}" | 25 | PROVIDES = "${BOOT_NAME}" |