summaryrefslogtreecommitdiffstats
path: root/recipes-bsp/imx-mkimage/imx-boot_0.2.bb
diff options
context:
space:
mode:
authorTom Hochstein <tom.hochstein@nxp.com>2019-05-22 13:52:36 -0500
committerOtavio Salvador <otavio@ossystems.com.br>2019-06-13 13:27:33 -0300
commitc14fa7277c3b827f67310954108b58a8ef39c232 (patch)
tree0b270dade926ab01d47755466fd77c79b22b17f5 /recipes-bsp/imx-mkimage/imx-boot_0.2.bb
parentc1f07bafafa08e06336dd63ae5620a97b651228b (diff)
downloadmeta-freescale-c14fa7277c3b827f67310954108b58a8ef39c232.tar.gz
imx-boot: Drop independent DCD component
The DCD component has moved into the firmware. Signed-off-by: Tom Hochstein <tom.hochstein@nxp.com>
Diffstat (limited to 'recipes-bsp/imx-mkimage/imx-boot_0.2.bb')
-rw-r--r--recipes-bsp/imx-mkimage/imx-boot_0.2.bb8
1 files changed, 0 insertions, 8 deletions
diff --git a/recipes-bsp/imx-mkimage/imx-boot_0.2.bb b/recipes-bsp/imx-mkimage/imx-boot_0.2.bb
index bd57dd03..13e161ac 100644
--- a/recipes-bsp/imx-mkimage/imx-boot_0.2.bb
+++ b/recipes-bsp/imx-mkimage/imx-boot_0.2.bb
@@ -41,10 +41,6 @@ ATF_MACHINE_NAME_mx8mq = "bl31-imx8mq.bin"
41ATF_MACHINE_NAME_mx8mm = "bl31-imx8mm.bin" 41ATF_MACHINE_NAME_mx8mm = "bl31-imx8mm.bin"
42ATF_MACHINE_NAME_append = "${@bb.utils.contains('COMBINED_FEATURES', 'optee', '-optee', '', d)}" 42ATF_MACHINE_NAME_append = "${@bb.utils.contains('COMBINED_FEATURES', 'optee', '-optee', '', d)}"
43 43
44DCD_NAME ?= "imx8qm_dcd.cfg.tmp"
45DCD_NAME_mx8qm = "imx8qm_dcd.cfg.tmp"
46DCD_NAME_mx8qxp = "imx8qx_dcd.cfg.tmp"
47
48UBOOT_NAME = "u-boot-${MACHINE}.bin-${UBOOT_CONFIG}" 44UBOOT_NAME = "u-boot-${MACHINE}.bin-${UBOOT_CONFIG}"
49BOOT_CONFIG_MACHINE = "${BOOT_NAME}-${MACHINE}-${UBOOT_CONFIG}.bin" 45BOOT_CONFIG_MACHINE = "${BOOT_NAME}-${MACHINE}-${UBOOT_CONFIG}.bin"
50 46
@@ -141,15 +137,11 @@ deploy_mx8m() {
141} 137}
142deploy_mx8() { 138deploy_mx8() {
143 install -d ${DEPLOYDIR}/${BOOT_TOOLS} 139 install -d ${DEPLOYDIR}/${BOOT_TOOLS}
144 install -m 0644 ${BOOT_STAGING}/${DCD_NAME} ${DEPLOYDIR}/${BOOT_TOOLS}
145 install -m 0644 ${BOOT_STAGING}/mx8qm-ahab-container.img ${DEPLOYDIR}/${BOOT_TOOLS} 140 install -m 0644 ${BOOT_STAGING}/mx8qm-ahab-container.img ${DEPLOYDIR}/${BOOT_TOOLS}
146 install -m 0755 ${S}/${TOOLS_NAME} ${DEPLOYDIR}/${BOOT_TOOLS} 141 install -m 0755 ${S}/${TOOLS_NAME} ${DEPLOYDIR}/${BOOT_TOOLS}
147} 142}
148deploy_mx8x() { 143deploy_mx8x() {
149 install -d ${DEPLOYDIR}/${BOOT_TOOLS} 144 install -d ${DEPLOYDIR}/${BOOT_TOOLS}
150 if [ "${MACHINE}" = "imx8qxpa0mek" ]; then
151 install -m 0644 ${BOOT_STAGING}/${DCD_NAME} ${DEPLOYDIR}/${BOOT_TOOLS}
152 fi
153 install -m 0644 ${BOOT_STAGING}/mx8qx-ahab-container.img ${DEPLOYDIR}/${BOOT_TOOLS} 145 install -m 0644 ${BOOT_STAGING}/mx8qx-ahab-container.img ${DEPLOYDIR}/${BOOT_TOOLS}
154 install -m 0755 ${S}/${TOOLS_NAME} ${DEPLOYDIR}/${BOOT_TOOLS} 146 install -m 0755 ${S}/${TOOLS_NAME} ${DEPLOYDIR}/${BOOT_TOOLS}
155} 147}