summaryrefslogtreecommitdiffstats
path: root/recipes-bsp/imx-mkimage/imx-boot_0.2.bb
diff options
context:
space:
mode:
authorAndrey Zhizhikin <andrey.zhizhikin@leica-geosystems.com>2020-01-06 17:01:08 +0000
committerOtavio Salvador <otavio@ossystems.com.br>2020-04-08 08:43:39 -0300
commit69b11cf31fc9dfb17e1d1469b11accbf76616692 (patch)
treebaac7e100d990417c5f221c14080cf1f803f0504 /recipes-bsp/imx-mkimage/imx-boot_0.2.bb
parente018eaabd51aa5aff9e7fa015d50ea7d3e54bd7d (diff)
downloadmeta-freescale-69b11cf31fc9dfb17e1d1469b11accbf76616692.tar.gz
imx-boot: add support for i.MX8M Nano EVK
Add ATF and platform machine definitions for i.MX8M Nano SoC in order to generate boot images. This mainly follows the setup done for i.MX8M Mini. Signed-off-by: Andrey Zhizhikin <andrey.zhizhikin@leica-geosystems.com> (cherry picked from commit 9babcb15e4cbe204dfa7421d35945e1aa1f08a03)
Diffstat (limited to 'recipes-bsp/imx-mkimage/imx-boot_0.2.bb')
-rw-r--r--recipes-bsp/imx-mkimage/imx-boot_0.2.bb5
1 files changed, 4 insertions, 1 deletions
diff --git a/recipes-bsp/imx-mkimage/imx-boot_0.2.bb b/recipes-bsp/imx-mkimage/imx-boot_0.2.bb
index 7518c911..16c7fa65 100644
--- a/recipes-bsp/imx-mkimage/imx-boot_0.2.bb
+++ b/recipes-bsp/imx-mkimage/imx-boot_0.2.bb
@@ -41,6 +41,7 @@ ATF_MACHINE_NAME_mx8qm = "bl31-imx8qm.bin"
41ATF_MACHINE_NAME_mx8qxp = "bl31-imx8qx.bin" 41ATF_MACHINE_NAME_mx8qxp = "bl31-imx8qx.bin"
42ATF_MACHINE_NAME_mx8mq = "bl31-imx8mq.bin" 42ATF_MACHINE_NAME_mx8mq = "bl31-imx8mq.bin"
43ATF_MACHINE_NAME_mx8mm = "bl31-imx8mm.bin" 43ATF_MACHINE_NAME_mx8mm = "bl31-imx8mm.bin"
44ATF_MACHINE_NAME_mx8mn = "bl31-imx8mn.bin"
44ATF_MACHINE_NAME_append = "${@bb.utils.contains('MACHINE_FEATURES', 'optee', '-optee', '', d)}" 45ATF_MACHINE_NAME_append = "${@bb.utils.contains('MACHINE_FEATURES', 'optee', '-optee', '', d)}"
45 46
46UBOOT_NAME = "u-boot-${MACHINE}.bin-${UBOOT_CONFIG}" 47UBOOT_NAME = "u-boot-${MACHINE}.bin-${UBOOT_CONFIG}"
@@ -53,6 +54,7 @@ SOC_TARGET_mx8qm = "iMX8QM"
53SOC_TARGET_mx8qxp = "iMX8QX" 54SOC_TARGET_mx8qxp = "iMX8QX"
54SOC_TARGET_mx8mq = "iMX8M" 55SOC_TARGET_mx8mq = "iMX8M"
55SOC_TARGET_mx8mm = "iMX8MM" 56SOC_TARGET_mx8mm = "iMX8MM"
57SOC_TARGET_mx8mn = "iMX8MN"
56 58
57DEPLOY_OPTEE = "${@bb.utils.contains('MACHINE_FEATURES', 'optee', 'true', 'false', d)}" 59DEPLOY_OPTEE = "${@bb.utils.contains('MACHINE_FEATURES', 'optee', 'true', 'false', d)}"
58 60
@@ -63,6 +65,7 @@ IMXBOOT_TARGETS ?= \
63 65
64BOOT_STAGING = "${S}/${SOC_TARGET}" 66BOOT_STAGING = "${S}/${SOC_TARGET}"
65BOOT_STAGING_mx8mm = "${S}/iMX8M" 67BOOT_STAGING_mx8mm = "${S}/iMX8M"
68BOOT_STAGING_mx8mn = "${S}/iMX8M"
66 69
67SOC_FAMILY = "INVALID" 70SOC_FAMILY = "INVALID"
68SOC_FAMILY_mx8 = "mx8" 71SOC_FAMILY_mx8 = "mx8"
@@ -70,7 +73,7 @@ SOC_FAMILY_mx8m = "mx8m"
70SOC_FAMILY_mx8x = "mx8x" 73SOC_FAMILY_mx8x = "mx8x"
71 74
72compile_mx8m() { 75compile_mx8m() {
73 bbnote 8MQ/8MM boot binary build 76 bbnote 8MQ/8MM/8MN boot binary build
74 for ddr_firmware in ${DDR_FIRMWARE_NAME}; do 77 for ddr_firmware in ${DDR_FIRMWARE_NAME}; do
75 bbnote "Copy ddr_firmware: ${ddr_firmware} from ${DEPLOY_DIR_IMAGE} -> ${BOOT_STAGING} " 78 bbnote "Copy ddr_firmware: ${ddr_firmware} from ${DEPLOY_DIR_IMAGE} -> ${BOOT_STAGING} "
76 cp ${DEPLOY_DIR_IMAGE}/${ddr_firmware} ${BOOT_STAGING} 79 cp ${DEPLOY_DIR_IMAGE}/${ddr_firmware} ${BOOT_STAGING}