diff options
author | Ming Liu <ming.liu@toradex.com> | 2020-05-02 13:09:17 +0200 |
---|---|---|
committer | Otavio Salvador <otavio@ossystems.com.br> | 2020-05-05 08:42:38 -0300 |
commit | 851cb78a9f7fc94574e39a6bf7fe90a21c329f6f (patch) | |
tree | e766cfe36b4ad324fba04006c9c90c2a1782ec69 /recipes-bsp/imx-mkimage/imx-boot_0.2.bb | |
parent | cf58e44173c3ee494e8b80e0fd54382e627f1f88 (diff) | |
download | meta-freescale-851cb78a9f7fc94574e39a6bf7fe90a21c329f6f.tar.gz |
imx-boot: fix mkimage_uboot linking issue
In imx-boot's Makefile, it downloads a native tool mkimage_uboot and
executes it, but this native tool requires libssl.so.1.1, which is in
${STAGING_LIBDIR_NATIVE}, we need set LD_LIBRARY_PATH to include it, or
it might run into following errors:
| ./mkimage_uboot -E -p 0x3000 -f u-boot.its u-boot.itb
| ./mkimage_uboot: error while loading shared libraries: libssl.so.1.1: cannot open shared object file: No such file or directory
Signed-off-by: Ming Liu <ming.liu@toradex.com>
Diffstat (limited to 'recipes-bsp/imx-mkimage/imx-boot_0.2.bb')
-rw-r--r-- | recipes-bsp/imx-mkimage/imx-boot_0.2.bb | 2 |
1 files changed, 2 insertions, 0 deletions
diff --git a/recipes-bsp/imx-mkimage/imx-boot_0.2.bb b/recipes-bsp/imx-mkimage/imx-boot_0.2.bb index 0604cec8..0f13a08b 100644 --- a/recipes-bsp/imx-mkimage/imx-boot_0.2.bb +++ b/recipes-bsp/imx-mkimage/imx-boot_0.2.bb | |||
@@ -105,6 +105,8 @@ compile_mx8x() { | |||
105 | cp ${DEPLOY_DIR_IMAGE}/${UBOOT_NAME} ${BOOT_STAGING}/u-boot.bin | 105 | cp ${DEPLOY_DIR_IMAGE}/${UBOOT_NAME} ${BOOT_STAGING}/u-boot.bin |
106 | } | 106 | } |
107 | do_compile() { | 107 | do_compile() { |
108 | # mkimage_uboot requires libssl.so.1.1 from ${STAGING_LIBDIR_NATIVE} | ||
109 | export LD_LIBRARY_PATH=${STAGING_LIBDIR_NATIVE}:$LD_LIBRARY_PATH | ||
108 | compile_${SOC_FAMILY} | 110 | compile_${SOC_FAMILY} |
109 | # mkimage for i.MX8 | 111 | # mkimage for i.MX8 |
110 | if ${DEPLOY_OPTEE}; then | 112 | if ${DEPLOY_OPTEE}; then |