diff options
author | Otavio Salvador <otavio@ossystems.com.br> | 2018-10-25 22:44:12 -0300 |
---|---|---|
committer | Otavio Salvador <otavio@ossystems.com.br> | 2018-10-26 14:23:37 -0300 |
commit | bc937ade566528cc097c9321694c0f5f5ef8cbf6 (patch) | |
tree | ce4a1a56a5082f9c5f6d849963f5bbef4f993733 /recipes-bsp/imx-lib | |
parent | 700abd5d1b9ce55de5c62a8d0a82c08aa6cd6897 (diff) | |
download | meta-freescale-bc937ade566528cc097c9321694c0f5f5ef8cbf6.tar.gz |
classes/use-imx-headers: Easy linux-imx-headers use
This allow to easy reuse of binary packages among similar SoCs. The
usual use for this is to share SoC specific packages among different
boards independently of the kernel version it is using, as far it is
ABI compatible with the official version it will just work.
Following recipes has been reworked to make use of the class:
- imx-lib
- imx-test
- imx-vpu-hantro
- imx-vpu
- imx-alsa-plugins
- gstreamer1.0-plugins-base
- gstreamer1.0-plugins-imx
- imx-gst1.0-plugin
Signed-off-by: Otavio Salvador <otavio@ossystems.com.br>
Signed-off-by: Tom Hochstein <tom.hochstein@nxp.com>
Diffstat (limited to 'recipes-bsp/imx-lib')
-rw-r--r-- | recipes-bsp/imx-lib/imx-lib_git.bb | 7 |
1 files changed, 3 insertions, 4 deletions
diff --git a/recipes-bsp/imx-lib/imx-lib_git.bb b/recipes-bsp/imx-lib/imx-lib_git.bb index d9258a1c..d94b2daa 100644 --- a/recipes-bsp/imx-lib/imx-lib_git.bb +++ b/recipes-bsp/imx-lib/imx-lib_git.bb | |||
@@ -6,8 +6,6 @@ DESCRIPTION = "Platform specific libraries for imx platform" | |||
6 | LICENSE = "LGPLv2.1" | 6 | LICENSE = "LGPLv2.1" |
7 | SECTION = "multimedia" | 7 | SECTION = "multimedia" |
8 | 8 | ||
9 | DEPENDS = "linux-imx-headers" | ||
10 | |||
11 | LIC_FILES_CHKSUM = "file://COPYING-LGPL-2.1;md5=fbc093901857fcd118f065f900982c24" | 9 | LIC_FILES_CHKSUM = "file://COPYING-LGPL-2.1;md5=fbc093901857fcd118f065f900982c24" |
12 | 10 | ||
13 | PE = "1" | 11 | PE = "1" |
@@ -20,6 +18,8 @@ SRCREV = "3f777974c0c146817e2ff5cb0340ca66a1f99e57" | |||
20 | 18 | ||
21 | S = "${WORKDIR}/git" | 19 | S = "${WORKDIR}/git" |
22 | 20 | ||
21 | inherit use-imx-headers | ||
22 | |||
23 | PLATFORM_mx6q = "IMX6Q" | 23 | PLATFORM_mx6q = "IMX6Q" |
24 | PLATFORM_mx6dl = "IMX6Q" | 24 | PLATFORM_mx6dl = "IMX6Q" |
25 | PLATFORM_mx6sl = "IMX6S" | 25 | PLATFORM_mx6sl = "IMX6S" |
@@ -33,7 +33,7 @@ PARALLEL_MAKE="-j 1" | |||
33 | EXTRA_OEMAKE = "" | 33 | EXTRA_OEMAKE = "" |
34 | 34 | ||
35 | do_compile () { | 35 | do_compile () { |
36 | INCLUDE_DIR="-I${STAGING_INCDIR}/imx" | 36 | INCLUDE_DIR="-I${STAGING_INCDIR_IMX}" |
37 | oe_runmake CROSS_COMPILE="${HOST_PREFIX}" PLATFORM="${PLATFORM}" INCLUDE="${INCLUDE_DIR}" all | 37 | oe_runmake CROSS_COMPILE="${HOST_PREFIX}" PLATFORM="${PLATFORM}" INCLUDE="${INCLUDE_DIR}" all |
38 | } | 38 | } |
39 | 39 | ||
@@ -42,4 +42,3 @@ do_install () { | |||
42 | } | 42 | } |
43 | 43 | ||
44 | COMPATIBLE_MACHINE = "(mx6|mx7)" | 44 | COMPATIBLE_MACHINE = "(mx6|mx7)" |
45 | PACKAGE_ARCH = "${MACHINE_SOCARCH}" | ||