diff options
author | Jun Zhu <junzhu@nxp.com> | 2017-10-13 00:15:42 +0800 |
---|---|---|
committer | Otavio Salvador <otavio@ossystems.com.br> | 2017-10-16 14:27:29 -0200 |
commit | e9e9109a2544545c3ac3456ec18227d96e56a70f (patch) | |
tree | 21ac404c956069b6ba66b21b6ce545faf6fa7cd1 /recipes-bsp/imx-lib | |
parent | 26800c9b52ae1bfc73e2ae9b600cd3bb76fa697e (diff) | |
download | meta-freescale-e9e9109a2544545c3ac3456ec18227d96e56a70f.tar.gz |
imx-lib: Add git recipe
- As the imx-lib git repository is public as git.freescale.com/imx/imx-lib.git,
build it from the git.
- Add support to i.MX 6SLL and 7ULP.
- Set PV as 5.8+${SRCPV}
Add the options to support i.MX 6SLL and 7ULP
Signed-off-by: Jun Zhu <junzhu@nxp.com>
Signed-off-by: Otavio Salvador <otavio@ossystems.com.br>
Diffstat (limited to 'recipes-bsp/imx-lib')
-rw-r--r-- | recipes-bsp/imx-lib/imx-lib_5.4.bb | 10 | ||||
-rw-r--r-- | recipes-bsp/imx-lib/imx-lib_git.bb (renamed from recipes-bsp/imx-lib/imx-lib.inc) | 26 |
2 files changed, 18 insertions, 18 deletions
diff --git a/recipes-bsp/imx-lib/imx-lib_5.4.bb b/recipes-bsp/imx-lib/imx-lib_5.4.bb deleted file mode 100644 index 3055c51a..00000000 --- a/recipes-bsp/imx-lib/imx-lib_5.4.bb +++ /dev/null | |||
@@ -1,10 +0,0 @@ | |||
1 | # Copyright (C) 2013-2016 Freescale Semiconductor | ||
2 | |||
3 | include imx-lib.inc | ||
4 | |||
5 | PE = "1" | ||
6 | |||
7 | SRC_URI[md5sum] = "a0da6a01698776f2df05130108c226c9" | ||
8 | SRC_URI[sha256sum] = "8d12c4a0a44d29569f1ead3a36adc28402b9c4036b53e11dd3ebf2295e3ce1d0" | ||
9 | |||
10 | COMPATIBLE_MACHINE = "(mx6|mx7)" | ||
diff --git a/recipes-bsp/imx-lib/imx-lib.inc b/recipes-bsp/imx-lib/imx-lib_git.bb index 0b21d942..d48ff5a5 100644 --- a/recipes-bsp/imx-lib/imx-lib.inc +++ b/recipes-bsp/imx-lib/imx-lib_git.bb | |||
@@ -1,5 +1,6 @@ | |||
1 | # Copyright (C) 2012-2013 Freescale Semiconductor | 1 | # Copyright (C) 2012-2016 Freescale Semiconductor |
2 | # Copyright (C) 2012-2016 O.S. Systems Software LTDA. | 2 | # Copyright (C) 2012-2016 O.S. Systems Software LTDA. |
3 | # Copyright 2017 NXP | ||
3 | 4 | ||
4 | DESCRIPTION = "Platform specific libraries for imx platform" | 5 | DESCRIPTION = "Platform specific libraries for imx platform" |
5 | LICENSE = "LGPLv2.1" | 6 | LICENSE = "LGPLv2.1" |
@@ -8,26 +9,35 @@ DEPENDS = "virtual/kernel" | |||
8 | 9 | ||
9 | LIC_FILES_CHKSUM = "file://COPYING-LGPL-2.1;md5=fbc093901857fcd118f065f900982c24" | 10 | LIC_FILES_CHKSUM = "file://COPYING-LGPL-2.1;md5=fbc093901857fcd118f065f900982c24" |
10 | 11 | ||
12 | PE = "1" | ||
13 | |||
14 | PV = "5.8+${SRCPV}" | ||
15 | |||
16 | SRCBRANCH = "imx_4.9.11_1.0.0_ga" | ||
17 | SRC_URI = "git://git.freescale.com/imx/imx-lib.git;protocol=git;branch=${SRCBRANCH}" | ||
18 | SRCREV = "f5f14fc24581e5d6e689f42a56b5f2992f978ef4" | ||
19 | |||
20 | S = "${WORKDIR}/git" | ||
21 | |||
11 | PLATFORM_mx6q = "IMX6Q" | 22 | PLATFORM_mx6q = "IMX6Q" |
12 | PLATFORM_mx6dl = "IMX6Q" | 23 | PLATFORM_mx6dl = "IMX6Q" |
13 | PLATFORM_mx6sl = "IMX6S" | 24 | PLATFORM_mx6sl = "IMX6S" |
25 | PLATFORM_mx6sll = "IMX6UL" | ||
14 | PLATFORM_mx6sx = "IMX6S" | 26 | PLATFORM_mx6sx = "IMX6S" |
15 | PLATFORM_mx7d = "IMX7" | ||
16 | PLATFORM_mx6ul = "IMX6UL" | 27 | PLATFORM_mx6ul = "IMX6UL" |
28 | PLATFORM_mx7d = "IMX7" | ||
29 | PLATFORM_mx7ulp = "IMX7" | ||
17 | 30 | ||
18 | PARALLEL_MAKE="-j 1" | 31 | PARALLEL_MAKE="-j 1" |
19 | EXTRA_OEMAKE = "" | 32 | EXTRA_OEMAKE = "" |
20 | 33 | ||
21 | SRC_URI = "${FSL_MIRROR}/imx-lib-${PV}.tar.gz" | ||
22 | |||
23 | do_compile () { | 34 | do_compile () { |
24 | INCLUDE_DIR="-I${STAGING_KERNEL_DIR}/include/uapi -I${STAGING_KERNEL_DIR}/include \ | 35 | INCLUDE_DIR="-I${STAGING_KERNEL_DIR}/include/uapi -I${STAGING_KERNEL_DIR}/include" |
25 | -I${STAGING_KERNEL_DIR}/drivers/mxc/security/rng/include \ | ||
26 | -I${STAGING_KERNEL_DIR}/drivers/mxc/security/sahara2/include" | ||
27 | |||
28 | oe_runmake CROSS_COMPILE="${HOST_PREFIX}" PLATFORM="${PLATFORM}" INCLUDE="${INCLUDE_DIR}" all | 36 | oe_runmake CROSS_COMPILE="${HOST_PREFIX}" PLATFORM="${PLATFORM}" INCLUDE="${INCLUDE_DIR}" all |
29 | } | 37 | } |
30 | 38 | ||
31 | do_install () { | 39 | do_install () { |
32 | oe_runmake PLATFORM="${PLATFORM}" DEST_DIR="${D}" install | 40 | oe_runmake PLATFORM="${PLATFORM}" DEST_DIR="${D}" install |
33 | } | 41 | } |
42 | |||
43 | COMPATIBLE_MACHINE = "(mx6|mx7)" | ||