diff options
author | Khem Raj <raj.khem@gmail.com> | 2017-05-11 09:57:46 -0700 |
---|---|---|
committer | Otavio Salvador <otavio@ossystems.com.br> | 2017-05-19 07:56:19 -0300 |
commit | ae6434f5f389a32cfc2a674f82f3f807cc721135 (patch) | |
tree | 1c4192d7090e6396de9aeac9795d4702a02666b9 /recipes-bsp/imx-kobs | |
parent | f89d2a3efe1cfdeac5df5c30289ee4303660cc8e (diff) | |
download | meta-freescale-ae6434f5f389a32cfc2a674f82f3f807cc721135.tar.gz |
imx-kobs: Fix build with musl
Signed-off-by: Khem Raj <raj.khem@gmail.com>
Signed-off-by: Otavio Salvador <otavio@ossystems.com.br>
Diffstat (limited to 'recipes-bsp/imx-kobs')
-rw-r--r-- | recipes-bsp/imx-kobs/imx-kobs/0001-Add-missing-includes-as-pointed-out-by-musl.patch | 33 | ||||
-rw-r--r-- | recipes-bsp/imx-kobs/imx-kobs_git.bb | 2 |
2 files changed, 35 insertions, 0 deletions
diff --git a/recipes-bsp/imx-kobs/imx-kobs/0001-Add-missing-includes-as-pointed-out-by-musl.patch b/recipes-bsp/imx-kobs/imx-kobs/0001-Add-missing-includes-as-pointed-out-by-musl.patch new file mode 100644 index 00000000..9c86f074 --- /dev/null +++ b/recipes-bsp/imx-kobs/imx-kobs/0001-Add-missing-includes-as-pointed-out-by-musl.patch | |||
@@ -0,0 +1,33 @@ | |||
1 | From c183a648958ab4454247cfd88d01da7730a53d19 Mon Sep 17 00:00:00 2001 | ||
2 | From: Khem Raj <raj.khem@gmail.com> | ||
3 | Date: Thu, 11 May 2017 00:59:07 -0700 | ||
4 | Subject: [PATCH] Add missing includes as pointed out by musl | ||
5 | |||
6 | These headers are indrectly included when building with | ||
7 | glibc, this is exposed when compiling with musl systems | ||
8 | |||
9 | Signed-off-by: Khem Raj <raj.khem@gmail.com> | ||
10 | --- | ||
11 | src/mtd.h | 3 +++ | ||
12 | 1 file changed, 3 insertions(+) | ||
13 | |||
14 | diff --git a/src/mtd.h b/src/mtd.h | ||
15 | index 6cb0ca2..0eaea48 100644 | ||
16 | --- a/src/mtd.h | ||
17 | +++ b/src/mtd.h | ||
18 | @@ -25,9 +25,12 @@ | ||
19 | #ifndef MTD_H | ||
20 | #define MTD_H | ||
21 | |||
22 | +#define _GNU_SOURCE | ||
23 | +#include <fcntl.h> | ||
24 | #include <mtd/mtd-user.h> | ||
25 | #include <endian.h> | ||
26 | #include <stdint.h> | ||
27 | +#include <stddef.h> | ||
28 | |||
29 | #include "BootControlBlocks.h" | ||
30 | #include "rom_nand_hamming_code_ecc.h" | ||
31 | -- | ||
32 | 2.12.2 | ||
33 | |||
diff --git a/recipes-bsp/imx-kobs/imx-kobs_git.bb b/recipes-bsp/imx-kobs/imx-kobs_git.bb index aab10f9c..eaea1657 100644 --- a/recipes-bsp/imx-kobs/imx-kobs_git.bb +++ b/recipes-bsp/imx-kobs/imx-kobs_git.bb | |||
@@ -10,6 +10,8 @@ PV = "5.5+git${SRCPV}" | |||
10 | SRCREV = "a2734b93759b4222f9dfa3f8c7645be9d39ea601" | 10 | SRCREV = "a2734b93759b4222f9dfa3f8c7645be9d39ea601" |
11 | 11 | ||
12 | SRC_URI = "git://github.com/NXPmicro/imx-kobs.git;protocal=https" | 12 | SRC_URI = "git://github.com/NXPmicro/imx-kobs.git;protocal=https" |
13 | file://0001-Add-missing-includes-as-pointed-out-by-musl.patch \ | ||
14 | " | ||
13 | 15 | ||
14 | S = "${WORKDIR}/git" | 16 | S = "${WORKDIR}/git" |
15 | 17 | ||