diff options
author | Otavio Salvador <otavio@ossystems.com.br> | 2016-10-06 15:33:05 -0300 |
---|---|---|
committer | Otavio Salvador <otavio@ossystems.com.br> | 2016-10-18 16:26:14 -0200 |
commit | 35173b36b6d82f1bd7e29e513702c7d016ed8123 (patch) | |
tree | 0553fc43d4c5d1805c7280d2fef71627dfeafdd6 /recipes-bsp/imx-kobs | |
parent | 0441cbae7aaf4220d5f12deac6ac5a3c7d4f79ee (diff) | |
download | meta-freescale-35173b36b6d82f1bd7e29e513702c7d016ed8123.tar.gz |
imx-kobs: Drop 5.4 recipe
The Git recipe is now preferred so we are dropping the old release.
Signed-off-by: Otavio Salvador <otavio@ossystems.com.br>
Diffstat (limited to 'recipes-bsp/imx-kobs')
-rw-r--r-- | recipes-bsp/imx-kobs/imx-kobs/fix-cal_nfc_geometry.patch | 31 | ||||
-rw-r--r-- | recipes-bsp/imx-kobs/imx-kobs/raw-mode.patch | 48 | ||||
-rw-r--r-- | recipes-bsp/imx-kobs/imx-kobs_5.4.bb | 19 |
3 files changed, 0 insertions, 98 deletions
diff --git a/recipes-bsp/imx-kobs/imx-kobs/fix-cal_nfc_geometry.patch b/recipes-bsp/imx-kobs/imx-kobs/fix-cal_nfc_geometry.patch deleted file mode 100644 index dddb49a1..00000000 --- a/recipes-bsp/imx-kobs/imx-kobs/fix-cal_nfc_geometry.patch +++ /dev/null | |||
@@ -1,31 +0,0 @@ | |||
1 | The Freescale downstream vendor kernel has a patch that exports the bch | ||
2 | flash geometry via a debugfs file. This is not available in mainline linux | ||
3 | kernels so the fallback method calculates the geometry based on known info | ||
4 | from the mtd partition. A bug exists in this funcion where it fails to | ||
5 | assume that block0 ECC is the same as the other blocks by default. | ||
6 | |||
7 | Upstream-Status: Pending | ||
8 | |||
9 | --- a/src/mtd.c | ||
10 | +++ b/src/mtd.c | ||
11 | @@ -610,7 +610,7 @@ static int cal_nfc_geometry(struct mtd_d | ||
12 | /* The two are fixed, please change them when the driver changes. */ | ||
13 | geo->metadata_size_in_bytes = 10; | ||
14 | geo->gf_len = 13; | ||
15 | - geo->ecc_chunkn_size_in_bytes = 512; | ||
16 | + geo->ecc_chunkn_size_in_bytes = geo->ecc_chunk0_size_in_bytes = 512; | ||
17 | |||
18 | if (mtd->oobsize > geo->ecc_chunkn_size_in_bytes) { | ||
19 | geo->gf_len = 14; | ||
20 | @@ -700,8 +700,9 @@ int parse_nfc_geometry(struct mtd_data * | ||
21 | unsigned int value; | ||
22 | |||
23 | if (!plat_config_data->m_u32UseNfcGeo) { | ||
24 | + /* fsl kernel patch provides bch_geometry via debugfs */ | ||
25 | if (!(node = fopen(dbg_geometry_node_path, "r"))) { | ||
26 | - fprintf(stderr, "Cannot open BCH geometry node: \"%s\"", | ||
27 | + fprintf(stderr, "Cannot open BCH geometry node: \"%s\"\n", | ||
28 | dbg_geometry_node_path); | ||
29 | return cal_nfc_geometry(md); | ||
30 | } | ||
31 | |||
diff --git a/recipes-bsp/imx-kobs/imx-kobs/raw-mode.patch b/recipes-bsp/imx-kobs/imx-kobs/raw-mode.patch deleted file mode 100644 index 76c2440a..00000000 --- a/recipes-bsp/imx-kobs/imx-kobs/raw-mode.patch +++ /dev/null | |||
@@ -1,48 +0,0 @@ | |||
1 | The downstream Freescale vendor kernel has a patch that allows determining | ||
2 | if raw NAND flash mode is provided via a debugfs file. This is not present | ||
3 | in upstream kernels, but the raw access support was added in the 3.19 | ||
4 | kernel, so we will check the kernel version if we can't find the file. | ||
5 | |||
6 | Upstream-Status: Pending | ||
7 | |||
8 | --- a/src/mtd.c | ||
9 | +++ b/src/mtd.c | ||
10 | @@ -34,6 +34,7 @@ | ||
11 | #include <errno.h> | ||
12 | #include <sys/types.h> | ||
13 | #include <sys/ioctl.h> | ||
14 | +#include <sys/utsname.h> | ||
15 | |||
16 | #include "mtd.h" | ||
17 | #include "rand.h" | ||
18 | @@ -808,15 +809,27 @@ struct mtd_data *mtd_open(const struct m | ||
19 | md->cfg = *cfg; | ||
20 | |||
21 | /* check if use new raw access mode */ | ||
22 | + /* by looking for debugfs from fsl patch */ | ||
23 | + md->raw_mode_flag = 0; | ||
24 | fp = fopen("/sys/kernel/debug/gpmi-nand/raw_mode", "r"); | ||
25 | if (!fp) { | ||
26 | - md->raw_mode_flag = 0; | ||
27 | - vp(md, "mtd: use legacy raw access mode\n"); | ||
28 | + /* fallback to kernel version: raw access added in 3.19 */ | ||
29 | + struct utsname uts; | ||
30 | + if (!uname(&uts)) { | ||
31 | + int major = 0, minor = 0; | ||
32 | + sscanf(uts.release, "%d.%d", &major, &minor); | ||
33 | + vp(md, "mtd: Linux %d.%d\n", major, minor); | ||
34 | + if ((major << 8 | minor) > (3 << 8 | 18)) | ||
35 | + md->raw_mode_flag = 1; | ||
36 | + } | ||
37 | } else { | ||
38 | fclose(fp); | ||
39 | md->raw_mode_flag = 1; | ||
40 | - vp(md, "mtd: use new bch layout raw access mode\n"); | ||
41 | } | ||
42 | + if (md->raw_mode_flag) | ||
43 | + vp(md, "mtd: use new bch layout raw access mode\n"); | ||
44 | + else | ||
45 | + vp(md, "mtd: use legacy raw access mode\n"); | ||
46 | |||
47 | if (plat_config_data->m_u32UseMultiBootArea) { | ||
48 | |||
diff --git a/recipes-bsp/imx-kobs/imx-kobs_5.4.bb b/recipes-bsp/imx-kobs/imx-kobs_5.4.bb deleted file mode 100644 index de396a17..00000000 --- a/recipes-bsp/imx-kobs/imx-kobs_5.4.bb +++ /dev/null | |||
@@ -1,19 +0,0 @@ | |||
1 | # Copyright (C) 2013-2016 Freescale Semiconductor | ||
2 | |||
3 | SUMMARY = "Nand boot write source" | ||
4 | SECTION = "base" | ||
5 | LICENSE = "GPLv2" | ||
6 | LIC_FILES_CHKSUM = "file://COPYING;md5=393a5ca445f6965873eca0259a17f833" | ||
7 | |||
8 | SRC_URI = "${FSL_MIRROR}/imx-kobs-${PV}.tar.gz \ | ||
9 | file://fix-compile.patch \ | ||
10 | file://raw-mode.patch \ | ||
11 | file://fix-cal_nfc_geometry.patch \ | ||
12 | " | ||
13 | |||
14 | SRC_URI[md5sum] = "77467d834f858c2ec216841583e5f437" | ||
15 | SRC_URI[sha256sum] = "85171b46068ac47c42fedb8104167bf9afd33dd9527ed127e1ca2eb29d7a86bf" | ||
16 | |||
17 | inherit autotools pkgconfig | ||
18 | |||
19 | COMPATIBLE_MACHINE = "(imx)" | ||