summaryrefslogtreecommitdiffstats
path: root/recipes-bsp/imx-atf
diff options
context:
space:
mode:
authorAndrey Zhizhikin <andrey.z@gmail.com>2021-01-12 22:14:17 +0000
committerOtavio Salvador <otavio@ossystems.com.br>2021-02-01 11:24:43 -0300
commitd46f7a84f9bde371bd1ff17ed30e8542a870509b (patch)
treed1bcfdb29b1cb749eea1ce31a054ec618cc617bf /recipes-bsp/imx-atf
parent5495996f680c401c1759bf944450c3000b837c66 (diff)
downloadmeta-freescale-d46f7a84f9bde371bd1ff17ed30e8542a870509b.tar.gz
imx-atf: upgrade to NXP release 5.4.70_2.3.0
Update recipe SRCREV and branch to point to new version available as a part of NXP release [imx_5.4.70_2.3.0]. Drop patches applied upstream from the layer. Signed-off-by: Andrey Zhizhikin <andrey.z@gmail.com>
Diffstat (limited to 'recipes-bsp/imx-atf')
-rw-r--r--recipes-bsp/imx-atf/imx-atf/0001-imx-Fix-missing-inclusion-of-cdefs.h.patch62
-rw-r--r--recipes-bsp/imx-atf/imx-atf/0001-imx-Fix-multiple-definition-of-ipc_handle.patch44
-rw-r--r--recipes-bsp/imx-atf/imx-atf_2.2.bb6
3 files changed, 2 insertions, 110 deletions
diff --git a/recipes-bsp/imx-atf/imx-atf/0001-imx-Fix-missing-inclusion-of-cdefs.h.patch b/recipes-bsp/imx-atf/imx-atf/0001-imx-Fix-missing-inclusion-of-cdefs.h.patch
deleted file mode 100644
index 209098d6..00000000
--- a/recipes-bsp/imx-atf/imx-atf/0001-imx-Fix-missing-inclusion-of-cdefs.h.patch
+++ /dev/null
@@ -1,62 +0,0 @@
1From e8bb1c2caa19fa224090eca0793586857199af9e Mon Sep 17 00:00:00 2001
2From: Samuel Holland <samuel@sholland.org>
3Date: Wed, 4 Dec 2019 02:48:37 -0600
4Subject: [PATCH] imx: Fix missing inclusion of cdefs.h
5
6This was found by compiling with -fno-common:
7
8./build/picopi/release/bl2/imx_snvs.o:(.bss.__packed+0x0): multiple definition of `__packed';
9./build/picopi/release/bl2/imx_caam.o:(.bss.__packed+0x0): first defined here
10
11__packed was intended to be the attribute macro from cdefs.h, not an
12object of the structure type.
13
14Upstream-Status: Backport
15
16Signed-off-by: Samuel Holland <samuel@sholland.org>
17Change-Id: Id02fac3f098be2d71c35c6b4a18012515532f32a
18---
19 plat/imx/common/include/imx_caam.h | 3 ++-
20 plat/imx/common/include/imx_snvs.h | 3 ++-
21 2 files changed, 4 insertions(+), 2 deletions(-)
22
23diff --git a/plat/imx/common/include/imx_caam.h b/plat/imx/common/include/imx_caam.h
24index 335bd0f8b..61005b51c 100644
25--- a/plat/imx/common/include/imx_caam.h
26+++ b/plat/imx/common/include/imx_caam.h
27@@ -1,5 +1,5 @@
28 /*
29- * Copyright (c) 2018, ARM Limited and Contributors. All rights reserved.
30+ * Copyright (c) 2018-2019, ARM Limited and Contributors. All rights reserved.
31 *
32 * SPDX-License-Identifier: BSD-3-Clause
33 */
34@@ -7,6 +7,7 @@
35 #ifndef IMX_CAAM_H
36 #define IMX_CAAM_H
37
38+#include <cdefs.h>
39 #include <stdint.h>
40 #include <arch.h>
41 #include <imx_regs.h>
42diff --git a/plat/imx/common/include/imx_snvs.h b/plat/imx/common/include/imx_snvs.h
43index 0b3d1085f..565c451dd 100644
44--- a/plat/imx/common/include/imx_snvs.h
45+++ b/plat/imx/common/include/imx_snvs.h
46@@ -1,11 +1,12 @@
47 /*
48- * Copyright (C) 2018, ARM Limited and Contributors. All rights reserved.
49+ * Copyright (C) 2018-2019, ARM Limited and Contributors. All rights reserved.
50 *
51 * SPDX-License-Identifier: BSD-3-Clause
52 */
53 #ifndef IMX_SNVS_H
54 #define IMX_SNVS_H
55
56+#include <cdefs.h>
57 #include <stdint.h>
58
59 #include <arch.h>
60--
612.28.0
62
diff --git a/recipes-bsp/imx-atf/imx-atf/0001-imx-Fix-multiple-definition-of-ipc_handle.patch b/recipes-bsp/imx-atf/imx-atf/0001-imx-Fix-multiple-definition-of-ipc_handle.patch
deleted file mode 100644
index 94050a06..00000000
--- a/recipes-bsp/imx-atf/imx-atf/0001-imx-Fix-multiple-definition-of-ipc_handle.patch
+++ /dev/null
@@ -1,44 +0,0 @@
1From 2338329e35254c1b8a887409d930ca76d9612093 Mon Sep 17 00:00:00 2001
2From: Samuel Holland <samuel@sholland.org>
3Date: Wed, 4 Dec 2019 02:45:58 -0600
4Subject: [PATCH] imx: Fix multiple definition of ipc_handle
5
6This is not conforming C and does not compile with -fno-common.
7
8Upstream-Status: Backport
9
10Signed-off-by: Samuel Holland <samuel@sholland.org>
11Change-Id: I6535954cc567d6efa06919069b91e3f50975b073
12---
13 plat/imx/common/include/sci/sci_ipc.h | 2 +-
14 plat/imx/common/sci/ipc.c | 2 ++
15 2 files changed, 3 insertions(+), 1 deletion(-)
16
17diff --git a/plat/imx/common/include/sci/sci_ipc.h b/plat/imx/common/include/sci/sci_ipc.h
18index cc8e47b28..1e3e53247 100755
19--- a/plat/imx/common/include/sci/sci_ipc.h
20+++ b/plat/imx/common/include/sci/sci_ipc.h
21@@ -63,6 +63,6 @@ void sc_ipc_read(sc_ipc_t ipc, void *data);
22 */
23 void sc_ipc_write(sc_ipc_t ipc, const void *data);
24
25-sc_ipc_t ipc_handle;
26+extern sc_ipc_t ipc_handle;
27
28 #endif /* SCI_IPC_H */
29diff --git a/plat/imx/common/sci/ipc.c b/plat/imx/common/sci/ipc.c
30index f329482fe..bf35a5ead 100755
31--- a/plat/imx/common/sci/ipc.c
32+++ b/plat/imx/common/sci/ipc.c
33@@ -11,6 +11,8 @@
34
35 #include "imx8_mu.h"
36
37+sc_ipc_t ipc_handle;
38+
39 #include <lib/bakery_lock.h>
40 DEFINE_BAKERY_LOCK(sc_ipc_bakery_lock);
41 #define sc_ipc_lock_init() bakery_lock_init(&sc_ipc_bakery_lock)
42--
432.28.0
44
diff --git a/recipes-bsp/imx-atf/imx-atf_2.2.bb b/recipes-bsp/imx-atf/imx-atf_2.2.bb
index 6fb857ec..81d884ad 100644
--- a/recipes-bsp/imx-atf/imx-atf_2.2.bb
+++ b/recipes-bsp/imx-atf/imx-atf_2.2.bb
@@ -7,12 +7,10 @@ LIC_FILES_CHKSUM = "file://${COREBASE}/meta/files/common-licenses/BSD-3-Clause;m
7 7
8PV .= "+git${SRCPV}" 8PV .= "+git${SRCPV}"
9 9
10SRCBRANCH = "imx_5.4.47_2.2.0" 10SRCBRANCH = "imx_5.4.70_2.3.0"
11SRC_URI = "git://source.codeaurora.org/external/imx/imx-atf.git;protocol=https;branch=${SRCBRANCH} \ 11SRC_URI = "git://source.codeaurora.org/external/imx/imx-atf.git;protocol=https;branch=${SRCBRANCH} \
12 file://0001-imx-Fix-missing-inclusion-of-cdefs.h.patch \
13 file://0001-imx-Fix-multiple-definition-of-ipc_handle.patch \
14" 12"
15SRCREV = "c949a888e909811db191500c51456391dff61284" 13SRCREV = "f1d7187f261ebf4b8a2a70d638d4bfc0a9b26c29"
16 14
17S = "${WORKDIR}/git" 15S = "${WORKDIR}/git"
18 16