diff options
author | Andrey Zhizhikin <andrey.zhizhikin@leica-geosystems.com> | 2020-08-18 11:35:33 +0000 |
---|---|---|
committer | Otavio Salvador <otavio@ossystems.com.br> | 2020-09-23 23:40:51 -0300 |
commit | 3f8c343fd6215088f8112049853e078315b914b8 (patch) | |
tree | 8fa9f87744fdeeb9cb48d58a92bdb575b8ec0030 /recipes-bsp/imx-atf | |
parent | 5b58232d3e7b5e66d5bdcfd11a6265b098b2f898 (diff) | |
download | meta-freescale-3f8c343fd6215088f8112049853e078315b914b8.tar.gz |
imx-atf: upgrade to 2.2
This adds support for additional i.MX8-based machines
Signed-off-by: Andrey Zhizhikin <andrey.zhizhikin@leica-geosystems.com>
Diffstat (limited to 'recipes-bsp/imx-atf')
-rw-r--r-- | recipes-bsp/imx-atf/imx-atf/0001-Allow-BUILD_STRING-to-be-set-in-.revision-file.patch | 29 | ||||
-rw-r--r-- | recipes-bsp/imx-atf/imx-atf/0001-imx-Fix-missing-inclusion-of-cdefs.h.patch | 62 | ||||
-rw-r--r-- | recipes-bsp/imx-atf/imx-atf/0001-imx-Fix-multiple-definition-of-ipc_handle.patch | 13 | ||||
-rw-r--r-- | recipes-bsp/imx-atf/imx-atf_2.2.bb (renamed from recipes-bsp/imx-atf/imx-atf_2.0.bb) | 14 |
4 files changed, 77 insertions, 41 deletions
diff --git a/recipes-bsp/imx-atf/imx-atf/0001-Allow-BUILD_STRING-to-be-set-in-.revision-file.patch b/recipes-bsp/imx-atf/imx-atf/0001-Allow-BUILD_STRING-to-be-set-in-.revision-file.patch deleted file mode 100644 index be747789..00000000 --- a/recipes-bsp/imx-atf/imx-atf/0001-Allow-BUILD_STRING-to-be-set-in-.revision-file.patch +++ /dev/null | |||
@@ -1,29 +0,0 @@ | |||
1 | From 4123893a8a4d93362a0a36f72134f75436fee457 Mon Sep 17 00:00:00 2001 | ||
2 | From: Tom Hochstein <tom.hochstein@nxp.com> | ||
3 | Date: Thu, 18 Oct 2018 18:03:46 -0500 | ||
4 | Subject: [PATCH] Allow BUILD_STRING to be set in .revision file. | ||
5 | |||
6 | Upstream-Status: Pending | ||
7 | |||
8 | Signed-off-by: Tom Hochstein <tom.hochstein@nxp.com> | ||
9 | --- | ||
10 | Makefile | 3 +++ | ||
11 | 1 file changed, 3 insertions(+) | ||
12 | |||
13 | diff --git a/Makefile b/Makefile | ||
14 | index 57c4a90..ec49397 100644 | ||
15 | --- a/Makefile | ||
16 | +++ b/Makefile | ||
17 | @@ -97,6 +97,9 @@ endif | ||
18 | |||
19 | # Default build string (git branch and commit) | ||
20 | ifeq (${BUILD_STRING},) | ||
21 | + BUILD_STRING := $(shell cat .revision 2> /dev/null) | ||
22 | +endif | ||
23 | +ifeq (${BUILD_STRING},) | ||
24 | BUILD_STRING := $(shell git describe --long --always --dirty --tags 2> /dev/null) | ||
25 | endif | ||
26 | VERSION_STRING := v${VERSION_MAJOR}.${VERSION_MINOR}(${BUILD_TYPE}):${BUILD_STRING} | ||
27 | -- | ||
28 | 2.7.4 | ||
29 | |||
diff --git a/recipes-bsp/imx-atf/imx-atf/0001-imx-Fix-missing-inclusion-of-cdefs.h.patch b/recipes-bsp/imx-atf/imx-atf/0001-imx-Fix-missing-inclusion-of-cdefs.h.patch new file mode 100644 index 00000000..209098d6 --- /dev/null +++ b/recipes-bsp/imx-atf/imx-atf/0001-imx-Fix-missing-inclusion-of-cdefs.h.patch | |||
@@ -0,0 +1,62 @@ | |||
1 | From e8bb1c2caa19fa224090eca0793586857199af9e Mon Sep 17 00:00:00 2001 | ||
2 | From: Samuel Holland <samuel@sholland.org> | ||
3 | Date: Wed, 4 Dec 2019 02:48:37 -0600 | ||
4 | Subject: [PATCH] imx: Fix missing inclusion of cdefs.h | ||
5 | |||
6 | This was found by compiling with -fno-common: | ||
7 | |||
8 | ./build/picopi/release/bl2/imx_snvs.o:(.bss.__packed+0x0): multiple definition of `__packed'; | ||
9 | ./build/picopi/release/bl2/imx_caam.o:(.bss.__packed+0x0): first defined here | ||
10 | |||
11 | __packed was intended to be the attribute macro from cdefs.h, not an | ||
12 | object of the structure type. | ||
13 | |||
14 | Upstream-Status: Backport | ||
15 | |||
16 | Signed-off-by: Samuel Holland <samuel@sholland.org> | ||
17 | Change-Id: Id02fac3f098be2d71c35c6b4a18012515532f32a | ||
18 | --- | ||
19 | plat/imx/common/include/imx_caam.h | 3 ++- | ||
20 | plat/imx/common/include/imx_snvs.h | 3 ++- | ||
21 | 2 files changed, 4 insertions(+), 2 deletions(-) | ||
22 | |||
23 | diff --git a/plat/imx/common/include/imx_caam.h b/plat/imx/common/include/imx_caam.h | ||
24 | index 335bd0f8b..61005b51c 100644 | ||
25 | --- a/plat/imx/common/include/imx_caam.h | ||
26 | +++ b/plat/imx/common/include/imx_caam.h | ||
27 | @@ -1,5 +1,5 @@ | ||
28 | /* | ||
29 | - * Copyright (c) 2018, ARM Limited and Contributors. All rights reserved. | ||
30 | + * Copyright (c) 2018-2019, ARM Limited and Contributors. All rights reserved. | ||
31 | * | ||
32 | * SPDX-License-Identifier: BSD-3-Clause | ||
33 | */ | ||
34 | @@ -7,6 +7,7 @@ | ||
35 | #ifndef IMX_CAAM_H | ||
36 | #define IMX_CAAM_H | ||
37 | |||
38 | +#include <cdefs.h> | ||
39 | #include <stdint.h> | ||
40 | #include <arch.h> | ||
41 | #include <imx_regs.h> | ||
42 | diff --git a/plat/imx/common/include/imx_snvs.h b/plat/imx/common/include/imx_snvs.h | ||
43 | index 0b3d1085f..565c451dd 100644 | ||
44 | --- a/plat/imx/common/include/imx_snvs.h | ||
45 | +++ b/plat/imx/common/include/imx_snvs.h | ||
46 | @@ -1,11 +1,12 @@ | ||
47 | /* | ||
48 | - * Copyright (C) 2018, ARM Limited and Contributors. All rights reserved. | ||
49 | + * Copyright (C) 2018-2019, ARM Limited and Contributors. All rights reserved. | ||
50 | * | ||
51 | * SPDX-License-Identifier: BSD-3-Clause | ||
52 | */ | ||
53 | #ifndef IMX_SNVS_H | ||
54 | #define IMX_SNVS_H | ||
55 | |||
56 | +#include <cdefs.h> | ||
57 | #include <stdint.h> | ||
58 | |||
59 | #include <arch.h> | ||
60 | -- | ||
61 | 2.28.0 | ||
62 | |||
diff --git a/recipes-bsp/imx-atf/imx-atf/0001-imx-Fix-multiple-definition-of-ipc_handle.patch b/recipes-bsp/imx-atf/imx-atf/0001-imx-Fix-multiple-definition-of-ipc_handle.patch index 000eff41..94050a06 100644 --- a/recipes-bsp/imx-atf/imx-atf/0001-imx-Fix-multiple-definition-of-ipc_handle.patch +++ b/recipes-bsp/imx-atf/imx-atf/0001-imx-Fix-multiple-definition-of-ipc_handle.patch | |||
@@ -1,4 +1,4 @@ | |||
1 | From 8c433aa6c6b2eaed4084233beea99ee3fb0b652f Mon Sep 17 00:00:00 2001 | 1 | From 2338329e35254c1b8a887409d930ca76d9612093 Mon Sep 17 00:00:00 2001 |
2 | From: Samuel Holland <samuel@sholland.org> | 2 | From: Samuel Holland <samuel@sholland.org> |
3 | Date: Wed, 4 Dec 2019 02:45:58 -0600 | 3 | Date: Wed, 4 Dec 2019 02:45:58 -0600 |
4 | Subject: [PATCH] imx: Fix multiple definition of ipc_handle | 4 | Subject: [PATCH] imx: Fix multiple definition of ipc_handle |
@@ -15,20 +15,19 @@ Change-Id: I6535954cc567d6efa06919069b91e3f50975b073 | |||
15 | 2 files changed, 3 insertions(+), 1 deletion(-) | 15 | 2 files changed, 3 insertions(+), 1 deletion(-) |
16 | 16 | ||
17 | diff --git a/plat/imx/common/include/sci/sci_ipc.h b/plat/imx/common/include/sci/sci_ipc.h | 17 | diff --git a/plat/imx/common/include/sci/sci_ipc.h b/plat/imx/common/include/sci/sci_ipc.h |
18 | index 7cb109206..d2c3bba1c 100644 | 18 | index cc8e47b28..1e3e53247 100755 |
19 | --- a/plat/imx/common/include/sci/sci_ipc.h | 19 | --- a/plat/imx/common/include/sci/sci_ipc.h |
20 | +++ b/plat/imx/common/include/sci/sci_ipc.h | 20 | +++ b/plat/imx/common/include/sci/sci_ipc.h |
21 | @@ -63,7 +63,7 @@ void sc_ipc_read(sc_ipc_t ipc, void *data); | 21 | @@ -63,6 +63,6 @@ void sc_ipc_read(sc_ipc_t ipc, void *data); |
22 | */ | 22 | */ |
23 | void sc_ipc_write(sc_ipc_t ipc, const void *data); | 23 | void sc_ipc_write(sc_ipc_t ipc, const void *data); |
24 | 24 | ||
25 | -sc_ipc_t ipc_handle; | 25 | -sc_ipc_t ipc_handle; |
26 | +extern sc_ipc_t ipc_handle; | 26 | +extern sc_ipc_t ipc_handle; |
27 | 27 | ||
28 | #endif /* SC_IPC_H */ | 28 | #endif /* SCI_IPC_H */ |
29 | |||
30 | diff --git a/plat/imx/common/sci/ipc.c b/plat/imx/common/sci/ipc.c | 29 | diff --git a/plat/imx/common/sci/ipc.c b/plat/imx/common/sci/ipc.c |
31 | index 68b0b8ef0..3169b7e0b 100644 | 30 | index f329482fe..bf35a5ead 100755 |
32 | --- a/plat/imx/common/sci/ipc.c | 31 | --- a/plat/imx/common/sci/ipc.c |
33 | +++ b/plat/imx/common/sci/ipc.c | 32 | +++ b/plat/imx/common/sci/ipc.c |
34 | @@ -11,6 +11,8 @@ | 33 | @@ -11,6 +11,8 @@ |
@@ -37,7 +36,7 @@ index 68b0b8ef0..3169b7e0b 100644 | |||
37 | 36 | ||
38 | +sc_ipc_t ipc_handle; | 37 | +sc_ipc_t ipc_handle; |
39 | + | 38 | + |
40 | #include <bakery_lock.h> | 39 | #include <lib/bakery_lock.h> |
41 | DEFINE_BAKERY_LOCK(sc_ipc_bakery_lock); | 40 | DEFINE_BAKERY_LOCK(sc_ipc_bakery_lock); |
42 | #define sc_ipc_lock_init() bakery_lock_init(&sc_ipc_bakery_lock) | 41 | #define sc_ipc_lock_init() bakery_lock_init(&sc_ipc_bakery_lock) |
43 | -- | 42 | -- |
diff --git a/recipes-bsp/imx-atf/imx-atf_2.0.bb b/recipes-bsp/imx-atf/imx-atf_2.2.bb index 1e1baba3..ab99f2fe 100644 --- a/recipes-bsp/imx-atf/imx-atf_2.0.bb +++ b/recipes-bsp/imx-atf/imx-atf_2.2.bb | |||
@@ -1,4 +1,4 @@ | |||
1 | # Copyright (C) 2017-2019 NXP | 1 | # Copyright (C) 2017-2020 NXP |
2 | 2 | ||
3 | DESCRIPTION = "i.MX ARM Trusted Firmware" | 3 | DESCRIPTION = "i.MX ARM Trusted Firmware" |
4 | SECTION = "BSP" | 4 | SECTION = "BSP" |
@@ -7,12 +7,12 @@ LIC_FILES_CHKSUM = "file://${COREBASE}/meta/files/common-licenses/BSD-3-Clause;m | |||
7 | 7 | ||
8 | PV .= "+git${SRCPV}" | 8 | PV .= "+git${SRCPV}" |
9 | 9 | ||
10 | SRCBRANCH = "lf-5.4.y" | 10 | SRCBRANCH = "imx_5.4.24_2.1.0" |
11 | SRC_URI = "git://source.codeaurora.org/external/imx/imx-atf.git;protocol=https;branch=${SRCBRANCH} \ | 11 | SRC_URI = "git://source.codeaurora.org/external/imx/imx-atf.git;protocol=https;branch=${SRCBRANCH} \ |
12 | file://0001-Allow-BUILD_STRING-to-be-set-in-.revision-file.patch \ | 12 | file://0001-imx-Fix-missing-inclusion-of-cdefs.h.patch \ |
13 | file://0001-imx-Fix-multiple-definition-of-ipc_handle.patch \ | 13 | file://0001-imx-Fix-multiple-definition-of-ipc_handle.patch \ |
14 | " | 14 | " |
15 | SRCREV = "7b3389d49815f1e3f7942bd312a27ee665bd2e33" | 15 | SRCREV = "b0a00f22b09c13572d3e87902a1069dee34763bd" |
16 | 16 | ||
17 | S = "${WORKDIR}/git" | 17 | S = "${WORKDIR}/git" |
18 | 18 | ||
@@ -22,10 +22,14 @@ BOOT_TOOLS = "imx-boot-tools" | |||
22 | 22 | ||
23 | PLATFORM ?= "INVALID" | 23 | PLATFORM ?= "INVALID" |
24 | PLATFORM_mx8qm = "imx8qm" | 24 | PLATFORM_mx8qm = "imx8qm" |
25 | PLATFORM_mx8qxp = "imx8qx" | 25 | PLATFORM_mx8x = "imx8qx" |
26 | PLATFORM_mx8mq = "imx8mq" | 26 | PLATFORM_mx8mq = "imx8mq" |
27 | PLATFORM_mx8mm = "imx8mm" | 27 | PLATFORM_mx8mm = "imx8mm" |
28 | PLATFORM_mx8mn = "imx8mn" | 28 | PLATFORM_mx8mn = "imx8mn" |
29 | PLATFORM_mx8mp = "imx8mp" | ||
30 | PLATFORM_mx8dx = "imx8dx" | ||
31 | PLATFORM_imx8dxlevk = "imx8dxl" | ||
32 | PLATFORM_mx8dxlevk-phantom = "imx8qx" | ||
29 | 33 | ||
30 | EXTRA_OEMAKE += " \ | 34 | EXTRA_OEMAKE += " \ |
31 | CROSS_COMPILE="${TARGET_PREFIX}" \ | 35 | CROSS_COMPILE="${TARGET_PREFIX}" \ |