diff options
author | Max Krummenacher <max.krummenacher@toradex.com> | 2022-08-24 13:27:59 +0200 |
---|---|---|
committer | github-actions[bot] <github-actions[bot]@users.noreply.github.com> | 2022-08-24 17:37:13 +0000 |
commit | b1d1d4013f598e74ca15d779f1863457962112a9 (patch) | |
tree | c379e559022992c6b051d6b06fb07159d643f93f /recipes-bsp/imx-atf | |
parent | f89933bbebc21506ab75be63fba9ffbaebed94da (diff) | |
download | meta-freescale-b1d1d4013f598e74ca15d779f1863457962112a9.tar.gz |
imx-atf: fix build error with binutils 2.39backport-1179-to-kirkstone
This disables the warning about a LOAD segment in the produced elf file
which has RWX permissions set. As the build is set to error out on any
warning the build fails without this patch.
| LD ...imx-atf/2.6+gitAUTOINC+c6a19b1a35-r0/git/build/imx8mm/release/bl31/bl31.elf
| aarch64-tdx-linux-ld: warning: ...git/build/imx8mm/release/bl31/bl31.elf has a LOAD segment with RWX permissions
| make: *** [Makefile:1254: ...git/build/imx8mm/release/bl31/bl31.elf] Error 1
| ERROR: oe_runmake failed
Bug report for atf: https://developer.trustedfirmware.org/T996
Reported-by: Peter Bergin <peter@berginkonsult.se>
Signed-off-by: Max Krummenacher <max.krummenacher@toradex.com>
(cherry picked from commit bac8c6af8471addb7add0d1b1ddfbbbd36bed16e)
Diffstat (limited to 'recipes-bsp/imx-atf')
-rw-r--r-- | recipes-bsp/imx-atf/imx-atf_2.6.bb | 5 |
1 files changed, 3 insertions, 2 deletions
diff --git a/recipes-bsp/imx-atf/imx-atf_2.6.bb b/recipes-bsp/imx-atf/imx-atf_2.6.bb index b0426f0b..1df61cab 100644 --- a/recipes-bsp/imx-atf/imx-atf_2.6.bb +++ b/recipes-bsp/imx-atf/imx-atf_2.6.bb | |||
@@ -29,7 +29,9 @@ EXTRA_OEMAKE += " \ | |||
29 | 29 | ||
30 | # Let the Makefile handle setting up the CFLAGS and LDFLAGS as it is a standalone application | 30 | # Let the Makefile handle setting up the CFLAGS and LDFLAGS as it is a standalone application |
31 | CFLAGS[unexport] = "1" | 31 | CFLAGS[unexport] = "1" |
32 | LDFLAGS[unexport] = "1" | 32 | # Needed for binutils >= 2.39 to prevent build failure. |
33 | # imx-atf links with ld, thus no '-Wl,' prefix | ||
34 | LDFLAGS = "--no-warn-rwx-segments" | ||
33 | AS[unexport] = "1" | 35 | AS[unexport] = "1" |
34 | LD[unexport] = "1" | 36 | LD[unexport] = "1" |
35 | 37 | ||
@@ -56,7 +58,6 @@ EXTRA_OEMAKE += 'IMX_BOOT_UART_BASE=${ATF_BOOT_UART_BASE}' | |||
56 | do_configure[noexec] = "1" | 58 | do_configure[noexec] = "1" |
57 | 59 | ||
58 | do_compile() { | 60 | do_compile() { |
59 | # Clear LDFLAGS to avoid the option -Wl recognize issue | ||
60 | oe_runmake bl31 | 61 | oe_runmake bl31 |
61 | if ${BUILD_OPTEE}; then | 62 | if ${BUILD_OPTEE}; then |
62 | oe_runmake clean BUILD_BASE=build-optee | 63 | oe_runmake clean BUILD_BASE=build-optee |