summaryrefslogtreecommitdiffstats
path: root/recipes-bsp/firmware-imx/firmware-sof-imx_2.2.0.bb
diff options
context:
space:
mode:
authorMax Krummenacher <max.krummenacher@toradex.com>2022-11-28 10:17:06 +0100
committergithub-actions[bot] <github-actions[bot]@users.noreply.github.com>2022-11-28 15:51:21 +0000
commit7a27adb44359063e12f5cc0210d05cd37d664a73 (patch)
tree09b9685defce3f8ddf253a02cd865ca29dfd78da /recipes-bsp/firmware-imx/firmware-sof-imx_2.2.0.bb
parentcf3221cda330fa315d227f5f3941550706898ce2 (diff)
downloadmeta-freescale-7a27adb44359063e12f5cc0210d05cd37d664a73.tar.gz
firmware-sof-imx: upgrade from 1.9.0-1 to 2.2.0
Update to the version used in lf5.15.52_2.1.0. Signed-off-by: Max Krummenacher <max.krummenacher@toradex.com> (cherry picked from commit 17d3879b85d65c83b2b4241fedbfdd88f80aadcd)
Diffstat (limited to 'recipes-bsp/firmware-imx/firmware-sof-imx_2.2.0.bb')
-rw-r--r--recipes-bsp/firmware-imx/firmware-sof-imx_2.2.0.bb24
1 files changed, 24 insertions, 0 deletions
diff --git a/recipes-bsp/firmware-imx/firmware-sof-imx_2.2.0.bb b/recipes-bsp/firmware-imx/firmware-sof-imx_2.2.0.bb
new file mode 100644
index 00000000..13edc7a6
--- /dev/null
+++ b/recipes-bsp/firmware-imx/firmware-sof-imx_2.2.0.bb
@@ -0,0 +1,24 @@
1# Copyright (C) 2020 Mihai Lindner <mihai.lindner@nxp.com>
2# Released under the MIT license (see COPYING.MIT for the terms)
3
4DESCRIPTION = "Sound Open Firmware"
5HOMEPAGE = "https://www.sofproject.org"
6SECTION = "base"
7LICENSE = "BSD-3-Clause"
8LIC_FILES_CHKSUM = "file://LICENCE;md5=0f00d99239d922ffd13cabef83b33444"
9
10SRC_URI = "${FSL_MIRROR}/sof-imx-${PV}.tar.gz"
11SRC_URI[md5sum] = "f0a86b07c83f7cd981068682c7e8593b"
12SRC_URI[sha256sum] = "bdd004808c41690fac277f30e791fbd87e665e75f4c1b6af9c18e9df9fb6f503"
13
14S = "${WORKDIR}/sof-imx-${PV}"
15
16inherit allarch
17
18do_install() {
19 # Install sof and sof-tplg folder
20 install -d ${D}${nonarch_base_libdir}/firmware/imx/
21 cp -r sof* ${D}${nonarch_base_libdir}/firmware/imx/
22}
23
24FILES:${PN} = "${nonarch_base_libdir}/firmware/imx"