summaryrefslogtreecommitdiffstats
path: root/recipes-bsp/firmware-imx/firmware-imx_8.5.bb
diff options
context:
space:
mode:
authorAndrey Zhizhikin <andrey.z@gmail.com>2020-08-31 08:27:12 +0000
committerOtavio Salvador <otavio@ossystems.com.br>2020-09-23 23:42:37 -0300
commitb3eff3e4cea333e35401e031293731ab32bc0929 (patch)
treeb3108cbaf19d1b093014d52dbd4fd2a54b3e0b92 /recipes-bsp/firmware-imx/firmware-imx_8.5.bb
parent4ff5c74607d49d40898bc18416365f7a050651aa (diff)
downloadmeta-freescale-b3eff3e4cea333e35401e031293731ab32bc0929.tar.gz
firmware-imx: upgrade to version 8.8
Update all recipe PN to match the one from upstream. Latest delivery from NXP has VPU firmware for imx27 in the package, so enable it to be included in the image. It also also lacks the VPU firmware for imx8qxp, so disable the package for now until it is provided from NXP. firmware-imx has been re-worked to provide a more unified mechanism for installing firmware files into ${D} and package split is expalined in the comments section. NOTE: This update uses new EULA v11 from NXP. Signed-off-by: Andrey Zhizhikin <andrey.z@gmail.com>
Diffstat (limited to 'recipes-bsp/firmware-imx/firmware-imx_8.5.bb')
-rw-r--r--recipes-bsp/firmware-imx/firmware-imx_8.5.bb76
1 files changed, 0 insertions, 76 deletions
diff --git a/recipes-bsp/firmware-imx/firmware-imx_8.5.bb b/recipes-bsp/firmware-imx/firmware-imx_8.5.bb
deleted file mode 100644
index ff623057..00000000
--- a/recipes-bsp/firmware-imx/firmware-imx_8.5.bb
+++ /dev/null
@@ -1,76 +0,0 @@
1# Copyright (C) 2012-2016 Freescale Semiconductor
2# Copyright 2017-2019 NXP
3# Copyright (C) 2018 O.S. Systems Software LTDA.
4SUMMARY = "Freescale i.MX firmware"
5DESCRIPTION = "Freescale i.MX firmware such as for the VPU"
6
7require firmware-imx-${PV}.inc
8
9PE = "1"
10
11SRC_URI += " \
12 git://github.com/NXP/imx-firmware.git;protocol=https;branch=${SRCBRANCH};destsuffix=${S}/git \
13"
14SRCREV = "8ce9046f5058fdd2c5271f86ccfc61bc5a248ae3"
15
16inherit allarch
17
18do_install() {
19 install -d ${D}${base_libdir}/firmware/imx
20
21 cd firmware
22 for d in *; do
23 case $d in
24 easrc)
25 # excluding as only applies Nano SoC
26 ;;
27 ddr|hdmi|seco)
28 # These folders are for i.MX 8 and are included in the boot image via imx-boot
29 bbnote Excluding folder $d
30 ;;
31 *)
32 cp -rfv $d ${D}${base_libdir}/firmware
33 ;;
34 esac
35 done
36 cd -
37
38 mv ${D}${base_libdir}/firmware/epdc/ ${D}${base_libdir}/firmware/imx/epdc/
39 mv ${D}${base_libdir}/firmware/imx/epdc/epdc_ED060XH2C1.fw.nonrestricted ${D}${base_libdir}/firmware/imx/epdc/epdc_ED060XH2C1.fw
40
41 find ${D}${base_libdir}/firmware -type f -exec chmod 644 '{}' ';'
42 find ${D}${base_libdir}/firmware -type f -exec chown root:root '{}' ';'
43
44 # Remove files not going to be installed
45 rm ${D}${base_libdir}/firmware/sdma/sdma-imx6q.bin
46 rm ${D}${base_libdir}/firmware/sdma/sdma-imx7d.bin
47 find ${D}${base_libdir}/firmware/ -name '*.mk' -exec rm '{}' ';'
48}
49
50python populate_packages_prepend() {
51 vpudir = bb.data.expand('${base_libdir}/firmware/vpu', d)
52 do_split_packages(d, vpudir, '^vpu_fw_([^_]*).*\.bin',
53 output_pattern='firmware-imx-vpu-%s',
54 description='Freescale IMX Firmware %s',
55 extra_depends='',
56 prepend=True)
57
58 sdmadir = bb.data.expand('${base_libdir}/firmware/sdma', d)
59 do_split_packages(d, sdmadir, '^sdma-([^-]*).*\.bin',
60 output_pattern='firmware-imx-sdma-%s',
61 description='Freescale IMX Firmware %s',
62 extra_depends='',
63 prepend=True)
64}
65
66ALLOW_EMPTY_${PN} = "1"
67
68PACKAGES_DYNAMIC = "${PN}-vpu-* ${PN}-sdma-*"
69
70PACKAGES =+ "${PN}-epdc ${PN}-scfw ${PN}-sdma"
71
72FILES_${PN}-epdc = "${base_libdir}/firmware/imx/epdc/"
73FILES_${PN}-scfw = "${base_libdir}/firmware/scfw/"
74FILES_${PN}-sdma = " ${base_libdir}/firmware/imx/sdma"
75
76COMPATIBLE_MACHINE = "(imx|use-mainline-bsp)"