summaryrefslogtreecommitdiffstats
path: root/recipes-bsp/firmware-imx/firmware-imx-8m_8.18.bb
diff options
context:
space:
mode:
authorOtavio Salvador <otavio@ossystems.com.br>2023-01-10 08:33:43 -0300
committerGitHub <noreply@github.com>2023-01-10 08:33:43 -0300
commit8ef79121cc16a5ee3616d115abd809ac615dc187 (patch)
tree84af12b6bfc5766f075e19d8937f44c7bc64213c /recipes-bsp/firmware-imx/firmware-imx-8m_8.18.bb
parente5cc73fb4770d7e1a3d65c0536bcf2cdad0a2ea7 (diff)
parentd6362b0423f50dfcb3e7e3b557118cc6544ae353 (diff)
downloadmeta-freescale-8ef79121cc16a5ee3616d115abd809ac615dc187.tar.gz
Merge pull request #1369 from Freescale/backport-1362-to-kirkstone
[Backport kirkstone] Update firmware and atf to 5.15.71-2.2.0
Diffstat (limited to 'recipes-bsp/firmware-imx/firmware-imx-8m_8.18.bb')
-rw-r--r--recipes-bsp/firmware-imx/firmware-imx-8m_8.18.bb24
1 files changed, 24 insertions, 0 deletions
diff --git a/recipes-bsp/firmware-imx/firmware-imx-8m_8.18.bb b/recipes-bsp/firmware-imx/firmware-imx-8m_8.18.bb
new file mode 100644
index 00000000..152ef0b5
--- /dev/null
+++ b/recipes-bsp/firmware-imx/firmware-imx-8m_8.18.bb
@@ -0,0 +1,24 @@
1# Copyright (C) 2018-2020 NXP
2SUMMARY = "Freescale i.MX firmware for 8M and 8M Mini family"
3DESCRIPTION = "Freescale i.MX firmware for 8M and 8M Mini family"
4
5require firmware-imx-${PV}.inc
6
7inherit deploy
8
9do_install[noexec] = "1"
10
11do_deploy() {
12 # Synopsys DDR
13 for ddr_firmware in ${DDR_FIRMWARE_NAME}; do
14 install -m 0644 ${S}/firmware/ddr/synopsys/${ddr_firmware} ${DEPLOYDIR}
15 done
16 # Cadence DP and HDMI
17 install -m 0644 ${S}/firmware/hdmi/cadence/signed_dp_imx8m.bin ${DEPLOYDIR}
18 install -m 0644 ${S}/firmware/hdmi/cadence/signed_hdmi_imx8m.bin ${DEPLOYDIR}
19}
20addtask deploy after do_install before do_build
21
22PACKAGE_ARCH = "${MACHINE_SOCARCH}"
23
24COMPATIBLE_MACHINE = "(mx8m-generic-bsp)"