diff options
author | Otavio Salvador <otavio@ossystems.com.br> | 2015-07-15 17:14:27 -0300 |
---|---|---|
committer | Otavio Salvador <otavio@ossystems.com.br> | 2015-07-16 15:01:29 -0300 |
commit | f8517afc7a5ada4538b3b7d397fa32586d57ffe5 (patch) | |
tree | 79349f091306d1760fd4687e62336ffa8fb8c721 /recipes-bsp/elftosb | |
parent | c92b415d653afc55f33b6b93fb9248193bfd4fa0 (diff) | |
download | meta-freescale-f8517afc7a5ada4538b3b7d397fa32586d57ffe5.tar.gz |
Move meta-fsl-arm content to layer root
The meta-fsl-arm is going to be used as the base for this layer. It
contains a clean history and allowing a more granullar set of changes.
This commit is just a rename of all contents of meta-fsl-arm
subdirectory to this layer's root, subsequent changes are based on top
of that.
Signed-off-by: Otavio Salvador <otavio@ossystems.com.br>
Diffstat (limited to 'recipes-bsp/elftosb')
-rw-r--r-- | recipes-bsp/elftosb/elftosb_10.12.01.bb | 22 | ||||
-rw-r--r-- | recipes-bsp/elftosb/files/cross-build.patch | 50 | ||||
-rw-r--r-- | recipes-bsp/elftosb/files/don-t-use-full-path-for-headers.patch | 42 |
3 files changed, 114 insertions, 0 deletions
diff --git a/recipes-bsp/elftosb/elftosb_10.12.01.bb b/recipes-bsp/elftosb/elftosb_10.12.01.bb new file mode 100644 index 00000000..2cef1f6a --- /dev/null +++ b/recipes-bsp/elftosb/elftosb_10.12.01.bb | |||
@@ -0,0 +1,22 @@ | |||
1 | # Copyright (C) 2011, 2012 Freescale | ||
2 | # Released under the MIT license (see COPYING.MIT for the terms) | ||
3 | |||
4 | DESCRIPTION = "Helper utility for freescale imx platforms" | ||
5 | LICENSE = "MIT" | ||
6 | LIC_FILES_CHKSUM = "file://COPYING;md5=172ede34353056ebec7a597d8459f029" | ||
7 | SECTION = "bootloader" | ||
8 | PR = "r4" | ||
9 | BBCLASSEXTEND = "native nativesdk" | ||
10 | |||
11 | SRC_URI = "http://repository.timesys.com/buildsources/e/elftosb/elftosb-${PV}/elftosb-${PV}.tar.gz \ | ||
12 | file://cross-build.patch \ | ||
13 | file://don-t-use-full-path-for-headers.patch" | ||
14 | SRC_URI[md5sum] = "e8005d606c1e0bb3507c82f6eceb3056" | ||
15 | SRC_URI[sha256sum] = "77bb6981620f7575b87d136d94c7daa88dd09195959cc75fc18b138369ecd42b" | ||
16 | |||
17 | do_install() { | ||
18 | install -d ${D}${bindir} | ||
19 | install ${S}/bld/linux/elftosb ${D}${bindir} | ||
20 | install ${S}/bld/linux/keygen ${D}${bindir} | ||
21 | install ${S}/bld/linux/sbtool ${D}${bindir} | ||
22 | } | ||
diff --git a/recipes-bsp/elftosb/files/cross-build.patch b/recipes-bsp/elftosb/files/cross-build.patch new file mode 100644 index 00000000..8cffa03e --- /dev/null +++ b/recipes-bsp/elftosb/files/cross-build.patch | |||
@@ -0,0 +1,50 @@ | |||
1 | --- a/makefile.rules.orig 2012-05-09 21:03:28.000000000 +0200 | ||
2 | +++ b/makefile.rules 2012-05-09 21:03:56.000000000 +0200 | ||
3 | @@ -9,6 +9,8 @@ | ||
4 | # SRC_DIR needs to be passed in. It is assumed that make is running in | ||
5 | # the build directory. | ||
6 | |||
7 | +CC ?= gcc | ||
8 | + | ||
9 | #******************************************************************************* | ||
10 | # Environment | ||
11 | |||
12 | @@ -101,7 +103,7 @@ | ||
13 | keygen.o | ||
14 | |||
15 | |||
16 | -LIBS = -lstdc++ | ||
17 | +LIBS ?= -lstdc++ -lm | ||
18 | |||
19 | |||
20 | ifeq ("${UNAMES}", "Linux") | ||
21 | @@ -137,13 +139,13 @@ | ||
22 | ${EXEC_FILE_ELFTOSB2} ${EXEC_FILE_SBTOOL} ${EXEC_FILE_KEYGEN} | ||
23 | |||
24 | elftosb: ${OBJ_FILES_ELFTOSB2} | ||
25 | - gcc ${OBJ_FILES_ELFTOSB2} ${LIBS} -o ${EXEC_FILE_ELFTOSB2} | ||
26 | + ${CC} ${OBJ_FILES_ELFTOSB2} ${LIBS} -o ${EXEC_FILE_ELFTOSB2} | ||
27 | |||
28 | sbtool: ${OBJ_FILES_SBTOOL} | ||
29 | - gcc ${OBJ_FILES_SBTOOL} ${LIBS} -o ${EXEC_FILE_SBTOOL} | ||
30 | + ${CC} ${OBJ_FILES_SBTOOL} ${LIBS} -o ${EXEC_FILE_SBTOOL} | ||
31 | |||
32 | keygen: ${OBJ_FILES_KEYGEN} | ||
33 | - gcc ${OBJ_FILES_KEYGEN} ${LIBS} -o ${EXEC_FILE_KEYGEN} | ||
34 | + ${CC} ${OBJ_FILES_KEYGEN} ${LIBS} -o ${EXEC_FILE_KEYGEN} | ||
35 | |||
36 | |||
37 | #ifeq ("${UNAMES}", "Linux") | ||
38 | @@ -153,10 +155,10 @@ | ||
39 | .SUFFIXES : .c .cpp | ||
40 | |||
41 | .c.o : | ||
42 | - gcc ${CFLAGS} -c $< | ||
43 | + ${CC} ${CFLAGS} -c $< | ||
44 | |||
45 | .cpp.o : | ||
46 | - gcc ${CFLAGS} -c $< | ||
47 | + ${CC} ${CFLAGS} -c $< | ||
48 | |||
49 | #endif | ||
50 | |||
diff --git a/recipes-bsp/elftosb/files/don-t-use-full-path-for-headers.patch b/recipes-bsp/elftosb/files/don-t-use-full-path-for-headers.patch new file mode 100644 index 00000000..8996ffbb --- /dev/null +++ b/recipes-bsp/elftosb/files/don-t-use-full-path-for-headers.patch | |||
@@ -0,0 +1,42 @@ | |||
1 | elftosb: don't use full path for headers | ||
2 | |||
3 | This fixes the building on new host distributions where header might | ||
4 | move due multilib support and other possible changes in future. | ||
5 | |||
6 | Upstream-Status: Pending | ||
7 | |||
8 | Signed-off-by: Otavio Salvador <otavio@ossystems.com.br> | ||
9 | --- | ||
10 | common/stdafx.h | 2 +- | ||
11 | stdafx.h | 2 +- | ||
12 | 2 files changed, 2 insertions(+), 2 deletions(-) | ||
13 | |||
14 | diff --git a/common/stdafx.h b/common/stdafx.h | ||
15 | index e6bf9dd..fb3c2d7 100644 | ||
16 | --- a/common/stdafx.h | ||
17 | +++ b/common/stdafx.h | ||
18 | @@ -27,7 +27,7 @@ | ||
19 | // For Linux systems only, types.h only defines the signed | ||
20 | // integer types. This is not professional code. | ||
21 | // Update: They are defined in the header files in the more recent version of redhat enterprise gcc. | ||
22 | -#include "/usr/include/sys/types.h" | ||
23 | +#include <sys/types.h> | ||
24 | #include <stdint.h> | ||
25 | //typedef unsigned long uint32_t; | ||
26 | //typedef unsigned short uint16_t; | ||
27 | diff --git a/stdafx.h b/stdafx.h | ||
28 | index ce80458..6ff2f44 100644 | ||
29 | --- a/stdafx.h | ||
30 | +++ b/stdafx.h | ||
31 | @@ -27,7 +27,7 @@ | ||
32 | // For Linux systems only, types.h only defines the signed | ||
33 | // integer types. This is not professional code. | ||
34 | // Update: They are defined in the header files in the more recent version of redhat enterprise gcc. | ||
35 | -#include "/usr/include/sys/types.h" | ||
36 | +#include <sys/types.h> | ||
37 | //typedef unsigned long uint32_t; | ||
38 | //typedef unsigned short uint16_t; | ||
39 | //typedef unsigned char uint8_t; | ||
40 | -- | ||
41 | 1.7.2.5 | ||
42 | |||