diff options
author | Chunrong Guo <chunrong.guo@nxp.com> | 2019-01-11 03:14:32 +0000 |
---|---|---|
committer | Otavio Salvador <otavio@ossystems.com.br> | 2019-01-14 16:23:38 -0200 |
commit | a7e2af210c6968914215c7cd32ccb47512408719 (patch) | |
tree | 04d3489e7c971724f438adf36f1671bfb5430ec8 /recipes-bsp/ddr-phy | |
parent | 84770ce75aa5402c29333fb36da2f69e1fbf3a1b (diff) | |
download | meta-freescale-a7e2af210c6968914215c7cd32ccb47512408719.tar.gz |
ddr-phy: add recipes
*update to lsdk 1812 tag
include the following changes
14d03e6 - Add fip file for DDR binaries for TF-A flow
241bedb - lx2: ddr: phy: add rdimm phy binaries.
2cb8757 - lx2: ddr: phy: add udimm phy binaries.
4081187 - Initial Commit
Signed-off-by: Chunrong Guo <chunrong.guo@nxp.com>
Diffstat (limited to 'recipes-bsp/ddr-phy')
-rw-r--r-- | recipes-bsp/ddr-phy/ddr-phy_git.bb | 29 |
1 files changed, 29 insertions, 0 deletions
diff --git a/recipes-bsp/ddr-phy/ddr-phy_git.bb b/recipes-bsp/ddr-phy/ddr-phy_git.bb new file mode 100644 index 00000000..ebd68c26 --- /dev/null +++ b/recipes-bsp/ddr-phy/ddr-phy_git.bb | |||
@@ -0,0 +1,29 @@ | |||
1 | SUMMARY = "DDR firmware repository" | ||
2 | LICENSE = "NXP-Binary-EULA" | ||
3 | LIC_FILES_CHKSUM = "file://NXP-Binary-EULA.txt;md5=89cc852481956e861228286ac7430d74" | ||
4 | |||
5 | inherit deploy fsl-eula-unpack | ||
6 | |||
7 | SRC_URI = "git://github.com/nxp/ddr-phy-binary.git;fsl-eula=true;nobranch=1" | ||
8 | SRCREV = "14d03e6e748ed5ebb9440f264bb374f1280b061c" | ||
9 | |||
10 | S = "${WORKDIR}/git" | ||
11 | |||
12 | REGLEX_lx2160a = "lx2160a" | ||
13 | |||
14 | do_install () { | ||
15 | install -d ${D}/boot | ||
16 | install -m 755 ${S}/${REGLEX}/* ${D}/boot | ||
17 | } | ||
18 | |||
19 | do_deploy () { | ||
20 | install -d ${DEPLOYDIR}/ddr-phy | ||
21 | install -m 755 ${S}/${REGLEX}/* ${DEPLOYDIR}/ddr-phy | ||
22 | } | ||
23 | addtask deploy before do_populate_sysroot after do_install | ||
24 | |||
25 | PACKAGES += "${PN}-image" | ||
26 | FILES_${PN}-image += "/boot" | ||
27 | |||
28 | COMPATIBLE_MACHINE = "(lx2160a)" | ||
29 | PACKAGE_ARCH = "${MACHINE_ARCH}" | ||