diff options
author | Otavio Salvador <otavio@ossystems.com.br> | 2017-03-09 11:34:11 -0300 |
---|---|---|
committer | Otavio Salvador <otavio@ossystems.com.br> | 2017-03-09 17:14:12 -0300 |
commit | ca6203da00d224b236b93869151e09b167358d10 (patch) | |
tree | 3f24ae704ab849e60a956f0b5e1709ca2ee0d92c /recipes-bsp/change-file-endianess | |
parent | 74280e666377a9bd2b785f09dcf91bf1cb7a967a (diff) | |
download | meta-freescale-ca6203da00d224b236b93869151e09b167358d10.tar.gz |
change-file-endianess: Rework recipe completely
The recipe was mixing different concepts. It is intended to provide a
TCL script to change the endianess of files and the recipe was
conceptually wrong.
The use of the deploy class is wrong as it is not an artifact that is
going to be used to install a board but a tool required for
development (so the need of native and nativesdk variants).
Change-Id: I5ebb063fa1c57a8c7c307314ac6322abfa88d33c
Signed-off-by: Otavio Salvador <otavio@ossystems.com.br>
Diffstat (limited to 'recipes-bsp/change-file-endianess')
-rw-r--r-- | recipes-bsp/change-file-endianess/change-file-endianess.bb | 14 |
1 files changed, 1 insertions, 13 deletions
diff --git a/recipes-bsp/change-file-endianess/change-file-endianess.bb b/recipes-bsp/change-file-endianess/change-file-endianess.bb index 9cf2212e..fc98b015 100644 --- a/recipes-bsp/change-file-endianess/change-file-endianess.bb +++ b/recipes-bsp/change-file-endianess/change-file-endianess.bb | |||
@@ -5,10 +5,6 @@ LIC_FILES_CHKSUM = "file://${COREBASE}/LICENSE;md5=4d92cd373abda3937c2bc47fbc49d | |||
5 | 5 | ||
6 | SRC_URI = "file://byte_swap.tcl" | 6 | SRC_URI = "file://byte_swap.tcl" |
7 | 7 | ||
8 | RDEPENDS += "tcl-native" | ||
9 | |||
10 | inherit native deploy | ||
11 | |||
12 | S = "${WORKDIR}" | 8 | S = "${WORKDIR}" |
13 | 9 | ||
14 | do_configure[noexec] = "1" | 10 | do_configure[noexec] = "1" |
@@ -19,14 +15,6 @@ do_install () { | |||
19 | install -m 755 ${WORKDIR}/byte_swap.tcl ${D}/${bindir} | 15 | install -m 755 ${WORKDIR}/byte_swap.tcl ${D}/${bindir} |
20 | } | 16 | } |
21 | 17 | ||
22 | do_deploy () { | 18 | RDEPENDS_${PN} += "tcl" |
23 | : | ||
24 | } | ||
25 | |||
26 | do_deploy_class-native () { | ||
27 | install -d ${DEPLOYDIR} | ||
28 | cp -f ${S}/byte_swap.tcl ${DEPLOYDIR}/ | ||
29 | } | ||
30 | addtask deploy before do_build after do_populate_sysroot | ||
31 | 19 | ||
32 | BBCLASSEXTEND = "native nativesdk" | 20 | BBCLASSEXTEND = "native nativesdk" |