summaryrefslogtreecommitdiffstats
path: root/recipes-bsp/change-file-endianess/change-file-endianess.bb
diff options
context:
space:
mode:
authorOtavio Salvador <otavio@ossystems.com.br>2017-03-09 11:34:11 -0300
committerOtavio Salvador <otavio@ossystems.com.br>2017-03-09 17:33:58 -0300
commitb905dc4ec5628357fd2fd402903c236cab05aa51 (patch)
tree5a4531b5be4dfcdb44d4f578c9d55ff45783b697 /recipes-bsp/change-file-endianess/change-file-endianess.bb
parent32d4482f8f0e77ba4e03e7cf4e0970303351e101 (diff)
downloadmeta-freescale-b905dc4ec5628357fd2fd402903c236cab05aa51.tar.gz
change-file-endianess: Rework recipe completely
The recipe was mixing different concepts. It is intended to provide a TCL script to change the endianess of files and the recipe was conceptually wrong. The use of the deploy class is wrong as it is not an artifact that is going to be used to install a board but a tool required for development (so the need of native and nativesdk variants). Change-Id: I5ebb063fa1c57a8c7c307314ac6322abfa88d33c Signed-off-by: Otavio Salvador <otavio@ossystems.com.br>
Diffstat (limited to 'recipes-bsp/change-file-endianess/change-file-endianess.bb')
-rw-r--r--recipes-bsp/change-file-endianess/change-file-endianess.bb14
1 files changed, 1 insertions, 13 deletions
diff --git a/recipes-bsp/change-file-endianess/change-file-endianess.bb b/recipes-bsp/change-file-endianess/change-file-endianess.bb
index 9cf2212e..fc98b015 100644
--- a/recipes-bsp/change-file-endianess/change-file-endianess.bb
+++ b/recipes-bsp/change-file-endianess/change-file-endianess.bb
@@ -5,10 +5,6 @@ LIC_FILES_CHKSUM = "file://${COREBASE}/LICENSE;md5=4d92cd373abda3937c2bc47fbc49d
5 5
6SRC_URI = "file://byte_swap.tcl" 6SRC_URI = "file://byte_swap.tcl"
7 7
8RDEPENDS += "tcl-native"
9
10inherit native deploy
11
12S = "${WORKDIR}" 8S = "${WORKDIR}"
13 9
14do_configure[noexec] = "1" 10do_configure[noexec] = "1"
@@ -19,14 +15,6 @@ do_install () {
19 install -m 755 ${WORKDIR}/byte_swap.tcl ${D}/${bindir} 15 install -m 755 ${WORKDIR}/byte_swap.tcl ${D}/${bindir}
20} 16}
21 17
22do_deploy () { 18RDEPENDS_${PN} += "tcl"
23 :
24}
25
26do_deploy_class-native () {
27 install -d ${DEPLOYDIR}
28 cp -f ${S}/byte_swap.tcl ${DEPLOYDIR}/
29}
30addtask deploy before do_build after do_populate_sysroot
31 19
32BBCLASSEXTEND = "native nativesdk" 20BBCLASSEXTEND = "native nativesdk"