summaryrefslogtreecommitdiffstats
path: root/recipes-bsp/atf
diff options
context:
space:
mode:
authorDaniel Klauer <daniel.klauer@gin.de>2019-08-01 11:06:56 +0200
committerOtavio Salvador <otavio@ossystems.com.br>2019-08-15 14:49:22 -0300
commitc090df937b5f9e5487c045d1a6c958ef65abd87d (patch)
treed402d5b7cf7d0d30fd4e89c0edb32803c2c1ac4b /recipes-bsp/atf
parentaac5d31be8cca3dc58513fb3ad1d81d041fba140 (diff)
downloadmeta-freescale-c090df937b5f9e5487c045d1a6c958ef65abd87d.tar.gz
Split fiptool build into separate recipe
Previously, ddr-phy built native fiptool during its own build process, but without using Yocto's native toolchain settings. This results in unexpected host dependencies. For example, fiptool depends on openssl, which may or may not be installed on the host. So now fiptool is built in a separate recipe (atf-tools-native) which can easily depend on openssl. Signed-off-by: Daniel Klauer <daniel.klauer@gin.de>
Diffstat (limited to 'recipes-bsp/atf')
-rw-r--r--recipes-bsp/atf/atf-tools_git.bb19
1 files changed, 19 insertions, 0 deletions
diff --git a/recipes-bsp/atf/atf-tools_git.bb b/recipes-bsp/atf/atf-tools_git.bb
new file mode 100644
index 00000000..a5998fe2
--- /dev/null
+++ b/recipes-bsp/atf/atf-tools_git.bb
@@ -0,0 +1,19 @@
1SUMMARY = "Tools for ARM Trusted Firmware, e.g. FIP image creation tool"
2LICENSE = "BSD"
3LIC_FILES_CHKSUM = "file://license.rst;md5=e927e02bca647e14efd87e9e914b2443"
4
5SRC_URI = "git://source.codeaurora.org/external/qoriq/qoriq-components/atf;nobranch=1"
6SRCREV = "17f94e4315e81e3d1b22d863d9614d724e8273dc"
7
8S = "${WORKDIR}/git"
9
10DEPENDS += "openssl"
11
12EXTRA_OEMAKE = "fiptool V=1 HOSTCC='${CC} ${CPPFLAGS} ${CFLAGS} ${LDFLAGS}'"
13
14do_install () {
15 install -m 0755 -d ${D}/${bindir}
16 install -m 0755 ${S}/tools/fiptool/fiptool ${D}/${bindir}/
17}
18
19BBCLASSEXTEND = "native"