diff options
author | Ting Liu <ting.liu@nxp.com> | 2020-05-15 12:56:41 +0800 |
---|---|---|
committer | Otavio Salvador <otavio@ossystems.com.br> | 2020-05-15 08:36:56 -0300 |
commit | f3148122d6883d722c1ce34fc92d7f8908f492f5 (patch) | |
tree | dbb8cd4ae8184d54842c443466d3419689bf2d54 /recipes-bsp/atf | |
parent | 17e6370fbe7eb4ace55e45a4c39c0b2ff70968a8 (diff) | |
download | meta-freescale-f3148122d6883d722c1ce34fc92d7f8908f492f5.tar.gz |
atf: fix build failure due to optee binary not exist
When optee enabled in DISTRO_FEATURES, optee-os-qoriq is added as
DEPENDS, and atf tries to find optee binary under ${DEPLOY_DIR_IMAGE}.
This has issue when do_deploy task of optee-os-qoriq does not run
before atf's do_compile.
Switch to find optee binary under ${RECIPE_SYSROOT} instead of
${DEPLOY_DIR_IMAGE}.
Steps to reproduce the issue:
$ echo 'DISTRO_FEATURES_append = " optee"' >>conf/local.conf
$ bitbake -c cleansstate atf optee-os-qoriq
$ bitbake -c install optee-os-qoriq
$ bitbake -c compile atf
| Building lx2160ardb
| Makefile:633: *** 'BL32=.../tmp/deploy/images/lx2160ardb/optee/tee_lx2160ardb.bin'
| was specified, but '.../tmp/deploy/images/lx2160ardb/optee/tee_lx2160ardb.bin'
| does not exist. Stop.
| make: *** Waiting for unfinished jobs....
Signed-off-by: Ting Liu <ting.liu@nxp.com>
Diffstat (limited to 'recipes-bsp/atf')
-rw-r--r-- | recipes-bsp/atf/atf_git.bb | 2 |
1 files changed, 1 insertions, 1 deletions
diff --git a/recipes-bsp/atf/atf_git.bb b/recipes-bsp/atf/atf_git.bb index 695a4518..7b8e4c9f 100644 --- a/recipes-bsp/atf/atf_git.bb +++ b/recipes-bsp/atf/atf_git.bb | |||
@@ -101,7 +101,7 @@ do_compile() { | |||
101 | fi | 101 | fi |
102 | 102 | ||
103 | if [ "${BUILD_OPTEE}" = "true" ]; then | 103 | if [ "${BUILD_OPTEE}" = "true" ]; then |
104 | bl32="${DEPLOY_DIR_IMAGE}/optee/tee_${MACHINE}.bin" | 104 | bl32="${RECIPE_SYSROOT}${nonarch_base_libdir}/firmware/tee_${MACHINE}.bin" |
105 | bl32opt="BL32=${bl32}" | 105 | bl32opt="BL32=${bl32}" |
106 | spdopt="SPD=opteed" | 106 | spdopt="SPD=opteed" |
107 | fi | 107 | fi |