summaryrefslogtreecommitdiffstats
path: root/recipes-bsp/atf/qoriq-atf-tools_2.3.bb
diff options
context:
space:
mode:
authorTing Liu <ting.liu@nxp.com>2020-12-16 19:27:38 +0530
committerOtavio Salvador <otavio@ossystems.com.br>2020-12-16 13:13:18 -0300
commit7ce1aadc64d39a467527d905a274e1dad388512d (patch)
tree486c4f065b930658004499ab1d9bb87e6335a648 /recipes-bsp/atf/qoriq-atf-tools_2.3.bb
parenteaf9de847d80daa0fa6cc4fb3aa608ccc3a5e539 (diff)
downloadmeta-freescale-7ce1aadc64d39a467527d905a274e1dad388512d.tar.gz
atf: rename to qoriq-atf
Signed-off-by: Ting Liu <ting.liu@nxp.com>
Diffstat (limited to 'recipes-bsp/atf/qoriq-atf-tools_2.3.bb')
-rw-r--r--recipes-bsp/atf/qoriq-atf-tools_2.3.bb14
1 files changed, 14 insertions, 0 deletions
diff --git a/recipes-bsp/atf/qoriq-atf-tools_2.3.bb b/recipes-bsp/atf/qoriq-atf-tools_2.3.bb
new file mode 100644
index 00000000..d4be32be
--- /dev/null
+++ b/recipes-bsp/atf/qoriq-atf-tools_2.3.bb
@@ -0,0 +1,14 @@
1require qoriq-atf-${PV}.inc
2
3SUMMARY = "Tools for ARM Trusted Firmware, e.g. FIP image creation tool"
4
5DEPENDS += "openssl"
6
7EXTRA_OEMAKE = "fiptool V=1 HOSTCC='${CC} ${CPPFLAGS} ${CFLAGS} ${LDFLAGS}'"
8
9do_install () {
10 install -m 0755 -d ${D}/${bindir}
11 install -m 0755 ${S}/tools/fiptool/fiptool ${D}/${bindir}/
12}
13
14BBCLASSEXTEND = "native"