summaryrefslogtreecommitdiffstats
path: root/recipes-bsp/atf/atf_git.bb
diff options
context:
space:
mode:
authorDaniel Klauer <daniel.klauer@gin.de>2019-08-01 11:15:01 +0200
committerOtavio Salvador <otavio@ossystems.com.br>2019-08-15 14:49:22 -0300
commitfa4994b2d8da73fd3ae30875b3af8d7a682cdd53 (patch)
treecb7725e460151cab6b2010ca7e5764989902df7b /recipes-bsp/atf/atf_git.bb
parentc090df937b5f9e5487c045d1a6c958ef65abd87d (diff)
downloadmeta-freescale-fa4994b2d8da73fd3ae30875b3af8d7a682cdd53.tar.gz
atf: Fix builds of native tools during build process
atf builds some native tools such as fiptool during its build process, this should use Yocto's native toolchain options instead of just the host's. This way the fiptool build will actually use the openssl-native dependency from Yocto's native sysroot, instead of the host's openssl (which may not exist). Signed-off-by: Daniel Klauer <daniel.klauer@gin.de>
Diffstat (limited to 'recipes-bsp/atf/atf_git.bb')
-rw-r--r--recipes-bsp/atf/atf_git.bb2
1 files changed, 2 insertions, 0 deletions
diff --git a/recipes-bsp/atf/atf_git.bb b/recipes-bsp/atf/atf_git.bb
index bc182ebe..e3d18624 100644
--- a/recipes-bsp/atf/atf_git.bb
+++ b/recipes-bsp/atf/atf_git.bb
@@ -29,6 +29,8 @@ LDFLAGS[unexport] = "1"
29AS[unexport] = "1" 29AS[unexport] = "1"
30LD[unexport] = "1" 30LD[unexport] = "1"
31 31
32EXTRA_OEMAKE += "HOSTCC='${BUILD_CC} ${BUILD_CPPFLAGS} ${BUILD_CFLAGS} ${BUILD_LDFLAGS}'"
33
32BOOTTYPE ?= "nor nand qspi flexspi_nor sd emmc" 34BOOTTYPE ?= "nor nand qspi flexspi_nor sd emmc"
33BUILD_SECURE = "${@bb.utils.contains('DISTRO_FEATURES', 'secure', 'true', 'false', d)}" 35BUILD_SECURE = "${@bb.utils.contains('DISTRO_FEATURES', 'secure', 'true', 'false', d)}"
34BUILD_OPTEE = "${@bb.utils.contains('COMBINED_FEATURES', 'optee', 'true', 'false', d)}" 36BUILD_OPTEE = "${@bb.utils.contains('COMBINED_FEATURES', 'optee', 'true', 'false', d)}"