diff options
author | Otavio Salvador <otavio@ossystems.com.br> | 2015-07-15 17:14:27 -0300 |
---|---|---|
committer | Otavio Salvador <otavio@ossystems.com.br> | 2015-07-16 15:01:29 -0300 |
commit | f8517afc7a5ada4538b3b7d397fa32586d57ffe5 (patch) | |
tree | 79349f091306d1760fd4687e62336ffa8fb8c721 /recipes-bsp/apptrk | |
parent | c92b415d653afc55f33b6b93fb9248193bfd4fa0 (diff) | |
download | meta-freescale-f8517afc7a5ada4538b3b7d397fa32586d57ffe5.tar.gz |
Move meta-fsl-arm content to layer root
The meta-fsl-arm is going to be used as the base for this layer. It
contains a clean history and allowing a more granullar set of changes.
This commit is just a rename of all contents of meta-fsl-arm
subdirectory to this layer's root, subsequent changes are based on top
of that.
Signed-off-by: Otavio Salvador <otavio@ossystems.com.br>
Diffstat (limited to 'recipes-bsp/apptrk')
-rw-r--r-- | recipes-bsp/apptrk/apptrk/apptrk-install-create-all-components-of-DEST.patch | 24 | ||||
-rw-r--r-- | recipes-bsp/apptrk/apptrk/no-strip.patch | 20 | ||||
-rw-r--r-- | recipes-bsp/apptrk/apptrk_git.bb | 24 |
3 files changed, 68 insertions, 0 deletions
diff --git a/recipes-bsp/apptrk/apptrk/apptrk-install-create-all-components-of-DEST.patch b/recipes-bsp/apptrk/apptrk/apptrk-install-create-all-components-of-DEST.patch new file mode 100644 index 00000000..6b4a0e83 --- /dev/null +++ b/recipes-bsp/apptrk/apptrk/apptrk-install-create-all-components-of-DEST.patch | |||
@@ -0,0 +1,24 @@ | |||
1 | Upstream-Status: Pending | ||
2 | |||
3 | Signed-off-by: Chunrong Guo <B40290@freescale.com> | ||
4 | |||
5 | |||
6 | for fix the following error: | ||
7 | |install: cannot create regular file /usr/bin/apptrk | ||
8 | |No such file or directory | ||
9 | |||
10 | |||
11 | --- a/Makefileold 2014-12-21 23:46:26.872329032 -0600 | ||
12 | +++ b/Makefile 2014-12-21 23:47:33.724326646 -0600 | ||
13 | @@ -89,9 +89,9 @@ | ||
14 | # Other Targets | ||
15 | install: all | ||
16 | if [ -f $(DESTDIR)/usr/bin/apptrk ]; then rm -f $(DESTDIR)/usr/bin/apptrk ; fi | ||
17 | - install $(OUTPUT) $(DESTDIR)/usr/bin/apptrk | ||
18 | + install -D $(OUTPUT) $(DESTDIR)/usr/bin/apptrk | ||
19 | if [ -f $(DESTDIR)/usr/bin/apptrk_debug ]; then rm -f $(DESTDIR)/usr/bin/apptrk_debug ; fi | ||
20 | - install $(OUTPUT_DBG) $(DESTDIR)/usr/bin/apptrk_debug | ||
21 | + install -D $(OUTPUT_DBG) $(DESTDIR)/usr/bin/apptrk_debug | ||
22 | |||
23 | clean: | ||
24 | -$(RM) $(OBJS)$(OBJS_DBG)$(EXECUTABLES)$(C_DEPS)$(C_DEPS_DBG) $(OUTPUT) $(OUTPUT_DBG) | ||
diff --git a/recipes-bsp/apptrk/apptrk/no-strip.patch b/recipes-bsp/apptrk/apptrk/no-strip.patch new file mode 100644 index 00000000..a8cf6205 --- /dev/null +++ b/recipes-bsp/apptrk/apptrk/no-strip.patch | |||
@@ -0,0 +1,20 @@ | |||
1 | Disable stripping of binaries | ||
2 | |||
3 | We don't want to strip these as this is handled separately at package | ||
4 | time. | ||
5 | |||
6 | Upstream-Status: Inappropriate [configuration] | ||
7 | |||
8 | Signed-off-by: Chunrong Guo <B40290@freescale.com> | ||
9 | |||
10 | --- a/Makefileold 2015-01-07 03:45:32.786477574 -0600 | ||
11 | +++ b/Makefile 2015-01-07 03:46:28.426475588 -0600 | ||
12 | @@ -62,7 +62,7 @@ | ||
13 | # CFLAGS += -DENABLE_64BIT_SUPPORT | ||
14 | |||
15 | |||
16 | -LDFLAGS += -s | ||
17 | + | ||
18 | |||
19 | # Add inputs and outputs from these tool invocations to the build variables | ||
20 | |||
diff --git a/recipes-bsp/apptrk/apptrk_git.bb b/recipes-bsp/apptrk/apptrk_git.bb new file mode 100644 index 00000000..4453cf87 --- /dev/null +++ b/recipes-bsp/apptrk/apptrk_git.bb | |||
@@ -0,0 +1,24 @@ | |||
1 | SUMMARY = "Debug agent for Freescale CodeWarrior" | ||
2 | SECTION = "apptrk" | ||
3 | LICENSE = "Freescale-EULA" | ||
4 | LIC_FILES_CHKSUM = "file://COPYING;md5=95560debfde180684364319811cc1421" | ||
5 | |||
6 | DEPENDS = "elfutils" | ||
7 | |||
8 | inherit kernel-arch | ||
9 | |||
10 | SRC_URI = "git://git.freescale.com/ppc/sdk/apptrk.git;nobranch=1 \ | ||
11 | file://apptrk-install-create-all-components-of-DEST.patch \ | ||
12 | file://no-strip.patch \ | ||
13 | " | ||
14 | SRCREV = "cbed10997c5e2a4aaa004fb0e1efec858bf1bbe1" | ||
15 | |||
16 | S = "${WORKDIR}/git" | ||
17 | |||
18 | EXTRA_OEMAKE = "" | ||
19 | |||
20 | CFLAGS += " -I${STAGING_INCDIR}" | ||
21 | |||
22 | do_install() { | ||
23 | oe_runmake install DESTDIR=${D} | ||
24 | } | ||