summaryrefslogtreecommitdiffstats
path: root/recipes-bsp/apptrk/apptrk/apptrk-install-create-all-components-of-DEST.patch
diff options
context:
space:
mode:
authorOtavio Salvador <otavio@ossystems.com.br>2015-07-15 17:14:27 -0300
committerOtavio Salvador <otavio@ossystems.com.br>2015-07-16 15:01:29 -0300
commitf8517afc7a5ada4538b3b7d397fa32586d57ffe5 (patch)
tree79349f091306d1760fd4687e62336ffa8fb8c721 /recipes-bsp/apptrk/apptrk/apptrk-install-create-all-components-of-DEST.patch
parentc92b415d653afc55f33b6b93fb9248193bfd4fa0 (diff)
downloadmeta-freescale-f8517afc7a5ada4538b3b7d397fa32586d57ffe5.tar.gz
Move meta-fsl-arm content to layer root
The meta-fsl-arm is going to be used as the base for this layer. It contains a clean history and allowing a more granullar set of changes. This commit is just a rename of all contents of meta-fsl-arm subdirectory to this layer's root, subsequent changes are based on top of that. Signed-off-by: Otavio Salvador <otavio@ossystems.com.br>
Diffstat (limited to 'recipes-bsp/apptrk/apptrk/apptrk-install-create-all-components-of-DEST.patch')
-rw-r--r--recipes-bsp/apptrk/apptrk/apptrk-install-create-all-components-of-DEST.patch24
1 files changed, 24 insertions, 0 deletions
diff --git a/recipes-bsp/apptrk/apptrk/apptrk-install-create-all-components-of-DEST.patch b/recipes-bsp/apptrk/apptrk/apptrk-install-create-all-components-of-DEST.patch
new file mode 100644
index 00000000..6b4a0e83
--- /dev/null
+++ b/recipes-bsp/apptrk/apptrk/apptrk-install-create-all-components-of-DEST.patch
@@ -0,0 +1,24 @@
1Upstream-Status: Pending
2
3Signed-off-by: Chunrong Guo <B40290@freescale.com>
4
5
6 for fix the following error:
7 |install: cannot create regular file /usr/bin/apptrk
8 |No such file or directory
9
10
11--- a/Makefileold 2014-12-21 23:46:26.872329032 -0600
12+++ b/Makefile 2014-12-21 23:47:33.724326646 -0600
13@@ -89,9 +89,9 @@
14 # Other Targets
15 install: all
16 if [ -f $(DESTDIR)/usr/bin/apptrk ]; then rm -f $(DESTDIR)/usr/bin/apptrk ; fi
17- install $(OUTPUT) $(DESTDIR)/usr/bin/apptrk
18+ install -D $(OUTPUT) $(DESTDIR)/usr/bin/apptrk
19 if [ -f $(DESTDIR)/usr/bin/apptrk_debug ]; then rm -f $(DESTDIR)/usr/bin/apptrk_debug ; fi
20- install $(OUTPUT_DBG) $(DESTDIR)/usr/bin/apptrk_debug
21+ install -D $(OUTPUT_DBG) $(DESTDIR)/usr/bin/apptrk_debug
22
23 clean:
24 -$(RM) $(OBJS)$(OBJS_DBG)$(EXECUTABLES)$(C_DEPS)$(C_DEPS_DBG) $(OUTPUT) $(OUTPUT_DBG)