diff options
author | Otavio Salvador <otavio@ossystems.com.br> | 2022-02-18 21:49:11 -0300 |
---|---|---|
committer | Otavio Salvador <otavio@ossystems.com.br> | 2022-02-21 20:06:28 -0300 |
commit | dbd0f0ae908a6b287488707cfe9f2d464b9b02d5 (patch) | |
tree | 156a3e17bd827103a8584b5e7f346d8bf2afd943 /recipes-bsp/alsa-state | |
parent | 4cbbc15d937d2fbd487f10431c59cc1c21b791eb (diff) | |
download | meta-freescale-dbd0f0ae908a6b287488707cfe9f2d464b9b02d5.tar.gz |
Rework recipes to use imx-generic-bsp more extensively
This rework the recipes making use of new imx-generic-bsp override; it
has been applied to:
- alsa-state
- firmware-imx
- imx-kobs
- imx-test
- imx-uuc
- linux-fslc
- linux-fslc-lts
- packagegroup-fsl-mfgtool
- u-boot-fslc
- uuu
Signed-off-by: Otavio Salvador <otavio@ossystems.com.br>
Diffstat (limited to 'recipes-bsp/alsa-state')
-rw-r--r-- | recipes-bsp/alsa-state/alsa-state.bbappend | 12 | ||||
-rw-r--r-- | recipes-bsp/alsa-state/alsa-state/imx-generic-bsp/asound.conf (renamed from recipes-bsp/alsa-state/alsa-state/imx-nxp-bsp/asound.conf) | 0 | ||||
-rwxr-xr-x | recipes-bsp/alsa-state/alsa-state/imx-generic-bsp/asound.state (renamed from recipes-bsp/alsa-state/alsa-state/imx-nxp-bsp/asound.state) | 0 |
3 files changed, 3 insertions, 9 deletions
diff --git a/recipes-bsp/alsa-state/alsa-state.bbappend b/recipes-bsp/alsa-state/alsa-state.bbappend index 4d766139..b4b1eddf 100644 --- a/recipes-bsp/alsa-state/alsa-state.bbappend +++ b/recipes-bsp/alsa-state/alsa-state.bbappend | |||
@@ -1,10 +1,4 @@ | |||
1 | # Append path for freescale layer to include alsa-state asound.conf | 1 | FILESEXTRAPATHS:prepend:imx-generic-bsp := "${THISDIR}/${PN}/imx-generic-bsp:" |
2 | FILESEXTRAPATHS:prepend:mx6-nxp-bsp := "${THISDIR}/${PN}/imx-nxp-bsp" | ||
3 | FILESEXTRAPATHS:prepend:mx7-nxp-bsp := "${THISDIR}/${PN}/imx-nxp-bsp" | ||
4 | FILESEXTRAPATHS:prepend:mx8-nxp-bsp := "${THISDIR}/${PN}/imx-nxp-bsp" | ||
5 | FILESEXTRAPATHS:prepend:use-mainline-bsp := "${THISDIR}/${PN}/imx-nxp-bsp" | ||
6 | 2 | ||
7 | PACKAGE_ARCH:mx6-nxp-bsp = "${MACHINE_ARCH}" | 3 | # Append path for freescale layer |
8 | PACKAGE_ARCH:mx7-nxp-bsp = "${MACHINE_ARCH}" | 4 | PACKAGE_ARCH:imx-generic-bsp = "${MACHINE_ARCH}" |
9 | PACKAGE_ARCH:mx8-nxp-bsp = "${MACHINE_ARCH}" | ||
10 | PACKAGE_ARCH:use-mainline-bsp = "${MACHINE_ARCH}" | ||
diff --git a/recipes-bsp/alsa-state/alsa-state/imx-nxp-bsp/asound.conf b/recipes-bsp/alsa-state/alsa-state/imx-generic-bsp/asound.conf index c511018e..c511018e 100644 --- a/recipes-bsp/alsa-state/alsa-state/imx-nxp-bsp/asound.conf +++ b/recipes-bsp/alsa-state/alsa-state/imx-generic-bsp/asound.conf | |||
diff --git a/recipes-bsp/alsa-state/alsa-state/imx-nxp-bsp/asound.state b/recipes-bsp/alsa-state/alsa-state/imx-generic-bsp/asound.state index ace734df..ace734df 100755 --- a/recipes-bsp/alsa-state/alsa-state/imx-nxp-bsp/asound.state +++ b/recipes-bsp/alsa-state/alsa-state/imx-generic-bsp/asound.state | |||