summaryrefslogtreecommitdiffstats
path: root/meta-fsl-ppc
diff options
context:
space:
mode:
authorLiu Ting-B28495 <ting.liu@freescale.com>2015-05-01 23:53:45 +0800
committerZhenhua Luo <zhenhua.luo@freescale.com>2015-05-12 14:41:51 +0800
commitd941ab6d0a6d7862d477c53acca282efaec49d2f (patch)
treed11e763efc5c308aa2e8a0d6a1b83977b50277c4 /meta-fsl-ppc
parent60188331d9687555055246d275f3fac304d73e5c (diff)
downloadmeta-freescale-d941ab6d0a6d7862d477c53acca282efaec49d2f.tar.gz
asf: use KBUILD_OUTPUT to point to build-artifacts
In poky commit 46cdaf1, the kernel build output was put into kernel-build-artifacts, and kernel-source is kept "pristine". KERNEL_PATH points to kernel-source, while KBUILD_OUTPUT points to build-artifacts which can be used for external module build. asf Makefile tries to include the .config, use KBUILD_OUTPUT to avoid build error. Signed-off-by: Liu Ting-B28495 <ting.liu@freescale.com>
Diffstat (limited to 'meta-fsl-ppc')
-rw-r--r--meta-fsl-ppc/recipes-kernel/asf/asf_git.bb9
1 files changed, 6 insertions, 3 deletions
diff --git a/meta-fsl-ppc/recipes-kernel/asf/asf_git.bb b/meta-fsl-ppc/recipes-kernel/asf/asf_git.bb
index b3379c1a..1ca4c8ea 100644
--- a/meta-fsl-ppc/recipes-kernel/asf/asf_git.bb
+++ b/meta-fsl-ppc/recipes-kernel/asf/asf_git.bb
@@ -7,15 +7,17 @@ SRC_URI = "git://git.freescale.com/ppc/sdk/asf.git;nobranch=1"
7SRCREV = "16eb472d6b2b34c8b605a86c469611bc8ddec1c9" 7SRCREV = "16eb472d6b2b34c8b605a86c469611bc8ddec1c9"
8 8
9inherit module qoriq_build_64bit_kernel 9inherit module qoriq_build_64bit_kernel
10do_configure[depends] += "virtual/kernel:do_shared_workdir" 10
11S = "${WORKDIR}/git/asfmodule" 11S = "${WORKDIR}/git/asfmodule"
12 12
13EXTRA_OEMAKE = "CROSS_COMPILE=${TARGET_PREFIX}" 13EXTRA_OEMAKE = "CROSS_COMPILE=${TARGET_PREFIX}"
14export KERNEL_PATH = "${STAGING_KERNEL_DIR}" 14export KERNEL_PATH = "${STAGING_KERNEL_DIR}"
15
15INHIBIT_PACKAGE_STRIP = "1" 16INHIBIT_PACKAGE_STRIP = "1"
16 17
17do_configure_append (){ 18do_configure[depends] += "virtual/kernel:do_shared_workdir"
18 cp ${STAGING_KERNEL_BUILDDIR}/.config ${STAGING_KERNEL_DIR}/ 19do_configure_prepend () {
20 sed -i 's,$(KERNEL_PATH)/.config,$(KBUILD_OUTPUT)/.config,' ${S}/Makefile
19} 21}
20 22
21do_install(){ 23do_install(){
@@ -28,3 +30,4 @@ do_install(){
28 30
29FILES_${PN} += "${libexecdir} /lib/modules/${KERNEL_VERSION}/asf" 31FILES_${PN} += "${libexecdir} /lib/modules/${KERNEL_VERSION}/asf"
30RDEPENDS_${PN} += "ipsec-tools" 32RDEPENDS_${PN} += "ipsec-tools"
33