summaryrefslogtreecommitdiffstats
path: root/meta-fsl-ppc/recipes-devtools
diff options
context:
space:
mode:
authorOtavio Salvador <otavio@ossystems.com.br>2015-07-13 14:00:59 -0300
committerOtavio Salvador <otavio@ossystems.com.br>2015-07-15 15:46:20 +0000
commitc92b415d653afc55f33b6b93fb9248193bfd4fa0 (patch)
treef473cb6d92bff7654ed35decf204041c34579b67 /meta-fsl-ppc/recipes-devtools
parent8800258fd611baf2dc62c8c620a4a2fdb75ef148 (diff)
parent60ecf4f21bb60a1c83a194b6799f56dcaf094f1b (diff)
downloadmeta-freescale-c92b415d653afc55f33b6b93fb9248193bfd4fa0.tar.gz
Merge branch 'master' from multiple repositories
Repositories: meta-fsl-arm meta-fsl-ppc Signed-off-by: Otavio Salvador <otavio@ossystems.com.br>
Diffstat (limited to 'meta-fsl-ppc/recipes-devtools')
-rw-r--r--meta-fsl-ppc/recipes-devtools/qemu/qemu_fslgit.bb57
1 files changed, 57 insertions, 0 deletions
diff --git a/meta-fsl-ppc/recipes-devtools/qemu/qemu_fslgit.bb b/meta-fsl-ppc/recipes-devtools/qemu/qemu_fslgit.bb
new file mode 100644
index 00000000..32e738e9
--- /dev/null
+++ b/meta-fsl-ppc/recipes-devtools/qemu/qemu_fslgit.bb
@@ -0,0 +1,57 @@
1require recipes-devtools/qemu/qemu.inc
2
3LIC_FILES_CHKSUM = "file://COPYING;md5=441c28d2cf86e15a37fa47e15a72fbac \
4 file://COPYING.LIB;endline=24;md5=c04def7ae38850e7d3ef548588159913"
5
6# This means QEMU v1.7 with FSL specific patches applied
7PV = "1.7+fsl"
8
9# NOTE: these options are note available in qemu 1.7, but qemu.inc assumes
10# version 2.0+ where they are available. For now we unset them, but we should
11# remove the following lines when upgrading to qemu 2.0+:
12PACKAGECONFIG[quorum] = ""
13PACKAGECONFIG[lzo] = ""
14PACKAGECONFIG[numa] = ""
15PACKAGECONFIG[gtk+] = ""
16
17SRC_URI = "git://git.freescale.com/ppc/sdk/qemu.git;nobranch=1"
18SRCREV = "6ac4597c059d35e2737b234747243e56d340f4db"
19
20S = "${WORKDIR}/git"
21
22QEMU_TARGETS = "ppc"
23PPC_OECONF = '${SDL} --cross-prefix=${TARGET_PREFIX} --disable-werror --disable-vnc --disable-bluez --disable-curl --enable-libusb'
24EXTRA_OECONF_e5500-64b = "--target-list=ppc64-softmmu ${PPC_OECONF}"
25EXTRA_OECONF_e6500-64b = "--target-list=ppc64-softmmu ${PPC_OECONF}"
26EXTRA_OECONF_e6500 = "--target-list=ppc64-softmmu ${PPC_OECONF}"
27EXTRA_OECONF_e5500 = "--target-list=ppc64-softmmu ${PPC_OECONF}"
28EXTRA_OECONF_e500v2 = "--target-list=ppc-softmmu ${PPC_OECONF}"
29EXTRA_OECONF_e500mc = "--target-list=ppc-softmmu ${PPC_OECONF}"
30
31do_configure_prepend() {
32 export PKG_CONFIG=${STAGING_DIR_NATIVE}${bindir_native}/pkg-config
33}
34
35do_configure_append () {
36 grep 'CONFIG_FDT=y' config-host.mak
37}
38
39# gets around qemu.inc trying to install powerpc_rom.bin
40do_install_prepend() {
41 touch ${WORKDIR}/powerpc_rom.bin
42}
43
44do_install_append() {
45 rm ${WORKDIR}/powerpc_rom.bin
46 # Prevent QA warnings about installed ${localstatedir}/run
47 if [ -d ${D}${localstatedir}/run ]; then rmdir ${D}${localstatedir}/run; fi
48}
49
50INSANE_SKIP_${PN} += "dev-deps"
51
52# This is only meant to be build to run on the target
53# for the given arch types listed, otherwise don't let
54# the package get built. COMPATIBLE_HOST would not work
55# because it was too generic
56COMPATIBLE_MACHINE = "a^"
57COMPATIBLE_MACHINE_libc-glibc_qoriq-ppc = ".*"