summaryrefslogtreecommitdiffstats
path: root/meta-fsl-ppc/recipes-connectivity/openssl/openssl_1.0.1i.bbappend
diff options
context:
space:
mode:
authorOtavio Salvador <otavio@ossystems.com.br>2015-07-13 14:00:59 -0300
committerOtavio Salvador <otavio@ossystems.com.br>2015-07-15 15:46:20 +0000
commitc92b415d653afc55f33b6b93fb9248193bfd4fa0 (patch)
treef473cb6d92bff7654ed35decf204041c34579b67 /meta-fsl-ppc/recipes-connectivity/openssl/openssl_1.0.1i.bbappend
parent8800258fd611baf2dc62c8c620a4a2fdb75ef148 (diff)
parent60ecf4f21bb60a1c83a194b6799f56dcaf094f1b (diff)
downloadmeta-freescale-c92b415d653afc55f33b6b93fb9248193bfd4fa0.tar.gz
Merge branch 'master' from multiple repositories
Repositories: meta-fsl-arm meta-fsl-ppc Signed-off-by: Otavio Salvador <otavio@ossystems.com.br>
Diffstat (limited to 'meta-fsl-ppc/recipes-connectivity/openssl/openssl_1.0.1i.bbappend')
-rw-r--r--meta-fsl-ppc/recipes-connectivity/openssl/openssl_1.0.1i.bbappend60
1 files changed, 60 insertions, 0 deletions
diff --git a/meta-fsl-ppc/recipes-connectivity/openssl/openssl_1.0.1i.bbappend b/meta-fsl-ppc/recipes-connectivity/openssl/openssl_1.0.1i.bbappend
new file mode 100644
index 00000000..89d7339a
--- /dev/null
+++ b/meta-fsl-ppc/recipes-connectivity/openssl/openssl_1.0.1i.bbappend
@@ -0,0 +1,60 @@
1FILESEXTRAPATHS_prepend := "${THISDIR}/openssl-fsl:"
2
3RDEPENDS_${PN}_class-target += "cryptodev-module"
4
5# base package is taken from Freescale repository
6SRCBRANCH = "OpenSSL_1_0_1-stable"
7SRC_URI = "git://git.openssl.org/openssl.git;branch=${SRCBRANCH} \
8 file://0001-remove-double-initialization-of-cryptodev-engine.patch \
9 file://0002-eng_cryptodev-add-support-for-TLS-algorithms-offload.patch \
10 file://0003-cryptodev-fix-algorithm-registration.patch \
11 file://0004-linux-pcc-make-it-more-robust-and-recognize-KERNEL_B.patch \
12 file://0005-ECC-Support-header-for-Cryptodev-Engine.patch \
13 file://0006-Fixed-private-key-support-for-DH.patch \
14 file://0007-Fixed-private-key-support-for-DH.patch \
15 file://0008-Initial-support-for-PKC-in-cryptodev-engine.patch \
16 file://0009-Added-hwrng-dev-file-as-source-of-RNG.patch \
17 file://0010-Asynchronous-interface-added-for-PKC-cryptodev-inter.patch \
18 file://0011-Add-RSA-keygen-operation-and-support-gendsa-command-.patch \
19 file://0012-RSA-Keygen-Fix.patch \
20 file://0013-Removed-local-copy-of-curve_t-type.patch \
21 file://0014-Modulus-parameter-is-not-populated-by-dhparams.patch \
22 file://0015-SW-Backoff-mechanism-for-dsa-keygen.patch \
23 file://0016-Fixed-DH-keygen-pair-generator.patch \
24 file://0017-cryptodev-add-support-for-aes-gcm-algorithm-offloadi.patch \
25"
26SRCREV = "2b456034457b58454aae3998a2765b6a5b9bc837"
27
28SRC_URI += "file://configure-targets.patch \
29 file://shared-libs.patch \
30 file://oe-ldflags.patch \
31 file://engines-install-in-libdir-ssl.patch \
32 file://openssl-fix-link.patch \
33 file://debian/version-script.patch \
34 file://debian/pic.patch \
35 file://debian/c_rehash-compat.patch \
36 file://debian/ca.patch \
37 file://debian/make-targets.patch \
38 file://debian/no-rpath.patch \
39 file://debian/man-dir.patch \
40 file://debian/man-section.patch \
41 file://debian/no-symbolic.patch \
42 file://debian/debian-targets.patch \
43 file://openssl_fix_for_x32.patch \
44 file://fix-cipher-des-ede3-cfb1.patch \
45 file://openssl-avoid-NULL-pointer-dereference-in-EVP_DigestInit_ex.patch \
46 file://openssl-avoid-NULL-pointer-dereference-in-dh_pub_encode.patch \
47 file://initial-aarch64-bits.patch \
48 file://find.pl \
49 file://openssl-fix-des.pod-error.patch \
50 "
51S = "${WORKDIR}/git"
52
53# Digest offloading through cryptodev is not recommended because of the
54# performance penalty of the Openssl engine interface. Openssl generates a huge
55# number of calls to digest functions for even a small amount of work data.
56# For example there are 70 calls to cipher code and over 10000 to digest code
57# when downloading only 10 files of 700 bytes each.
58# Do not build OpenSSL with cryptodev digest support until engine digest
59# interface gets some rework:
60CFLAG := "${@'${CFLAG}'.replace('-DUSE_CRYPTODEV_DIGESTS', '')}"