summaryrefslogtreecommitdiffstats
path: root/meta-fsl-arm/recipes-bsp/u-boot
diff options
context:
space:
mode:
authorOtavio Salvador <otavio@ossystems.com.br>2014-09-01 11:20:34 -0300
committerOtavio Salvador <otavio@ossystems.com.br>2014-09-01 12:18:36 -0300
commit21eab88a14d84801fcd532e20130ad7fec07b4a7 (patch)
tree9d4df5c28a912a9c635dd284634e05a22e2f7004 /meta-fsl-arm/recipes-bsp/u-boot
parent4748ed0ada4238ccfee310fa0f9c3007d01892a9 (diff)
downloadmeta-freescale-21eab88a14d84801fcd532e20130ad7fec07b4a7.tar.gz
u-boot-imx: Use the new fsl-u-boot-localversion class
This uses the new class for LOCALVERSION handling. The local version is set for '+imx' by default but can be overriden by users of this .inc file. While on that move the PACKAGE_ARCH setting, in the 2009.08 recipe, to the end of file, as done on other recipes. Change-Id: Ic7e26635908cefe28c340cd9885e1efa0a009a16 Signed-off-by: Otavio Salvador <otavio@ossystems.com.br>
Diffstat (limited to 'meta-fsl-arm/recipes-bsp/u-boot')
-rw-r--r--meta-fsl-arm/recipes-bsp/u-boot/u-boot-imx_2009.08.bb5
-rw-r--r--meta-fsl-arm/recipes-bsp/u-boot/u-boot-imx_2013.04.bb4
2 files changed, 8 insertions, 1 deletions
diff --git a/meta-fsl-arm/recipes-bsp/u-boot/u-boot-imx_2009.08.bb b/meta-fsl-arm/recipes-bsp/u-boot/u-boot-imx_2009.08.bb
index 393e7f32..7b31cc8c 100644
--- a/meta-fsl-arm/recipes-bsp/u-boot/u-boot-imx_2009.08.bb
+++ b/meta-fsl-arm/recipes-bsp/u-boot/u-boot-imx_2009.08.bb
@@ -54,7 +54,9 @@ UBOOT_MAKE_TARGET = "u-boot.bin"
54S = "${WORKDIR}/git" 54S = "${WORKDIR}/git"
55EXTRA_OEMAKE += 'HOSTSTRIP=true' 55EXTRA_OEMAKE += 'HOSTSTRIP=true'
56 56
57PACKAGE_ARCH = "${MACHINE_ARCH}" 57inherit fsl-u-boot-localversion
58
59LOCALVERSION = "+imx"
58 60
59do_compile_prepend() { 61do_compile_prepend() {
60 if [ "${@base_contains('DISTRO_FEATURES', 'ld-is-gold', 'ld-is-gold', '', d)}" = "ld-is-gold" ] ; then 62 if [ "${@base_contains('DISTRO_FEATURES', 'ld-is-gold', 'ld-is-gold', '', d)}" = "ld-is-gold" ] ; then
@@ -63,3 +65,4 @@ do_compile_prepend() {
63} 65}
64 66
65COMPATIBLE_MACHINE = "(imx28evk|mx5|mx6)" 67COMPATIBLE_MACHINE = "(imx28evk|mx5|mx6)"
68PACKAGE_ARCH = "${MACHINE_ARCH}"
diff --git a/meta-fsl-arm/recipes-bsp/u-boot/u-boot-imx_2013.04.bb b/meta-fsl-arm/recipes-bsp/u-boot/u-boot-imx_2013.04.bb
index 1c0f828e..867f0edd 100644
--- a/meta-fsl-arm/recipes-bsp/u-boot/u-boot-imx_2013.04.bb
+++ b/meta-fsl-arm/recipes-bsp/u-boot/u-boot-imx_2013.04.bb
@@ -14,5 +14,9 @@ SRCREV = "ce0ea2507c492d43bbf88f8609482a171b2d2003"
14 14
15S = "${WORKDIR}/git" 15S = "${WORKDIR}/git"
16 16
17inherit fsl-u-boot-localversion
18
19LOCALVERSION = "+imx"
20
17PACKAGE_ARCH = "${MACHINE_ARCH}" 21PACKAGE_ARCH = "${MACHINE_ARCH}"
18COMPATIBLE_MACHINE = "(mx6)" 22COMPATIBLE_MACHINE = "(mx6)"