diff options
author | Otavio Salvador <otavio@ossystems.com.br> | 2016-09-06 11:59:55 -0300 |
---|---|---|
committer | Otavio Salvador <otavio@ossystems.com.br> | 2016-09-08 11:24:25 -0300 |
commit | 2ce6ca4ec44bf72bc6b1b6e53e04209edb7b9e70 (patch) | |
tree | edad729f14f4edf6120d9d25dd6e46adeb24107d /dynamic-layers | |
parent | ad657765bc4c0cef6cb7a86165c813d3bee3cd2f (diff) | |
download | meta-freescale-2ce6ca4ec44bf72bc6b1b6e53e04209edb7b9e70.tar.gz |
qtbase: Enable support for i.MX SoCs with PXP
This enables the use of GLES2 backend for Software Rendering allowing
SoCs without GPU support to use it. Up to now, this includes i.MX6UL
and i.MX7D.
Change-Id: I3011a84198d42744639121394423106fcfc738b3
Signed-off-by: Otavio Salvador <otavio@ossystems.com.br>
Diffstat (limited to 'dynamic-layers')
-rw-r--r-- | dynamic-layers/qt5-layer/recipes-qt/qt5/qtbase_%.bbappend | 2 |
1 files changed, 2 insertions, 0 deletions
diff --git a/dynamic-layers/qt5-layer/recipes-qt/qt5/qtbase_%.bbappend b/dynamic-layers/qt5-layer/recipes-qt/qt5/qtbase_%.bbappend index 3b998867..a693fb2a 100644 --- a/dynamic-layers/qt5-layer/recipes-qt/qt5/qtbase_%.bbappend +++ b/dynamic-layers/qt5-layer/recipes-qt/qt5/qtbase_%.bbappend | |||
@@ -6,10 +6,12 @@ HAS_X11 = "${@bb.utils.contains('DISTRO_FEATURES', 'x11', 1, 0, d)}" | |||
6 | IMXGPU_imxgpu3d = "3d" | 6 | IMXGPU_imxgpu3d = "3d" |
7 | IMXGPU_imxgpu2d = "2d" | 7 | IMXGPU_imxgpu2d = "2d" |
8 | 8 | ||
9 | PACKAGECONFIG_GL_imxpxp = "gles2" | ||
9 | PACKAGECONFIG_GL_imxgpu3d = "gles2" | 10 | PACKAGECONFIG_GL_imxgpu3d = "gles2" |
10 | PACKAGECONFIG_GL_imxgpu2d = "${@bb.utils.contains('DISTRO_FEATURES', 'x11', ' gl', '', d)}" | 11 | PACKAGECONFIG_GL_imxgpu2d = "${@bb.utils.contains('DISTRO_FEATURES', 'x11', ' gl', '', d)}" |
11 | 12 | ||
12 | QT_CONFIG_FLAGS_APPEND = "" | 13 | QT_CONFIG_FLAGS_APPEND = "" |
14 | QT_CONFIG_FLAGS_APPEND_imxpxp = "${@base_contains('DISTRO_FEATURES', 'x11', ' -no-eglfs', ' -eglfs', d)}" | ||
13 | QT_CONFIG_FLAGS_APPEND_imxgpu2d = "${@bb.utils.contains('DISTRO_FEATURES', 'x11', ' -no-eglfs', ' -no-opengl -linuxfb -no-eglfs', d)}" | 15 | QT_CONFIG_FLAGS_APPEND_imxgpu2d = "${@bb.utils.contains('DISTRO_FEATURES', 'x11', ' -no-eglfs', ' -no-opengl -linuxfb -no-eglfs', d)}" |
14 | QT_CONFIG_FLAGS_APPEND_imxgpu3d = "${@bb.utils.contains('DISTRO_FEATURES', 'x11', ' -no-eglfs', ' -eglfs', d)}" | 16 | QT_CONFIG_FLAGS_APPEND_imxgpu3d = "${@bb.utils.contains('DISTRO_FEATURES', 'x11', ' -no-eglfs', ' -eglfs', d)}" |
15 | QT_CONFIG_FLAGS_append = " ${QT_CONFIG_FLAGS_APPEND}" | 17 | QT_CONFIG_FLAGS_append = " ${QT_CONFIG_FLAGS_APPEND}" |