summaryrefslogtreecommitdiffstats
path: root/dynamic-layers
diff options
context:
space:
mode:
authorOtavio Salvador <otavio@ossystems.com.br>2015-07-15 17:21:16 -0300
committerOtavio Salvador <otavio@ossystems.com.br>2015-07-16 15:01:29 -0300
commitca38cdc4de1143cf6b7af76e9426ecf31f0922f0 (patch)
tree01db34465457c4b22036f27dba53d55f01ef6d03 /dynamic-layers
parentb6e2300960729d67720e1e626051999ca7a7009f (diff)
downloadmeta-freescale-ca38cdc4de1143cf6b7af76e9426ecf31f0922f0.tar.gz
Move external layer's specific changes for 'dynamic-layers' subdir
The external layer's specific changes are now in the 'dynamic-layers' subdirectory. This approach ease the identification of layer specific recipes and extensions as all those are more visible isolated of the main layer components. Signed-off-by: Otavio Salvador <otavio@ossystems.com.br>
Diffstat (limited to 'dynamic-layers')
-rw-r--r--dynamic-layers/browser-layer/recipes-browser/chromium/chromium-imx.inc49
-rw-r--r--dynamic-layers/browser-layer/recipes-browser/chromium/chromium_40.0.2214.91.bbappend12
-rw-r--r--dynamic-layers/efl-layer/recipes-efl/efl/efl/0001-Add-preprocessor-definitions-for-Vivante-GLES-header.patch55
-rw-r--r--dynamic-layers/efl-layer/recipes-efl/efl/efl_%.bbappend3
-rw-r--r--dynamic-layers/openembedded-layer/recipes-benchmark/glmark2/glmark2_%.bbappend3
-rw-r--r--dynamic-layers/openembedded-layer/recipes-kernel/asf/asf_git.bb33
-rw-r--r--dynamic-layers/openembedded-layer/recipes-support/opencv/opencv/0001-MGS-515-ccc-Opencv-app-can-t-run-on-imx6sx-with-cam.patch46
-rw-r--r--dynamic-layers/openembedded-layer/recipes-support/opencv/opencv_%.bbappend3
-rw-r--r--dynamic-layers/qt5-layer/recipes-qt/qt5/qtbase/Force_egl_visual_ID_33.patch23
-rw-r--r--dynamic-layers/qt5-layer/recipes-qt/qt5/qtbase_%.bbappend79
-rw-r--r--dynamic-layers/qt5-layer/recipes-qt/qt5/qtwebkit/0001-Fix-to-match-the-uniform-precision-qualifiers-in-ver.patch42
-rw-r--r--dynamic-layers/qt5-layer/recipes-qt/qt5/qtwebkit_%.bbappend4
12 files changed, 352 insertions, 0 deletions
diff --git a/dynamic-layers/browser-layer/recipes-browser/chromium/chromium-imx.inc b/dynamic-layers/browser-layer/recipes-browser/chromium/chromium-imx.inc
new file mode 100644
index 00000000..f63807d5
--- /dev/null
+++ b/dynamic-layers/browser-layer/recipes-browser/chromium/chromium-imx.inc
@@ -0,0 +1,49 @@
1DEPENDS_append_mx6q = " libfslvpuwrap"
2DEPENDS_append_mx6dl = " libfslvpuwrap"
3
4# Additional imx code and patches are included in the chromium-imx git repository.
5# The code below fetches this repository, copies the extra source over to the main
6# chromium source directory, and applies the patches.
7
8CHROMIUM_IMX_BRANCH ?= "master"
9CHROMIUM_IMX_SRCREV ?= "HEAD"
10CHROMIUM_IMX_DESTSUFFIX ?= "chromium-imx-git"
11
12PATCH_BASE_DIR = "${WORKDIR}/${CHROMIUM_IMX_DESTSUFFIX}/patches"
13
14CHROMIUM_IMX_COMMON_PATCHES ?= " "
15CHROMIUM_IMX_VPU_PATCHES ?= " "
16CHROMIUM_IMX_WAYLAND_PATCHES ?= " "
17
18SRC_URI += "git://github.com/Freescale/chromium-imx.git;destsuffix=${CHROMIUM_IMX_DESTSUFFIX};branch=${CHROMIUM_IMX_BRANCH};rev=${CHROMIUM_IMX_SRCREV}"
19
20do_unpack[postfuncs] += "copy_chromium_imx_files"
21# using =+ instead of += to make sure add_chromium_imx_patches is
22# executed before add_ozone_wayland_patches in the main recipe;
23# this is necessary because add_chromium_imx_patches appends
24# patches to the OZONE_WAYLAND_EXTRA_PATCHES variable
25do_patch[prefuncs] =+ "add_chromium_imx_patches"
26
27# * Lost context problems are not known to happen with Vivante GPUs,
28# so it is safe to use ignore-lost-context
29# * EGL is on by default due to the GPU on the i.MX6
30PACKAGECONFIG_append = " use-egl ignore-lost-context"
31
32copy_chromium_imx_files() {
33 # sources in src/ are already organized in a manner
34 # that matches the subdirectories in the chromium
35 # source directory; just copy over the files in src/
36 cp -r ${WORKDIR}/chromium-imx-git/src/* ${S}/
37}
38
39python add_chromium_imx_patches() {
40 d.appendVar('SRC_URI', ' ' + d.getVar('CHROMIUM_IMX_COMMON_PATCHES', 1))
41 d.appendVar('SRC_URI', ' ' + d.getVar('CHROMIUM_IMX_VPU_PATCHES', 1))
42 d.appendVar('OZONE_WAYLAND_EXTRA_PATCHES', ' ' + d.getVar('CHROMIUM_IMX_WAYLAND_PATCHES', 1))
43}
44
45# Necessary flags to enable support for h.264 and MP4 in Chromium
46# (Parsing is done by ffmpeg)
47EXTRA_OEGYP += "-Dproprietary_codecs=1 -Dffmpeg_branding=Chrome"
48
49COMPATIBLE_MACHINE = "(mx6)"
diff --git a/dynamic-layers/browser-layer/recipes-browser/chromium/chromium_40.0.2214.91.bbappend b/dynamic-layers/browser-layer/recipes-browser/chromium/chromium_40.0.2214.91.bbappend
new file mode 100644
index 00000000..d9c5d154
--- /dev/null
+++ b/dynamic-layers/browser-layer/recipes-browser/chromium/chromium_40.0.2214.91.bbappend
@@ -0,0 +1,12 @@
1include chromium-imx.inc
2
3CHROMIUM_IMX_BRANCH = "chromium-40"
4CHROMIUM_IMX_SRCREV = "af13a3dbdfdb4b162a9f9692761216e5d6204e57"
5CHROMIUM_IMX_COMMON_PATCHES += "file://${PATCH_BASE_DIR}/common/0001-Enable-share-group-workaround-for-Vivante-GPUs.patch"
6
7VPU_PATCHES = "file://${PATCH_BASE_DIR}/common/0002-Add-VPU-video-decode-accelerator-to-Chromium-GPU-.patch"
8
9CHROMIUM_IMX_VPU_PATCHES_mx6q += "${VPU_PATCHES}"
10CHROMIUM_IMX_VPU_PATCHES_mx6dl += "${VPU_PATCHES}"
11
12CHROMIUM_IMX_WAYLAND_PATCHES += "file://${PATCH_BASE_DIR}/wayland/0001-Modify-eglwayland-versions-for-Vivante-GPUs.patch"
diff --git a/dynamic-layers/efl-layer/recipes-efl/efl/efl/0001-Add-preprocessor-definitions-for-Vivante-GLES-header.patch b/dynamic-layers/efl-layer/recipes-efl/efl/efl/0001-Add-preprocessor-definitions-for-Vivante-GLES-header.patch
new file mode 100644
index 00000000..53f0a528
--- /dev/null
+++ b/dynamic-layers/efl-layer/recipes-efl/efl/efl/0001-Add-preprocessor-definitions-for-Vivante-GLES-header.patch
@@ -0,0 +1,55 @@
1From 0775633e35127e903a1a84d823bf2e7d388d4042 Mon Sep 17 00:00:00 2001
2From: Carlos Rafael Giani <dv@pseudoterminal.org>
3Date: Sun, 1 Jun 2014 01:57:53 +0200
4Subject: [PATCH] Add preprocessor definitions for Vivante GLES headers
5
6The Vivante headers require the LINUX preprocessor definition, otherwise
7compile errors occur
8
9Upstream-Status: Pending
10
11Signed-off-by: Carlos Rafael Giani <dv@pseudoterminal.org>
12---
13 m4/evas_check_engine.m4 | 4 ++--
14 src/Makefile_Evas.am | 2 ++
15 2 files changed, 4 insertions(+), 2 deletions(-)
16
17diff --git a/m4/evas_check_engine.m4 b/m4/evas_check_engine.m4
18index 3fd4890..35d1c5f 100644
19--- a/m4/evas_check_engine.m4
20+++ b/m4/evas_check_engine.m4
21@@ -26,9 +26,9 @@ EFL_FIND_X(evas_engine_[]$1,
22 [X11 XCreateColormap Xrender XRenderCreatePicture],
23 [
24 CFLAGS_save="$CFLAGS"
25- CFLAGS="$evas_engine_[]$1[]_cflags $CFLAGS"
26+ CFLAGS="$evas_engine_[]$1[]_cflags $CFLAGS -DLINUX"
27 CPPFLAGS_save="$CPPFLAGS"
28- CPPFLAGS="$evas_engine_[]$1[]_cflags $CPPFLAGS"
29+ CPPFLAGS="$evas_engine_[]$1[]_cflags $CPPFLAGS -DLINUX"
30
31 AC_CHECK_HEADER([GL/gl.h],
32 [have_dep="yes"],
33diff --git a/src/Makefile_Evas.am b/src/Makefile_Evas.am
34index 644391b..6232f78 100644
35--- a/src/Makefile_Evas.am
36+++ b/src/Makefile_Evas.am
37@@ -632,6 +632,7 @@ lib_evas_libevas_la_LIBADD += @evas_engine_gl_common_libs@
38 else
39 noinst_LTLIBRARIES += modules/evas/engines/gl_common/libevas_engine_gl_common.la
40 modules_evas_engines_gl_common_libevas_engine_gl_common_la_SOURCES = $(GL_COMMON_SOURCES)
41+modules_evas_engines_gl_common_libevas_engine_gl_common_la_CFLAGS = -DLINUX
42 modules_evas_engines_gl_common_libevas_engine_gl_common_la_CPPFLAGS = -I$(top_builddir)/src/lib/efl \
43 -I$(top_srcdir)/src/lib/evas/include \
44 -I$(top_srcdir)/src/lib/evas/cserve2 \
45@@ -736,6 +737,7 @@ else
46 engineglx11pkgdir = $(libdir)/evas/modules/engines/gl_x11/$(MODULE_ARCH)
47 engineglx11pkg_LTLIBRARIES = modules/evas/engines/gl_x11/module.la
48 modules_evas_engines_gl_x11_module_la_SOURCES = $(GL_X11_SOURCES)
49+modules_evas_engines_gl_x11_module_la_CFLAGS = -DLINUX
50 modules_evas_engines_gl_x11_module_la_CPPFLAGS = -I$(top_builddir)/src/lib/efl \
51 -I$(top_srcdir)/src/lib/evas/include \
52 -I$(top_srcdir)/src/lib/evas/cserve2 \
53--
541.8.3.2
55
diff --git a/dynamic-layers/efl-layer/recipes-efl/efl/efl_%.bbappend b/dynamic-layers/efl-layer/recipes-efl/efl/efl_%.bbappend
new file mode 100644
index 00000000..72ef7980
--- /dev/null
+++ b/dynamic-layers/efl-layer/recipes-efl/efl/efl_%.bbappend
@@ -0,0 +1,3 @@
1FILESEXTRAPATHS_prepend := "${THISDIR}/${PN}:"
2
3SRC_URI_append_mx6 = " file://0001-Add-preprocessor-definitions-for-Vivante-GLES-header.patch"
diff --git a/dynamic-layers/openembedded-layer/recipes-benchmark/glmark2/glmark2_%.bbappend b/dynamic-layers/openembedded-layer/recipes-benchmark/glmark2/glmark2_%.bbappend
new file mode 100644
index 00000000..8e57d663
--- /dev/null
+++ b/dynamic-layers/openembedded-layer/recipes-benchmark/glmark2/glmark2_%.bbappend
@@ -0,0 +1,3 @@
1#Remove gles2 as it is not supported by sololite
2
3PACKAGECONFIG_remove_mx6sl = "gles2"
diff --git a/dynamic-layers/openembedded-layer/recipes-kernel/asf/asf_git.bb b/dynamic-layers/openembedded-layer/recipes-kernel/asf/asf_git.bb
new file mode 100644
index 00000000..7cf8f57a
--- /dev/null
+++ b/dynamic-layers/openembedded-layer/recipes-kernel/asf/asf_git.bb
@@ -0,0 +1,33 @@
1DESCRIPTION = "Non-DPAA software Application Specific Fast-path"
2SECTION = "asf"
3LICENSE = "GPLv2 & GPLv2+ & BSD"
4LIC_FILES_CHKSUM = "file://COPYING;md5=b5881ecf398da8a03a3f4c501e29d287"
5
6SRC_URI = "git://git.freescale.com/ppc/sdk/asf.git;branch=master"
7SRCREV = "62ba10ab6bab8f8f53934e4bb55b5a552bf3fd6b"
8
9inherit module
10
11S = "${WORKDIR}/git/asfmodule"
12
13EXTRA_OEMAKE = "CROSS_COMPILE=${TARGET_PREFIX}"
14export KERNEL_PATH = "${STAGING_KERNEL_DIR}"
15
16INHIBIT_PACKAGE_STRIP = "1"
17
18do_configure[depends] += "virtual/kernel:do_shared_workdir"
19do_configure_prepend () {
20 find ${S} -name Makefile -exec \
21 sed -i 's,$(KERNEL_PATH)/.config,$(KBUILD_OUTPUT)/.config,' {} \;
22}
23
24do_install(){
25 mkdir -p ${D}/${libexecdir}
26 mkdir -p ${D}/lib/modules/${KERNEL_VERSION}/asf
27 cp -rf ${S}/bin/full ${D}/lib/modules/${KERNEL_VERSION}/asf
28 cp -rf ${S}/bin/min ${D}/lib/modules/${KERNEL_VERSION}/asf
29 cp -rf ${S}/../scripts ${D}/${libexecdir}/
30}
31
32FILES_${PN} += "${libexecdir} /lib/modules/${KERNEL_VERSION}/asf"
33RDEPENDS_${PN} += "ipsec-tools"
diff --git a/dynamic-layers/openembedded-layer/recipes-support/opencv/opencv/0001-MGS-515-ccc-Opencv-app-can-t-run-on-imx6sx-with-cam.patch b/dynamic-layers/openembedded-layer/recipes-support/opencv/opencv/0001-MGS-515-ccc-Opencv-app-can-t-run-on-imx6sx-with-cam.patch
new file mode 100644
index 00000000..274fbe74
--- /dev/null
+++ b/dynamic-layers/openembedded-layer/recipes-support/opencv/opencv/0001-MGS-515-ccc-Opencv-app-can-t-run-on-imx6sx-with-cam.patch
@@ -0,0 +1,46 @@
1From 90f869763026e8ff18aeecde217d778f00e4f294 Mon Sep 17 00:00:00 2001
2From: Shawn Xiao <b49994@freescale.com>
3Date: Tue, 10 Feb 2015 16:11:59 +0800
4Subject: [PATCH] MGS-515 [#ccc] Opencv app can't run on imx6sx with cam
5
6This issue is caused by the no support of VIDIOC_QUERYCTRL ioctl
7item in latest cam driver.
8
9Modified the errno in check logic to compatible with new driver.
10
11Feb 10, 2015
12
13Upstream-Status: Pending
14
15Signed-off-by: Shawn Xiao <b49994@freescale.com>
16---
17 modules/highgui/src/cap_v4l.cpp | 6 ++++--
18 1 file changed, 4 insertions(+), 2 deletions(-)
19
20diff --git a/modules/highgui/src/cap_v4l.cpp b/modules/highgui/src/cap_v4l.cpp
21index c9fca05..8c46b6c 100644
22--- a/modules/highgui/src/cap_v4l.cpp
23+++ b/modules/highgui/src/cap_v4l.cpp
24@@ -707,7 +707,8 @@ static void v4l2_scan_controls(CvCaptureCAM_V4L* capture)
25
26 } else {
27
28- if (errno == EINVAL)
29+ if (errno == ENOTTY ||
30+ errno == EINVAL)
31 continue;
32
33 perror ("VIDIOC_QUERYCTRL");
34@@ -774,7 +775,8 @@ static void v4l2_scan_controls(CvCaptureCAM_V4L* capture)
35
36 } else {
37
38- if (errno == EINVAL)
39+ if (errno == ENOTTY ||
40+ errno == EINVAL)
41 break;
42
43 perror ("VIDIOC_QUERYCTRL");
44--
452.3.0
46
diff --git a/dynamic-layers/openembedded-layer/recipes-support/opencv/opencv_%.bbappend b/dynamic-layers/openembedded-layer/recipes-support/opencv/opencv_%.bbappend
new file mode 100644
index 00000000..be166965
--- /dev/null
+++ b/dynamic-layers/openembedded-layer/recipes-support/opencv/opencv_%.bbappend
@@ -0,0 +1,3 @@
1FILESEXTRAPATHS_prepend := "${THISDIR}/${PN}:"
2
3SRC_URI_append_mx6sx = " file://0001-MGS-515-ccc-Opencv-app-can-t-run-on-imx6sx-with-cam.patch"
diff --git a/dynamic-layers/qt5-layer/recipes-qt/qt5/qtbase/Force_egl_visual_ID_33.patch b/dynamic-layers/qt5-layer/recipes-qt/qt5/qtbase/Force_egl_visual_ID_33.patch
new file mode 100644
index 00000000..b0be292d
--- /dev/null
+++ b/dynamic-layers/qt5-layer/recipes-qt/qt5/qtbase/Force_egl_visual_ID_33.patch
@@ -0,0 +1,23 @@
1Workaround EGL initialization failure due visual mismatch
2
3Error:
4
5Warning: EGL suggested using X Visual ID 33 (RGB888) for EGL config 28 (RGB444), but this is incompatable
6Unable to find an X11 visual which matches EGL config 28
7Could not initialize EGL
8Aborted
9
10Upstream-Status: Inappropriate [workaround]
11
12Signed-off-by: Otavio Salvador <otavio@ossystems.com.br>
13
14diff -Naur qtbase-opensource-src-5.1.1_original/src/platformsupport/eglconvenience/qxlibeglintegration.cpp qtbase-opensource-src-5.1.1/src/platformsupport/eglconvenience/qxlibeglintegration.cpp
15--- qtbase-opensource-src-5.1.1_original/src/platformsupport/eglconvenience/qxlibeglintegration.cpp 2013-12-25 19:08:42.163895341 -0800
16+++ qtbase-opensource-src-5.1.1/src/platformsupport/eglconvenience/qxlibeglintegration.cpp 2013-12-25 19:09:37.207893799 -0800
17@@ -180,5 +180,5 @@
18 }
19
20 qWarning("Unable to find an X11 visual which matches EGL config %d", configId);
21- return (VisualID)0;
22+ return (VisualID)33;
23 }
diff --git a/dynamic-layers/qt5-layer/recipes-qt/qt5/qtbase_%.bbappend b/dynamic-layers/qt5-layer/recipes-qt/qt5/qtbase_%.bbappend
new file mode 100644
index 00000000..a376a838
--- /dev/null
+++ b/dynamic-layers/qt5-layer/recipes-qt/qt5/qtbase_%.bbappend
@@ -0,0 +1,79 @@
1# Copyright (C) 2013 Eric Bénard - Eukréa Electromatique
2
3FILESEXTRAPATHS_prepend := "${THISDIR}/${PN}:"
4
5SRC_URI += "file://Force_egl_visual_ID_33.patch"
6
7HAS_X11 = "${@base_contains('DISTRO_FEATURES', 'x11', 1, 0, d)}"
8
9IS_MX6SL = "0"
10IS_MX6SL_mx6sl = "1"
11
12PACKAGECONFIG_GL_mx5 = "gles2"
13QT_CONFIG_FLAGS_append_mx5 = "${@base_contains('DISTRO_FEATURES', 'x11', ' -no-eglfs', ' -eglfs', d)}"
14
15PACKAGECONFIG_GL_mx6q = "gles2"
16PACKAGECONFIG_GL_mx6dl = "gles2"
17PACKAGECONFIG_GL_mx6sx = "gles2"
18PACKAGECONFIG_GL_mx6sl = "${@base_contains('DISTRO_FEATURES', 'x11', \
19 ' gl', '', d)}"
20QT_CONFIG_FLAGS_append_mx6q = "${@base_contains('DISTRO_FEATURES', 'x11', ' -no-eglfs', ' -eglfs', d)}"
21QT_CONFIG_FLAGS_append_mx6dl = "${@base_contains('DISTRO_FEATURES', 'x11', ' -no-eglfs', ' -eglfs', d)}"
22QT_CONFIG_FLAGS_append_mx6sx = "${@base_contains('DISTRO_FEATURES', 'x11', ' -no-eglfs', ' -eglfs', d)}"
23QT_CONFIG_FLAGS_append_mx6sl = "${@base_contains('DISTRO_FEATURES', 'x11', \
24 ' -no-eglfs', ' -no-opengl -linuxfb -no-eglfs', d)}"
25
26do_configure_prepend_mx5() {
27 sed -i 's!load(qt_config)!!' ${S}/mkspecs/linux-oe-g++/qmake.conf
28
29 cat >> ${S}/mkspecs/linux-oe-g++/qmake.conf <<EOF
30IMX5_CFLAGS = -D_LINUX=1
31QMAKE_LIBS_EGL += -lEGL
32QMAKE_LIBS_OPENGL_ES2 += -lGLESv2 -lEGL
33QMAKE_LIBS_OPENVG += -lOpenVG -lEGL
34
35QMAKE_CFLAGS_RELEASE += \$\$IMX5_CFLAGS
36QMAKE_CXXFLAGS_RELEASE += \$\$IMX5_CFLAGS
37QMAKE_CFLAGS_DEBUG += \$\$IMX5_CFLAGS
38QMAKE_CXXFLAGS_DEBUG += \$\$IMX5_CFLAGS
39
40load(qt_config)
41
42EOF
43}
44
45do_configure_prepend_mx6() {
46 # adapt qmake.conf to our needs
47 sed -i 's!load(qt_config)!!' ${S}/mkspecs/linux-oe-g++/qmake.conf
48 if test ${HAS_X11} -eq 0; then
49 if test ${IS_MX6SL} -eq 0; then
50
51 cat >> ${S}/mkspecs/linux-oe-g++/qmake.conf <<EOF
52EGLFS_PLATFORM_HOOKS_SOURCES = \$\$PWD/qeglfshooks_imx6.cpp
53IMX6_CFLAGS = -DLINUX=1 -DEGL_API_FB=1
54EOF
55 else
56cat >> ${S}/mkspecs/linux-oe-g++/qmake.conf <<EOF
57IMX6_CFLAGS = -DLINUX=1
58EOF
59fi
60 # copy the hook in the mkspecs directory OE is using
61 cp ${S}/mkspecs/devices/linux-imx6-g++/qeglfshooks_imx6.cpp ${S}/mkspecs/linux-oe-g++/
62 else
63 cat >> ${S}/mkspecs/linux-oe-g++/qmake.conf <<EOF
64IMX6_CFLAGS = -DLINUX=1
65EOF
66 fi
67 cat >> ${S}/mkspecs/linux-oe-g++/qmake.conf <<EOF
68QMAKE_LIBS_EGL += -lEGL
69QMAKE_LIBS_OPENGL_ES2 += -lGLESv2 -lEGL -lGAL
70QMAKE_LIBS_OPENVG += -lOpenVG -lEGL -lGAL
71QMAKE_CFLAGS_RELEASE += \$\$IMX6_CFLAGS
72QMAKE_CXXFLAGS_RELEASE += \$\$IMX6_CFLAGS
73QMAKE_CFLAGS_DEBUG += \$\$IMX6_CFLAGS
74QMAKE_CXXFLAGS_DEBUG += \$\$IMX6_CFLAGS
75
76load(qt_config)
77
78EOF
79}
diff --git a/dynamic-layers/qt5-layer/recipes-qt/qt5/qtwebkit/0001-Fix-to-match-the-uniform-precision-qualifiers-in-ver.patch b/dynamic-layers/qt5-layer/recipes-qt/qt5/qtwebkit/0001-Fix-to-match-the-uniform-precision-qualifiers-in-ver.patch
new file mode 100644
index 00000000..80e55c7f
--- /dev/null
+++ b/dynamic-layers/qt5-layer/recipes-qt/qt5/qtwebkit/0001-Fix-to-match-the-uniform-precision-qualifiers-in-ver.patch
@@ -0,0 +1,42 @@
1From 66dab98c3f42eb70a4c6761a8694e374b8578e99 Mon Sep 17 00:00:00 2001
2From: Prabhu Sundararaj <prabhu.sundararaj@freescale.com>
3Date: Thu, 8 May 2014 09:27:04 -0700
4Subject: [PATCH] Fix to match the uniform precision qualifiers in vertex and
5 fragment shaders
6
7When the vertex and fragment shaders are linked together, then they will
8share a single global uniform name space. Hence, types and precisions of
9uniforms with the same name must match across all shaders that are linked
10into a single executable.
11
12As per GLSL_ES_Specification_3.00.3.pdf
13Page 124 12.3 Numeric Precision
14The fragment language has no default precision qualifier for floating point types.
15Hence for float, floating point vector and matrix variable declarations, either
16the declaration must include a precision qualifier or the default float
17precision must have been previously declared.
18
19Upstream-Status: Submitted [https://bugs.webkit.org/show_bug.cgi?id=124653#c9]
20
21Change-Id: I4eb3363b3bca8bc3c839212ec7c966201a3e65e2
22Signed-off-by: Prabhu Sundararaj <prabhu.sundararaj@freescale.com>
23---
24 Source/WebCore/platform/graphics/texmap/TextureMapperShaderProgram.cpp | 2 +-
25 1 file changed, 1 insertion(+), 1 deletion(-)
26
27diff --git a/Source/WebCore/platform/graphics/texmap/TextureMapperShaderProgram.cpp b/Source/WebCore/platform/graphics/texmap/TextureMapperShaderProgram.cpp
28index f4b9a7e..7e991bf 100644
29--- a/Source/WebCore/platform/graphics/texmap/TextureMapperShaderProgram.cpp
30+++ b/Source/WebCore/platform/graphics/texmap/TextureMapperShaderProgram.cpp
31@@ -208,7 +208,7 @@ static const char* fragmentTemplate =
32 ANTIALIASING_TEX_COORD_DIRECTIVE
33 BLUR_CONSTANTS
34 STRINGIFY(
35- precision mediump float;
36+ precision highp float;
37 uniform SamplerType s_sampler;
38 uniform sampler2D s_contentTexture;
39 uniform float u_opacity;
40--
411.9.1
42
diff --git a/dynamic-layers/qt5-layer/recipes-qt/qt5/qtwebkit_%.bbappend b/dynamic-layers/qt5-layer/recipes-qt/qt5/qtwebkit_%.bbappend
new file mode 100644
index 00000000..5d961e64
--- /dev/null
+++ b/dynamic-layers/qt5-layer/recipes-qt/qt5/qtwebkit_%.bbappend
@@ -0,0 +1,4 @@
1FILESEXTRAPATHS_prepend := "${THISDIR}/${PN}:"
2
3SRC_URI += "file://0001-Fix-to-match-the-uniform-precision-qualifiers-in-ver.patch"
4