summaryrefslogtreecommitdiffstats
path: root/dynamic-layers
diff options
context:
space:
mode:
authorChunrong Guo <chunrong.guo@nxp.com>2018-01-31 12:46:24 +0800
committerOtavio Salvador <otavio@ossystems.com.br>2018-02-06 10:02:16 -0200
commit164a5cee63513e00f1a76213ad0c5cfd7c8353bf (patch)
tree5ca569a4701660aff4a3ff9f523e12152cce6577 /dynamic-layers
parent422e786fb8ebeff42272009862bfb9c9a023c07b (diff)
downloadmeta-freescale-164a5cee63513e00f1a76213ad0c5cfd7c8353bf.tar.gz
asf: remove
This pkg will not be supported anymore. Signed-off-by: Chunrong Guo <chunrong.guo@nxp.com> Signed-off-by: Otavio Salvador <otavio@ossystems.com.br>
Diffstat (limited to 'dynamic-layers')
-rw-r--r--dynamic-layers/networking-layer/recipes-kernel/asf/asf_git.bb39
1 files changed, 0 insertions, 39 deletions
diff --git a/dynamic-layers/networking-layer/recipes-kernel/asf/asf_git.bb b/dynamic-layers/networking-layer/recipes-kernel/asf/asf_git.bb
deleted file mode 100644
index cc6629b8..00000000
--- a/dynamic-layers/networking-layer/recipes-kernel/asf/asf_git.bb
+++ /dev/null
@@ -1,39 +0,0 @@
1DESCRIPTION = "Non-DPAA software Application Specific Fast-path"
2SECTION = "asf"
3LICENSE = "GPLv2 & GPLv2+ & BSD"
4LIC_FILES_CHKSUM = "file://COPYING;md5=b5881ecf398da8a03a3f4c501e29d287"
5
6SRC_URI = "git://git.freescale.com/ppc/sdk/asf.git;branch=sdk-v2.0.x"
7SRCREV = "a8bbba6c2fd23bd79446c0ee62e352bfed528fb4"
8
9RDEPENDS_${PN} += "ipsec-tools"
10
11inherit module qoriq_build_64bit_kernel
12
13S = "${WORKDIR}/git/asfmodule"
14
15EXTRA_OEMAKE = "CROSS_COMPILE=${TARGET_PREFIX}"
16export KERNEL_PATH = "${STAGING_KERNEL_DIR}"
17
18INHIBIT_PACKAGE_STRIP = "1"
19
20do_configure[depends] += "virtual/kernel:do_shared_workdir"
21do_configure_prepend () {
22 find ${S} -name Makefile -exec \
23 sed -i 's,$(KERNEL_PATH)/.config,$(KBUILD_OUTPUT)/.config,' {} \;
24}
25
26do_install(){
27 install -d ${D}/${libexecdir}
28 install -d ${D}/lib/modules/${KERNEL_VERSION}/asf
29 cp -rf ${S}/bin/full ${D}/lib/modules/${KERNEL_VERSION}/asf
30 cp -rf ${S}/bin/min ${D}/lib/modules/${KERNEL_VERSION}/asf
31 cp -rf ${S}/../scripts ${D}/${libexecdir}/
32 find ${D}/lib -depth -type d -exec rmdir --ignore-fail-on-non-empty {} \;
33}
34
35FILES_${PN} += "${libexecdir}"
36
37COMPATIBLE_MACHINE = "(qoriq)"
38PACKAGE_ARCH = "${MACHINE_SOCARCH}"
39